Bug 197766 - KeyError: 'partitionobjinit' when using Kickstart
KeyError: 'partitionobjinit' when using Kickstart
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
: Reopened
Depends On:
Blocks: 537889
  Show dependency treegraph
 
Reported: 2006-07-06 03:25 EDT by Felix Schwarz
Modified: 2009-11-16 12:17 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 537889 (view as bug list)
Environment:
Last Closed: 2006-08-11 13:49:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error log (58.54 KB, text/plain)
2006-07-06 03:25 EDT, Felix Schwarz
no flags Details
Kickstart configuration (806 bytes, text/plain)
2006-07-06 03:31 EDT, Felix Schwarz
no flags Details
correct error log (57.18 KB, text/plain)
2006-07-12 14:53 EDT, Felix Schwarz
no flags Details
stack trace (62.64 KB, text/plain)
2006-08-08 15:28 EDT, Felix Schwarz
no flags Details

  None (edit)
Description Felix Schwarz 2006-07-06 03:25:50 EDT
Description of problem:
I'm using Kickstart + VNC to install a new computer. With my kickstart settings,
the first screen shows the partitioning scheme selection ("use standard
partitioning scheme" etc).

The back button is enabled. If I click on that back button, Anaconda gets a
KeyError and the installation is being aborted.

I am using the standard FC5 files, no modifications.

How reproducible: Always

Steps to Reproduce:
1. Boot with the attached Kickstart files (kernel append line is
"ks=hd:hda2:/newsroot/ks.cfg"
2. Connect with VNC
3. Klick on the Back button
  
Actual results:
Installation is aborted.

Expected results:
Back button is disabled.
Comment 1 Felix Schwarz 2006-07-06 03:25:50 EDT
Created attachment 131977 [details]
Error log
Comment 2 Felix Schwarz 2006-07-06 03:31:51 EDT
Created attachment 131978 [details]
Kickstart configuration
Comment 3 Jeremy Katz 2006-07-10 20:24:35 EDT
Did you regenerate your installer repository?  It looks like a malformed repo.
Comment 4 Felix Schwarz 2006-07-12 14:52:14 EDT
Sorry, I messed up with the log files. This log files belongs to another bug
where I indeed had incorrect repository data.

This bug still happens even with correct data. New attachment will follow in a
minute.
Comment 5 Felix Schwarz 2006-07-12 14:53:54 EDT
Created attachment 132324 [details]
correct error log

This times, you can see the real error. .-)
Comment 6 Chris Lumens 2006-07-13 14:55:09 EDT
Lots of dispatcher work post-FC5.  This should be fixed now.
Comment 7 Felix Schwarz 2006-08-08 15:25:01 EDT
Not fixed in FC6 Test 2. Changing version to fc6test2. Reopening.
Comment 8 Felix Schwarz 2006-08-08 15:28:17 EDT
Created attachment 133820 [details]
stack trace
Comment 9 Chris Lumens 2006-08-11 13:49:55 EDT
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.