Bug 197774 - Bond0 always have the same ipv6 link LocalAddress.
Bond0 always have the same ipv6 link LocalAddress.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Graf
Brian Brock
:
Depends On:
Blocks: 176344 198694
  Show dependency treegraph
 
Reported: 2006-07-06 05:14 EDT by Jose Plans
Modified: 2014-06-18 04:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-07 01:40:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch from <kmori@redhat.com> (580 bytes, patch)
2006-07-06 05:14 EDT, Jose Plans
no flags Details | Diff
Fix patch (3.58 KB, patch)
2006-07-18 06:02 EDT, Keiichi Mori
no flags Details | Diff
delay_ipv6dev_init.patch (5.61 KB, patch)
2006-08-13 21:08 EDT, Keiichi Mori
no flags Details | Diff
bonding_support_carrier_state.patch (6.92 KB, patch)
2006-08-13 21:10 EDT, Keiichi Mori
no flags Details | Diff

  None (edit)
Description Jose Plans 2006-07-06 05:14:03 EDT
[Environments]
RHEL4 Update3
kernel-2.6.9-34.EL
initscripts-7.93.24.EL-1.1

[Descriptions]
A bonding interface always has the same IPv6 Link LocalAddress
"fe80::200:ff:fe00:0/64". And this could be the cause of a problem if
there are multiple bonding interfaces on one segment.

When executing "ip link set dev bond0 up" in the script "/sbin/ifup",
"fe80::200:ff:fe00:0/64" is set as the Link LocalAddress of the bonding
interface because it does not have a MAC address yet.

The MAC address of first slave interface should be set as it of the
bonding interface before executing "ip link set dev bond0 up" in the
script "/sbin/ifup".

[Suggested solution]
Would it make sense to setup ifcfg-bond0 with MACADDR="xxxxx.." and tell the
bonding device we are going to use that MAC address ? 
(/sbin/ip link set dev bond0 address $MACADDR)

Attached is a suggested patch,
Comment 1 Jose Plans 2006-07-06 05:14:04 EDT
Created attachment 131985 [details]
Patch from <kmori@redhat.com>
Comment 2 Bill Nottingham 2006-07-06 11:11:53 EDT
I'm not sure that's the right answer, because it would require changing the
bond0 configuration potentially every time you change the slaves.
Comment 3 Keiichi Mori 2006-07-18 05:58:10 EDT
I found the fix patch on this issue in upstream:
http://kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=3c21edbd113788b110116141c8078623a0900b6a;hp=8de3351e6e0a1081fbf6864ae37839e327699a08

I have confirmed that this change creates link-local addresses for bonding devices.

Comment 4 Keiichi Mori 2006-07-18 06:02:10 EDT
Created attachment 132592 [details]
Fix patch

Backported from upstream to RHEL4 kernel.
applied to kernel-2.6.9-40.EL and confirmed the fix.
Comment 6 Bill Nottingham 2006-07-18 14:52:08 EDT
Bouncing to the kernel.
Comment 9 Keiichi Mori 2006-07-21 03:34:06 EDT
My patch in #4 was not enough to solve this issue, unfortunately.
If IPV6ADDR is set in ifcfg-bondX, that patch does not work.
Also, it causes deadlock issue when restart network interfaces,
like "service network restart".

Comment 10 Keiichi Mori 2006-07-21 05:05:08 EDT
This issue does not happen on RHEL5 Alpha (kernel-2.6.16-1.2290_EL).
So, It seems to need backporting from upstream more.
Comment 12 Keiichi Mori 2006-08-13 21:10:33 EDT
Created attachment 134111 [details]
bonding_support_carrier_state.patch

Also, bonding driver needs to support carrier state for master device.
http://kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=ff59c4563a8d1b39597aab4917959146c


Attaching the backported patch to RHEL4.
Comment 13 Keiichi Mori 2006-08-13 21:12:32 EDT
Just clarify that we need both patches, comment#11 and comment#12, for this issue.

I will ask the customer to verify them.
Comment 18 RHEL Product and Program Management 2007-05-09 06:05:28 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 19 RHEL Product and Program Management 2007-09-07 15:44:24 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.

Note You need to log in before you can comment on or make changes to this bug.