Bug 197780 - Thunderbird crashes when rewrapping text
Thunderbird crashes when rewrapping text
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-06 06:55 EDT by Euan Maxwell
Modified: 2007-12-10 04:44 EST (History)
2 users (show)

See Also:
Fixed In Version: thunderbird-2.0.0.9-1.fc7 (perhaps earlier)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 04:44:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Euan Maxwell 2006-07-06 06:55:11 EDT
Description of problem:

Thunderbird crashes in certain instances when attempts are made to rewrap quoted
text in a reply.

Version-Release number of selected component (if applicable):
1.5.0.4 (20060614)
thunderbird-1.5.0.4-1.1.fc5

we're on Fedora Core 5 x86_64

How reproducible:

Fairly easily.  Make sure you're replying in text only so it's using ">" to
quote original mail and not the blue bar down the side.

Steps to Reproduce:
1. I select a message in my inbox, hit reply.  Composer comes up and has text
quoted in-line from original.

2.  I select text to rewrap and select the "Rewrap" option from the Edit menu.
3.  Thunderbird crashes immediately.  This is reproducable.  If you don't select
any text, or select all text in the message, it tends not to crash.

When part of the original message is selected, it varies whether or not it crashes.

A consistent way (for me at least) to get it to crash is to reply, select all
the text except for the line that gives you the original sender's email address:

ie:

test@test.com wrote:     << don't select this line, but everything else below
>
> commented email follows


  
Actual results:

Thunderbird crashes

Expected results:

Text should rewrap in composer.
Additional info:

You can download a full strace -f of my thunderbird when this crash has been
replicated here:

http://www.emdevelopment.com/thunderbird_strace.txt.bz2
Comment 1 Matěj Cepl 2007-07-18 13:32:26 EDT
Fedora Core 5 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora Core 6, or
Fedora 7, or Rawhide)? If this issue turns out to still be reproducible, please
let us know in this bug report.  If after a month's time we have not heard back
from you, we will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.
Comment 2 Euan Maxwell 2007-07-20 05:27:34 EDT
I'm now running Fedora Core 6 (upgraded from 5) and thunderbird 1.5.0.12

The bug is still reproducible.  Although my colleague running an identical setup
cannot reproduce this bug.

I have no themes/extentions installed apart from the standard ones.
Comment 3 Matěj Cepl 2007-12-10 04:24:46 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 4 Euan Maxwell 2007-12-10 04:44:05 EST
This is no longer reproducible in the current version on my Fedora 7 install.

Note You need to log in before you can comment on or make changes to this bug.