Bug 197785 - The 2.6.17-1.2145_FC5 and 2.6.17-1.2145_FC5smp kernels hand when booting with a RAID drive.
The 2.6.17-1.2145_FC5 and 2.6.17-1.2145_FC5smp kernels hand when booting with...
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity urgent
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-06 08:28 EDT by John Preston
Modified: 2015-01-04 17:27 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-24 17:58:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Preston 2006-07-06 08:28:14 EDT
Description of problem:
The system hangs at the RedHat message after selecting the kernel to be used via
grub.

Version-Release number of selected component (if applicable):
kernel 2.6.17-1.2145_FC5 and 2.6.17-1.2145_FC5smp

How reproducible:
Always occurs.

Steps to Reproduce:
1. Boot using 2.6.17-1.2145_FC5 or 2.6.17-1.2145_FC5smp kernel
2.
3.
  
Actual results:


Expected results:


Additional info:
I am using a MSI-6788 motherboard with a Addonics ADST114 4 port RAID controller
with 2 200GB SATA drives configured as RAID 1. The output of the mount command
shows:

/dev/dm-1 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/dm-6 on /data1 type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
/dev/dm-2 on /home type ext3 (rw)
/dev/dm-3 on /usr/local type ext3 (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
automount(pid1898) on /net type autofs (rw,fd=4,pgrp=1898,minproto=2,maxproto=4)

The last kernel that works is:
2.6.16-1.2133_FC5 and 2.6.16-1.2133_FC5smp
Comment 1 Christopher Tomao 2006-07-08 15:47:32 EDT
Need to chime in on this one:
My last bootable kernel also was 2.6.16-1.2133 - the 2 subsequently released
kernels hung at the following points in runlevel 3 and single-user mode:

2139: device-mapper ioctl (don't have the kernel installed anymore, so can't
view the exact message)

2145: Red Hat nash version 5.0.32 starting

Subsequent to both points, the system hangs indefinitely. However, I found a
workaround that won't help you, but should help locate the bug: I removed and
created a new kernel image via mkinitrd, with the --omit-raid-modules and
--omit-scsi-modules options. I have a raid - ntfs partition spanned between 2
sata drives (I have a silicon image controller), so I don't need to boot off it
or even access the drives in Fedora. I can boot off the new image without error.
Therefore, the problem must lay somewhere between the new kernels and the scsi
or raid modules being loaded. Please note: other than being a dual boot between
Windwos XP Pro and Fedora Core 5, my install is stock: I did not compile my own
kernel. I hope this helps, please let me know if there is anything else I can
provide (I'm a bit of a newbie, so please provide explicit instructions/links
when you can).
Comment 2 John C. Bonnett 2006-07-09 04:14:18 EDT
I have the same symptoms as Christopher with the same two kernels. On the same
machine I have a Windows system on RAID mirrored drives, not accessed from the
Linux system. RAID is via Promise 20276 chipset on motherboard. Kernel 2133 is
the last one that worked for me too.
Comment 3 Vukasin Toroman 2006-07-17 05:51:58 EDT
Same behavior here. I am however booting from the RAID drive so the afore
mentioned fix does not help me at all. 
The RAID controler used (from lspci) is: 
00:1f.2 RAID bus controller: Intel Corporation 82801ER (ICH5R) SATA Controller
(rev 02)

As with the John, the setup worked (and still works) perfectly when I boot the
2.6.16-1.2133_FC5smp kernel.

Comment 4 John Preston 2006-07-17 07:29:17 EDT
I've just tried the 2.6.17-1.2157_FC5 kernel and the problem is the same. It
stop boot at the 'RedHat nash version 5.0.32 starting' message.
Comment 5 James Gregory 2006-07-26 10:06:19 EDT
I am having the same problem with 2.6.17-1.2157_FC5smp. FC5 stops loading after
the "Red Hat nash version 5.0.32 starting" message. The RAID controller in the
server is Promise FastTrak TX2 (set up to mirror one drive to another) and it
works fine the in default kernel installed in FC5.
Comment 6 Vukasin Toroman 2006-07-31 04:34:06 EDT
It would really be reassuring if someone, anyone of the people respolnsible for
maintaining the fedora kernel would at least aknowledge this issue. It seems
that these boot failures are no isolated incidents but still there is no comment
to what is causing them or to when, who or how are they going to be solved?! If
some additional info would help speed things up, please request it here.
Comment 7 Jason Smyth 2006-08-19 00:45:54 EDT
I am no expert, but it seems to me this is likely related to
[url=https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=196556]Bug
196556[/url] and
[url=https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=196626]Bug 196626[/url].
Comment 8 Jason Smyth 2006-08-19 00:56:30 EDT
Sorry for the bad links. I'm new to Bugzilla and mistakenly tried BB code
instead of html. Lesson learned. These links should work:

<a href="https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=196556">Bug 196556</a>

<a href="https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=196626">Bug 196626</a>
Comment 9 Dave Jones 2006-10-16 20:25:03 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 10 Dave Jones 2006-11-24 17:58:53 EST
This bug has been mass-closed along with all other bugs that
have been in NEEDINFO state for several months.

Due to the large volume of inactive bugs in bugzilla, this
is the only method we have of cleaning out stale bug reports
where the reporter has disappeared.

If you can reproduce this bug after installing all the
current updates, please reopen this bug.

If you are not the reporter, you can add a comment requesting
it be reopened, and someone will get to it asap.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.