Bug 197787 - nvidia kernel module doesn't be built in kernel-devel-2.6.17-1.2356.fc6
nvidia kernel module doesn't be built in kernel-devel-2.6.17-1.2356.fc6
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-06 08:50 EDT by sangu
Modified: 2015-01-04 17:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-11 02:56:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2006-07-06 08:50:36 EDT
Description of problem:
nvidia kernel module build error message.
[...]
make -rR -f /usr/src/kernels/2.6.17-1.2356.fc6-i686/scripts/Makefile.modpost
scripts/mod/modpost -m -a -i
/usr/src/kernels/2.6.17-1.2356.fc6-i686/Module.symvers -I
/usr/src/redhat/BUILD/nvidia-kmod-1.0.8762/_kmod_build_/usr/src/nv/Modules.symvers
-o
/usr/src/redhat/BUILD/nvidia-kmod-1.0.8762/_kmod_build_/usr/src/nv/Modules.symvers
/usr/src/redhat/BUILD/nvidia-kmod-1.0.8762/_kmod_build_/usr/src/nv/nvidia.o
WARNING: could not find
/usr/src/redhat/BUILD/nvidia-kmod-1.0.8762/_kmod_build_/usr/src/nv/.nv-kernel.o.cmd
for /usr/src/redhat/BUILD/nvidia-kmod-1.0.8762/_kmod_build_/usr/src/nv/nv-kernel.o
FATAL: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol
'lockdep_init_map'
make[3]: *** [__modpost] Error 1
make[2]: *** [modules] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [mdl] Error 1
make: *** [module] Error 2

Please See : http://www.nvnews.net/vbulletin/showthread.php?p=930330#post930330

Version-Release number of selected component (if applicable):
2.6.17-1.2356.fc6

How reproducible:
always

Steps to Reproduce:
1. nvidia kernel module build
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Dave Jones 2006-07-11 02:56:11 EDT
nvidia module shouldn't be picking up this symbol.
Comment 2 Terence Ripperda 2006-07-11 10:35:02 EDT
unfortunately, our module has no choice if the user has enabled the lock
verifier, as the lock verifier code will pull in this symbol automatically. 
Comment 3 Dave Jones 2006-07-14 18:21:23 EDT
then complain upstream, because rawhide will always be running with lockdep
enabled from now on. (It'll be disabled for release kernels only).


Note You need to log in before you can comment on or make changes to this bug.