Bug 197813 - mesa errors: libGL warning: 3D driver claims to not support visual 0x4b
mesa errors: libGL warning: 3D driver claims to not support visual 0x4b
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-06 12:26 EDT by Pete Graner
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-22 09:08:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Graner 2006-07-06 12:26:34 EDT
Description of problem: While running GL based apps the error:

glxgears
libGL warning: 3D driver claims to not support visual 0x4b

glxgear runs in this case, but compiz will not:

compiz --replace gconf
libGL warning: 3D driver claims to not support visual 0x4b
compiz: No GLXFBConfig for default depth, this isn't going to work.
compiz: Failed to manage screen: 0
compiz: No managable screens found on display :0.0


Version-Release number of selected component (if applicable):
[pgraner@meatwad ~]$ rpm -qa | grep mesa
mesa-libGLU-devel-6.5-13.fc6
mesa-libGLU-6.5-13.fc6
mesa-libGL-6.5-13.fc6
mesa-libGL-devel-6.5-13.fc6


How reproducible: Started with todays rawhide mesa and kernel update.

Additional info: I tried the previous kernel with the new mesa packages and
still get the error. If I roll the mesa back to the previous version it works.
So I don't think its a kernel issue at this point.
Comment 1 Nicholas Miell 2006-07-07 02:24:07 EDT
What driver and architecture?

As a shot in the dark, does it go away if you add -fno-strict-aliasing to the
OPT_FLAGS? (This is more for the X team's benefit, but if you (Pete) want to try
it, go for it -- it's an easy mesa.spec modification.)

WORKSFORME on AMD64/R200 with everything I tried (glxinfo, glxgears, glthreads,
IOQuake3, UT2004 Demo).
Comment 2 Pete Graner 2006-07-07 09:51:34 EDT
driver == radeon
arch == i386

lspci -v 
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW
[Radeon Mobility 7500] (prog-if 00 [VGA])
        Subsystem: IBM Unknown device 0530
        Flags: bus master, stepping, fast Back2Back, 66MHz, medium devsel,
latency 66, IRQ 11
        Memory at e0000000 (32-bit, prefetchable) [size=128M]
        I/O ports at 3000 [size=256]
        Memory at c0100000 (32-bit, non-prefetchable) [size=64K]
        [virtual] Expansion ROM at c0120000 [disabled] [size=128K]
        Capabilities: [58] AGP version 2.0
        Capabilities: [50] Power Management version 2
Comment 3 Adam Jackson 2006-09-21 23:43:03 EDT
Can you still reproduce this with mesa 6.5.1 packages?
Comment 4 Pete Graner 2006-09-22 09:06:55 EDT
Wen't away sometime ago. Just forgot to close out the bug. Sorry.

Note You need to log in before you can comment on or make changes to this bug.