Bug 197835 - /var/log/mail is not owned by any package
/var/log/mail is not owned by any package
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: sendmail (Show other bugs)
4.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Thomas Woerner
David Lawrence
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-06 14:12 EDT by Robert Scheck
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-22 10:56:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2006-07-06 14:12:23 EDT
Description of problem:
This bug report was created as clone of bug #192850. As far as I know, RHEL and 
Fedora bugs always should be kept separate in Bugzilla.

/var/log/mail is not owned by any package, but should be owned by sendmail,
as the sendmail rpm package is delivering its content.

Version-Release number of selected component (if applicable):
sendmail-8.13.1-3.RHEL4.5

How reproducible:
rpm -qf /var/log/mail

Expected results:
Please apply the following patch (or better):

--- snipp ---
--- sendmail.spec       2006-03-25 21:29:02.000000000 +0100
+++ sendmail.spec.rsc   2006-05-23 18:22:57.000000000 +0200
@@ -533,6 +533,7 @@
 %attr(0644,root,root) %ghost   /etc/aliases.db
 %attr(0770,smmsp,smmsp) %dir   /var/spool/clientmqueue
 %attr(0700,root,mail) %dir     /var/spool/mqueue
+%dir %{stdir}
 %dir /etc/smrsh
 %dir /etc/mail

--- snapp ---
Comment 1 Florian La Roche 2006-08-02 04:10:20 EDT
Shouldn't this go into syslog since that defines where the data will end
up?

regards,

Florian La Roche
Comment 2 Robert Scheck 2006-08-09 14:28:29 EDT
Hu, did I miss something? Where does syslog define /var/log/mail/statistics?
IIRC /var/log/maillog is, where data from syslog ends. And the statistics file
is owned by the sendmail package, so the parent directory should be owned by
sendmail, too.
Comment 3 Florian La Roche 2006-08-10 03:31:49 EDT
Ok, that makes sense.

regards,

Florian La Roche
Comment 4 RHEL Product and Program Management 2006-08-18 11:14:32 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Thomas Woerner 2007-01-22 10:56:42 EST
/var/spool/mail should not belong to a mailer. Maybe another mailer is used and
sendmail is not installed at all.

Note You need to log in before you can comment on or make changes to this bug.