This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 197840 - add WMV to /etc/mime.types
add WMV to /etc/mime.types
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mailcap (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Ben Levenson
http://www.flytrapsoul.com/pages/vide...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-06 14:31 EDT by Steve Chapel
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-19 03:07:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Chapel 2006-07-06 14:31:35 EDT
Description of problem:
Apache serves WMV files with the incorrect MIME type of text/plain by default.
Because the default charset of Apache 2 on Fedora Core seems to be UTF-8,
Firefox does not detect that the file is in fact a binary file, and tries to
display the content as if it were a text file.

Version-Release number of selected component (if applicable):
Apache/2.0.49

How reproducible:
Always

Steps to Reproduce:
1. Open http://www.flytrapsoul.com/pages/video/flytrapdial.wmv in Firefox.
  
Actual results:
The file is displayed as a text file.

Expected results:
The file is opened in the default WMV player.

Additional info:
Many other types of files are also incorrectly sent with the MIME type
text/plain. See https://bugzilla.mozilla.org/show_bug.cgi?id=183340 and
https://bugzilla.mozilla.org/show_bug.cgi?id=261263 for more information about
files sent by Apache with the wrong MIME type.
Comment 1 Fedora Update System 2006-07-18 12:12:51 EDT
mailcap-2.1.21-1.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.