Bug 197973 - Patch for splittree.py to follow symlinks in package size calculation
Patch for splittree.py to follow symlinks in package size calculation
Status: CLOSED DUPLICATE of bug 195240
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
https://www.redhat.com/archives/anaco...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-07 15:31 EDT by Eric Moret
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-10 20:38:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to splittree that follows symlinks in disc size calculation (705 bytes, patch)
2006-07-07 15:31 EDT, Eric Moret
no flags Details | Diff

  None (edit)
Description Eric Moret 2006-07-07 15:31:22 EDT
Description of problem:
I am trying to create a 5 discs FC5 distribution based on the DVD image. In
order to save disk space I would like to create a unified tree with symlinks to
the rpm packages rather than copying over rpm files to the new tree.

Version-Release number of selected component (if applicable):
anaconda-11.0.5-1

How reproducible:
Always

Steps to Reproduce:
1. mount FC5 DVD image on /mnt/fc5
2. mkdir -p /usr/local/src/cs-fedora/i386
3. cp -al /mnt/fc5/* /usr/local/src/cs-fedora/i386
4. prepare unified tree (pkgorder, etc...)
4. /usr/lib/anaconda-runtime/splittree.py \
   --arch=i386 \
   --total-discs=5 \
   --bin-discs=5 \
   --src-discs=0 \
   --srcdir=/usr/local/src/cs-fedora/SRPMS \
   --release-string="Fedora Core 5" \
   --pkgorderfile=/usr/local/src/cs-fedora/pkgfile.txt \
   --distdir=/usr/local/src/cs-fedora/i386 \
   --productpath=Fedora
  
Actual results:
First package on disc1: kernel-2.6.17-1.2139_FC5.i686.rpm
Last package on disc1 : lucene-javadoc-1.4.3-1jpp_11fc.i386.rpm
i386-disc1 size: 133M

Files and links to packages in Fedora/RPMS only take up to 133M! The package 
size calculation does not follow symlinks. So they all fit on the first 
disc. Obviously not what I want.


Expected results:
First package on disc1: kernel-2.6.17-1.2139_FC5.i686.rpm
Last package on disc1 : evolution-sharp-0.10.2-9.3.i386.rpm
i386-disc1 size: 629M
First package on disc2: mono-data-1.1.13.7-1.fc5.1.i386.rpm
Last package on disc2 : ant-apache-oro-1.6.5-1jpp_7fc.i386.rpm
i386-disc2 size: 623M
First package on disc3: eclipse-platform-3.1.2-1jpp_15fc.i386.rpm
Last package on disc3 : kdeedu-devel-3.5.3-0.1.fc5.i386.rpm
i386-disc3 size: 640M
First package on disc4: xfsprogs-2.7.3-1.2.1.i386.rpm
Last package on disc4 : slrn-pull-0.9.8.1pl1-1.2.1.i386.rpm
i386-disc4 size: 621M
First package on disc5: thunderbird-1.5.0.4-1.1.fc5.i386.rpm
Last package on disc5 : lucene-javadoc-1.4.3-1jpp_11fc.i386.rpm
i386-disc5 size: 603M


Additional info:
Please see attached patch to correct behaviour
Comment 1 Eric Moret 2006-07-07 15:31:23 EDT
Created attachment 132085 [details]
Patch to splittree that follows symlinks in disc size calculation
Comment 2 Jeremy Katz 2006-07-10 20:38:15 EDT

*** This bug has been marked as a duplicate of 195240 ***

Note You need to log in before you can comment on or make changes to this bug.