Bug 198035 - lockdep oops in hwclock driver
lockdep oops in hwclock driver
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
: Reopened
: 198036 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-08 09:03 EDT by Jurgen Kramer
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-28 13:36:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full dmesg output (31.69 KB, text/plain)
2006-07-08 09:03 EDT, Jurgen Kramer
no flags Details

  None (edit)
Description Jurgen Kramer 2006-07-08 09:03:04 EDT
Description of problem:
While booting the system a lockdep related oops is shown.

Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2358.fc6

How reproducible:
allways

Steps to Reproduce:
1. Boot system
2.
3.
  
Actual results:
=================================
[ INFO: inconsistent lock state ]
---------------------------------
inconsistent {hardirq-on-W} -> {in-hardirq-W} usage.
hwclock/486 [HC1[1]:SC0[0]:HE0:SE1] takes:
 (rtc_lock){+-..}, at: [<c053c9ad>] rtc_get_rtc_time+0x1c/0x177
{hardirq-on-W} state was registered at:
  [<c043c546>] lock_acquire+0x4b/0x6d
  [<c060e29b>] _spin_lock+0x19/0x28
  [<c0407433>] get_cmos_time+0x13/0x11d
  [<c07ad610>] hpet_time_init+0x8/0x4e
  [<c07a769b>] start_kernel+0x22c/0x3a9
  [<c0400210>] 0xc0400210
irq event stamp: 1792
hardirqs last  enabled at (1791): [<c0403f77>] restore_nocheck+0x12/0x15
hardirqs last disabled at (1792): [<c04049c7>] common_interrupt+0x1b/0x2c
softirqs last  enabled at (716): [<c042987d>] __do_softirq+0xec/0xf2
softirqs last disabled at (707): [<c04065ab>] do_softirq+0x5a/0xbe

other info that might help us debug this:
no locks held by hwclock/486.

stack backtrace:
 [<c0405167>] show_trace_log_lvl+0x54/0xfd
 [<c040571e>] show_trace+0xd/0x10
 [<c040583d>] dump_stack+0x19/0x1b
 [<c043a982>] print_usage_bug+0x1ca/0x1d7
 [<c043acc8>] mark_lock+0x96/0x36a
 [<c043b9fa>] __lock_acquire+0x3b2/0x98d
 [<c043c546>] lock_acquire+0x4b/0x6d
 [<c060e4a4>] _spin_lock_irq+0x1f/0x2e
 [<c053c9ad>] rtc_get_rtc_time+0x1c/0x177
 [<c0419824>] hpet_rtc_interrupt+0x92/0x14d
 [<c0451020>] handle_IRQ_event+0x20/0x4d
 [<c04510e1>] __do_IRQ+0x94/0xef
 [<c04066c8>] do_IRQ+0xb9/0xcd
 [<c04049d1>] common_interrupt+0x25/0x2c


Expected results:
no oops ;)

Additional info:
This is on a MacBook running current FC6 devel.
Comment 1 Jurgen Kramer 2006-07-08 09:03:04 EDT
Created attachment 132102 [details]
Full dmesg output
Comment 2 Dave Jones 2006-07-11 01:44:08 EDT
*** Bug 198036 has been marked as a duplicate of this bug. ***
Comment 3 Dave Jones 2006-07-12 00:06:38 EDT
should be fixed in tomorrows rawhide push (kernel-2.6.17-1.2375.fc6 or higher).
Comment 4 Wade Mealing 2006-07-24 23:50:05 EDT
Upgraded to current rawhide (2.6.17-2439.fc6 smp) still happening.
Comment 7 Jurgen Kramer 2006-07-28 13:32:35 EDT
I no longer see this message with the newer kernels (tested with
2.6.17-1.2462.fc6). Can be closed?

Note You need to log in before you can comment on or make changes to this bug.