Bug 198043 - Driver reverts to software rendering due to missing symbol
Driver reverts to software rendering due to missing symbol
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-08 09:32 EDT by Jurgen Kramer
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-21 18:00:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jurgen Kramer 2006-07-08 09:32:28 EDT
Description of problem:
Driver reverts to software rendering because of missing symbol

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-1.6.0-6.modeset20060707

How reproducible:
allways

Steps to Reproduce:
1. Boot in level 5
2. Check GL performance with glxgears
3.
  
Actual results:
Hardware assisted GL not available:

drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 9, (OK)
drmOpenByBusid: Searching for BusID pci:0000:00:02.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 9, (OK)
drmOpenByBusid: drmOpenMinor returns 9
drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
(EE) AIGLX error: dlopen of /usr/lib/dri/i915_dri.so failed
(/usr/lib/dri/i915_dri.so: undefined symbol: _glapi_tls_Context)
(EE) AIGLX: reverting to software rendering



Expected results:
More FPS ;)

Additional info:
This is on a Apple MacBook
Comment 1 Tom London 2006-07-08 13:46:22 EDT
I can confirm: Thinkpad X41 with:
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express
Graphics Controller (rev 03)

Results in a 'panning' 1280x1024 screen within a 1024x768 display.

Here are first few lines of /var/log/gdm/:0.log:

X Window System Version 7.1.0
Release Date: 22 May 2006
X Protocol Version 11, Revision 0, Release 7.1
Build Operating System: Linux 2.6.9-34.ELsmp i686 Red Hat, Inc.
Current Operating System: Linux localhost.localdomain 2.6.17-1.2358.fc6 #1 SMP
Fri Jul 7 04:02:07 EDT 2006 i686
Build Date: 07 July 2006
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Jul  8 10:35:06 2006
(==) Using config file: "/etc/X11/xorg.conf"
(WW) I810: No matching Device section for instance (BusID PCI:0:2:1) found
(EE) I810(0): Unable to read from SDVOCTRL_E Slave 112.
(EE) I810(0): Unable to read from SDVOCTRL_E Slave 114.
(EE) I810(0): DDC Analog 0, 00005010
(EE) I810(0): DDC LVDS 1, 00005018
Executing (ax == 0x5f01) BIOS call at i830_driver.c:617
Couldn't get established mode 5
Couldn't get established mode 12
(EE) I810(0): Modeline "1280x1024"x75.0  135.00  1280 1296 1440 1688  1024 1025
1028 1066 +hsync +vsync
(EE) I810(0): Modeline "1280x1024"x75.0  135.00  1280 1296 1440 1688  1024 1025
1028 1066 +hsync +vsync
(EE) I810(0): Modeline "1280x1024"x60.0  108.78  1280 1360 1496 1712  1024 1025
1028 1059

Display 'returns to normal' (i.e., 1280x1024 display as 1280x1024) when I revert
to xorg-x11-drv-i810-1.6.0-5.i386.rpm.

Here is :0.log when I run with 1.6.0-5:

X Window System Version 7.1.0
Release Date: 22 May 2006
X Protocol Version 11, Revision 0, Release 7.1
Build Operating System: Linux 2.6.9-34.ELsmp i686 Red Hat, Inc.
Current Operating System: Linux localhost.localdomain 2.6.17-1.2358.fc6 #1 SMP
Fri Jul 7 04:02:07 EDT 2006 i686
Build Date: 07 July 2006
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Jul  8 10:46:03 2006
(==) Using config file: "/etc/X11/xorg.conf"
(WW) I810: No matching Device section for instance (BusID PCI:0:2:1) found
(EE) AIGLX error: dlopen of /usr/lib/dri/i915_dri.so failed
(/usr/lib/dri/i915_dri.so: undefined symbol: _glapi_tls_Context)
(EE) AIGLX: reverting to software rendering
    xkb_keycodes             { include "xfree86+aliases(qwerty)" };
    xkb_types                { include "complete" };
    xkb_compatibility        { include "complete" };
    xkb_symbols              { include "pc(pc105)+us" };
    xkb_geometry             { include "pc(pc105)" };
AUDIT: Sat Jul  8 10:46:04 2006: 3478 Xorg: client 1 rejected from local host
Comment 2 Adam Jackson 2006-07-08 19:07:40 EDT
Jurgen's bug is actually a bug against Mesa, since that's what provides i915_dri.so.

Tom, your issue is a different bug, I've cloned it off as bug #198062.  Please
follow it there.  Please note that the summary of this bug (about software
rendering) had nothing to do with your issue (bad modesetting).
Comment 3 Jurgen Kramer 2006-07-09 07:50:45 EDT
the missing symbol problem is solved with the latest xorg update:

drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 9, (OK)
drmOpenByBusid: Searching for BusID pci:0000:00:02.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 9, (OK)
drmOpenByBusid: drmOpenMinor returns 9
drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
(WW) AIGLX: 3D driver claims to not support visual 0x23
(WW) AIGLX: 3D driver claims to not support visual 0x24
(WW) AIGLX: 3D driver claims to not support visual 0x25
(WW) AIGLX: 3D driver claims to not support visual 0x26
(WW) AIGLX: 3D driver claims to not support visual 0x27
(WW) AIGLX: 3D driver claims to not support visual 0x28


But unfortunately:

audit(1152446074.317:56): avc:  denied  { execmem } for  pid=3226
comm="glxgears" scontext=user_u:system_r:unconfined_t:s0
tcontext=user_u:system_r:unconfined_t:s0 tclass=process
audit(1152446094.782:57): avc:  denied  { execmem } for  pid=3253 comm="glxinfo"
scontext=user_u:system_r:unconfined_t:s0
tcontext=user_u:system_r:unconfined_t:s0 tclass=process

Note You need to log in before you can comment on or make changes to this bug.