Bug 198056 - gnome-screensaver spec broken. Also patch from ubantu to fix GL screensaver visual selection not imcorporated
gnome-screensaver spec broken. Also patch from ubantu to fix GL screensaver v...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-08 16:17 EDT by Jamie Beverly
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 14:33:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Would use a patch, but it just seemed easier to provide the src.rpm includes ubantu "thow_shall_not_flicker" and "no_flicker" patches. and corrects the %trigger* sections (also uncommented the ac/am) (1.85 MB, application/octet-stream)
2006-07-08 16:17 EDT, Jamie Beverly
no flags Details

  None (edit)
Description Jamie Beverly 2006-07-08 16:17:30 EDT
Description of problem:
The spec file for gnome-screensaver neglects to utilize $1 and $2 in the
%triggerun sections. It also overwrites any existing .desktop files upon
upgrade/reinstall.

Also, there is a patch from ubantu that allows gnome-screensaver to correctly
identify the gl visual for gl screensavers that has not been included in the spec.

Version-Release number of selected component (if applicable):
gnome-screensaver-2.14.2-1

How reproducible:
examine gnome-screensaver.spec... install gnome screensaver, or attempt to run a
gl-extras screenhack.

  
Actual results:
/usr/share/gnome-screensaver/themes contains none of the .desktop files for
xscreensaver*extras screenhacks due to %triggerun removing them as quickly as it
installed them in the %triggerin section.

manually installing the .desktop files with the migrate-xscreensaver script
populates the approproate desktop files, however any attempt to run a gl
screensaver on a system using DRI results in a very nasty flicker effect because
the default visual chosen by gnome-screensaver is the first returned; and that's
not the correct visual on many DRI systems.

Expected results:
gnome screensaver is able to run gl screenhacks, correctly installes the
.desktop files if xscreensaver-extras and/or xscreensaver-gl-extras is installed.

.desktop files for xscreensaver-extras and/or xscreensaver-gl-extras should be
removed when gnome-screensaver, xscreensaver-extras, or xscreensaver-gl-extras
are removed.

Additional info:
All of the above is corrected in the .src.rpm I've attached to to this bug. The
spec is commented; I won't have my feelings hurt if the ubantu patch is prettied
up (hunk-offsets corrected, I was too lazy to type recountdiff)
Comment 1 Jamie Beverly 2006-07-08 16:17:31 EDT
Created attachment 132114 [details]
Would use a patch, but it just seemed easier to provide the src.rpm includes ubantu "thow_shall_not_flicker" and "no_flicker" patches. and corrects the %trigger* sections (also uncommented the ac/am)
Comment 2 Ray Strode [halfline] 2008-03-18 14:33:37 EDT
Hi,

We no longer support Fedora Core 5 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)

Note You need to log in before you can comment on or make changes to this bug.