Bug 198062 - Modesetting i810 driver doesn't set modes right
Modesetting i810 driver doesn't set modes right
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-08 19:06 EDT by Adam Jackson
Modified: 2008-08-11 12:38 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-11 12:38:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (2.91 KB, text/plain)
2006-07-09 11:52 EDT, Tom London
no flags Details
Xorg.0.log from 1.6.0-5 version of i810 driver (66.20 KB, text/plain)
2006-07-09 11:53 EDT, Tom London
no flags Details
Xorg.0.log from 1.6.0-6.modeset version of i810 driver (96.39 KB, text/plain)
2006-07-09 11:54 EDT, Tom London
no flags Details
xorg config on Dell D620 (1.83 KB, text/plain)
2006-07-10 09:35 EDT, Peter Robinson
no flags Details
The xorg log file for the modesetting driverr (46.54 KB, text/plain)
2006-07-10 09:36 EDT, Peter Robinson
no flags Details
xorg log pre modesetting driver (63.28 KB, text/plain)
2006-07-10 09:38 EDT, Peter Robinson
no flags Details
xorg-x11-drv-i810-1.6.0-11.20060713modeset.fc6 log files on Dell 640m/e1405 (26.81 KB, application/x-gzip)
2006-07-15 22:03 EDT, Yijun Yuan
no flags Details
Xorg log file for Aopen mini pc (289.89 KB, text/plain)
2006-07-17 09:56 EDT, Kevin DeKorte
no flags Details
Xorg conf file for Aopen mini pc (2.62 KB, application/octet-stream)
2006-07-17 09:58 EDT, Kevin DeKorte
no flags Details
Log file for older driver on Aopen MiniPC that works correctly (63.80 KB, text/plain)
2006-07-17 10:53 EDT, Kevin DeKorte
no flags Details
Xorg.0.log from 1.6.0-13 version of i810 driver (37.39 KB, text/plain)
2006-08-03 10:00 EDT, Tom London
no flags Details
Xorg.setup.log (9.23 KB, text/plain)
2006-08-03 10:01 EDT, Tom London
no flags Details
Xorg.0.log for failing 1.6-13 driver (69.57 KB, text/plain)
2006-08-03 13:16 EDT, Kevin DeKorte
no flags Details
Results after putting Option "MonitorLayout" "DFP,NONE" in xorg.conf (243.71 KB, text/plain)
2006-08-03 20:19 EDT, Kevin DeKorte
no flags Details
Xorg.0.log from xorg-x11-drv-i810-1.6.0-13.20060717modeset.fc6 (212.35 KB, text/plain)
2006-08-03 21:49 EDT, Tom London
no flags Details
Xorg.0.log with no MonitorLayout option in xorg.conf (98.24 KB, text/plain)
2006-08-04 09:40 EDT, Tom London
no flags Details
Xorg.0.log (156.15 KB, text/plain)
2006-08-05 14:15 EDT, Paul Dickson
no flags Details
i845 on Dell D620 (1.84 KB, application/octet-stream)
2006-08-07 17:11 EDT, Peter Robinson
no flags Details
xorg log for i945 on Dell D620 (63.49 KB, text/plain)
2006-08-07 17:25 EDT, Peter Robinson
no flags Details
Xorg.0.log on an LG T1 Dual Express with org-x11-drv-i810-1.60-13.20060717modeset (39.25 KB, text/plain)
2006-08-09 06:49 EDT, Rene Rask
no flags Details
xorg-x11-drv-i810-1.6.5-3.fc6 on Dell 640m/e1405 (18.37 KB, application/x-gzip)
2006-08-18 12:26 EDT, Yijun Yuan
no flags Details
flickering xorg.log modelines (2.25 KB, text/plain)
2006-10-25 17:52 EDT, Christian Weiske
no flags Details
Xorg.0.log from 'intel' run (73.27 KB, text/plain)
2007-04-05 12:25 EDT, Tom London
no flags Details
Xorg.0.log from 'intel' run (previous was for i810, sorry) (121.87 KB, text/plain)
2007-04-05 12:26 EDT, Tom London
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 6942 None None None Never

  None (edit)
Description Adam Jackson 2006-07-08 19:06:19 EDT
Originally on bug #198043:

I can confirm: Thinkpad X41 with:
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express
Graphics Controller (rev 03)

Results in a 'panning' 1280x1024 screen within a 1024x768 display.

Here are first few lines of /var/log/gdm/:0.log:

X Window System Version 7.1.0
Release Date: 22 May 2006
X Protocol Version 11, Revision 0, Release 7.1
Build Operating System: Linux 2.6.9-34.ELsmp i686 Red Hat, Inc.
Current Operating System: Linux localhost.localdomain 2.6.17-1.2358.fc6 #1 SMP
Fri Jul 7 04:02:07 EDT 2006 i686
Build Date: 07 July 2006
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Jul  8 10:35:06 2006
(==) Using config file: "/etc/X11/xorg.conf"
(WW) I810: No matching Device section for instance (BusID PCI:0:2:1) found
(EE) I810(0): Unable to read from SDVOCTRL_E Slave 112.
(EE) I810(0): Unable to read from SDVOCTRL_E Slave 114.
(EE) I810(0): DDC Analog 0, 00005010
(EE) I810(0): DDC LVDS 1, 00005018
Executing (ax == 0x5f01) BIOS call at i830_driver.c:617
Couldn't get established mode 5
Couldn't get established mode 12
(EE) I810(0): Modeline "1280x1024"x75.0  135.00  1280 1296 1440 1688  1024 1025
1028 1066 +hsync +vsync
(EE) I810(0): Modeline "1280x1024"x75.0  135.00  1280 1296 1440 1688  1024 1025
1028 1066 +hsync +vsync
(EE) I810(0): Modeline "1280x1024"x60.0  108.78  1280 1360 1496 1712  1024 1025
1028 1059

Display 'returns to normal' (i.e., 1280x1024 display as 1280x1024) when I revert
to xorg-x11-drv-i810-1.6.0-5.i386.rpm.

Here is :0.log when I run with 1.6.0-5:

X Window System Version 7.1.0
Release Date: 22 May 2006
X Protocol Version 11, Revision 0, Release 7.1
Build Operating System: Linux 2.6.9-34.ELsmp i686 Red Hat, Inc.
Current Operating System: Linux localhost.localdomain 2.6.17-1.2358.fc6 #1 SMP
Fri Jul 7 04:02:07 EDT 2006 i686
Build Date: 07 July 2006
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Jul  8 10:46:03 2006
(==) Using config file: "/etc/X11/xorg.conf"
(WW) I810: No matching Device section for instance (BusID PCI:0:2:1) found
(EE) AIGLX error: dlopen of /usr/lib/dri/i915_dri.so failed
(/usr/lib/dri/i915_dri.so: undefined symbol: _glapi_tls_Context)
(EE) AIGLX: reverting to software rendering
    xkb_keycodes             { include "xfree86+aliases(qwerty)" };
    xkb_types                { include "complete" };
    xkb_compatibility        { include "complete" };
    xkb_symbols              { include "pc(pc105)+us" };
    xkb_geometry             { include "pc(pc105)" };
AUDIT: Sat Jul  8 10:46:04 2006: 3478 Xorg: client 1 rejected from local host
Comment 1 Adam Jackson 2006-07-08 19:08:38 EDT
Please attach the complete /var/log/Xorg.0.log from both 1.6.0-5 and
1.6.0-6.modeset*, and your xorg.conf.
Comment 2 Tom London 2006-07-09 11:52:36 EDT
Created attachment 132135 [details]
xorg.conf
Comment 3 Tom London 2006-07-09 11:53:28 EDT
Created attachment 132136 [details]
Xorg.0.log from 1.6.0-5 version of i810 driver
Comment 4 Tom London 2006-07-09 11:54:14 EDT
Created attachment 132137 [details]
Xorg.0.log from 1.6.0-6.modeset version of i810 driver
Comment 5 Konstantin Ryabitsev 2006-07-09 13:10:14 EDT
Yeah, I see it too, except it's much worse for me, since my Mactel Mini now
insists on always going for the 2560x1600 on a 1680x1050 screen, forcing a
virtual display. I'll see if I can find a previous RPM to revert to.
Comment 6 Adam Jackson 2006-07-09 15:42:10 EDT
This appears to be the problem:

(II) I810(0): Found panel of size 1024x768 in BIOS VBT tables

Although this is also pretty hilarious:

(II) I810(0): Not using default mode "640x350" (height too large for virtual size)

I'm looking into it.
Comment 7 Konstantin Ryabitsev 2006-07-09 16:25:58 EDT
Yes, it looks like all modes are discarded with "height too large for virtual
size" and then the largest defined in bios is used.
Comment 8 Peter Robinson 2006-07-10 09:33:19 EDT
The new modesetting driver is doing interesting things on my Dell Latitude D620
too. The old driver (xorg-x11-drv-i810-1.6.0-4) gives me a stretched 1024x768
and the new one seems to detect the laptop screen properly but I get garbled
stuff on the screen. Will attach the two log files and the xorg logs and config.
Comment 9 Peter Robinson 2006-07-10 09:35:47 EDT
Created attachment 132170 [details]
xorg config on Dell D620
Comment 10 Peter Robinson 2006-07-10 09:36:44 EDT
Created attachment 132171 [details]
The xorg log file for the modesetting driverr
Comment 11 Peter Robinson 2006-07-10 09:38:31 EDT
Created attachment 132172 [details]
xorg log pre modesetting driver
Comment 12 Paul Dickson 2006-07-13 01:30:43 EDT
I did the equivalent of System->Preferences->Screen Resolution (I have it as an
icon on my top panel) and selected a smaller size than what the screen displays
(selected 1024x768 on a screen that's 1280x800).  The new screen was 1024x768
stretched to 1280x800.  I aborted that mode, that the screen switched to
1280x800 without the extra panning screen area.
Comment 13 Adam Jackson 2006-07-14 14:58:43 EDT
All: As step one, please comment out the following entries in your xorg.conf:
- Any Modes lines in the Screen section
- Any DisplaySize, HorizSync, or VertRefresh commands in the Monitor section
and make sure you're running at least 1.6.0-11*, previous versions did
hilariously wrong things in mode validation.

pbrobinson@: I'm not sure why your config requests 1400x1050, the panel
certainly seems to be 1440x900.  Following the above hints should do something
more sensible.

selinux@: Everything I'm finding about the Thinkpad X41 indicates that it really
is 1024x768.  Try this for me, when you have X running:
- Xnest -ac -noreset :2
- DISPLAY=:2 xsetroot -gray
The Xnest window should fill with the traditional X root weave background.  If
it looks like alternating white and black squares, you're running at the native
panel resolution (or a power-of-two factor, I suppose); if it looks like a
head-exploding striped interference pattern, you're not.
Comment 14 Adam Jackson 2006-07-14 15:04:58 EDT
Also please make sure you are _not_ using the 855resolution or 915resolution
hacks, they're known to interact badly.
Comment 15 Tom London 2006-07-14 15:18:53 EDT
I installed Xnest, but I get a seg fault when I try to run it from gnome/gdm.

Also, the LCD panel of the X41 is indeed 1024x768, but the adapter supports
higher for external monitors. I typically run with the laptop-lid shut, only
driving the external monitor at 1280x1024.

I'm installing latest xorg-x11-drv-i810 driver. I've made the xorg.conf changes,
and will report after install is complete.
Comment 16 Adam Jackson 2006-07-14 15:30:05 EDT
(In reply to comment #15)
> I installed Xnest, but I get a seg fault when I try to run it from gnome/gdm.

Can you open a new bug for this please?

Comment 17 Tom London 2006-07-14 15:47:21 EDT
Filed against 'xorg-x11-server' (couldn't find bz dropdown for Xnest)

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=198930
Comment 18 Tom London 2006-07-14 19:41:26 EDT
OK, installed 'new' i810 driver and made changes to xorg.conf as describe in
comment #13.

'Fails' the same way as before: 1024x768 'panning' mode, instead of 1280x1024.

Xorg.0.log appears the same as with previous modeset driver:  Lots of 'height
too large for virtural ....'

I've reverted back to xorg-x11-drv-i810-1.6.0-5
Comment 19 Konstantin Ryabitsev 2006-07-15 11:17:33 EDT
xorg-x11-drv-i810-1.6.0-11.20060713modeset.fc6

Confirmed working on Mactel Mini. It now correctly goes into 1680x1050 without
having to resort to 915resolution or other hacks. Thanks bunches! Logs/configs
available upon request.
Comment 20 Yijun Yuan 2006-07-15 22:03:48 EDT
Created attachment 132517 [details]
xorg-x11-drv-i810-1.6.0-11.20060713modeset.fc6 log files on Dell 640m/e1405

xorg-x11-drv-i810-1.6.0-11.20060713modeset.fc6 don't work for me. In fact, all
modeset version don't work, when I'm running start& the screen goes a kind of
black. Driver prior to that works with 915resolution. I'm not running
915resolution this time.

In the attachment there is the xorg.conf, Xorg.0.log, lspci-v, dmesg, etc.
Comment 21 Adam Jackson 2006-07-15 22:27:56 EDT
(In reply to comment #18)
> OK, installed 'new' i810 driver and made changes to xorg.conf as describe in
> comment #13.
> 
> 'Fails' the same way as before: 1024x768 'panning' mode, instead of 1280x1024.
> 
> Xorg.0.log appears the same as with previous modeset driver:  Lots of 'height
> too large for virtural ....'

So, the behaviour you'd prefer is that the external monitor be run at 1280x1024
native, and the internal panel either in 10x7 pan-and-scan or turned off,
correct?  Either of those are doable I think, I'm just not sure which option to
prefer.  (Sadly it's not possible to use the panel's scaler to filter _down_
from 1280x1024 to 1024x768.)
Comment 22 Tom London 2006-07-16 12:24:12 EDT
To be as clear as possible, here is the behavior I think is 'expected. (Please
reset expectations if I have them wrong....):

1. When there is no external monitor connected, or when the laptop display is
'selected', the display should be in max supported/configured resolution.  In my
case (Thinkpad X41) this should be 1024x768, no?
2. When there is an external monitor connected and 'active', and when the laptop
display is not 'active', the resolution should be in the max
supported/configured resolution. I typically connect to 2 different LCD
displays, one supports a max of 1280x1024, the other goes higher. Regardless, at
least 1280x1024 should be selected.

I do not want pan and scan in either case (laptop LCD active, or external
monitor active).  Previous drivers never came up in pan and scan.

Also, once the pan and scan mode 'starts', I can't seem to get out of it except
to System->Admin->Display and display a particular resolution (e.g., 1280x1024)
that gets put in xorg.conf, and to restart Xorg.

Am I just thinking about this wrong?

tom
Comment 23 Kevin DeKorte 2006-07-17 09:56:04 EDT
Created attachment 132545 [details]
Xorg log file for Aopen mini pc
Comment 24 Kevin DeKorte 2006-07-17 09:57:05 EDT
driver: xorg-x11-drv-i810-1.6.0-11.20060713modeset.fc6

Hardware: Aopen MiniPC with built in i915 video card. External 19" display is a
Hyundai L90D+, connection type DVI.

Previous driver detected 1280x1024 mode with no problem. The current driver does
not. I will attach Xorg.0.log and xorg.conf to this bug
Comment 25 Kevin DeKorte 2006-07-17 09:58:18 EDT
Created attachment 132546 [details]
Xorg conf file for Aopen mini pc
Comment 26 Kevin DeKorte 2006-07-17 10:52:12 EDT
switching the driver on my MiniPC back to xorg-x11-drv-i810-1.6.0-4 and not
changing anything in the xorg.conf file, allows the default rez of 1280x1024 to
work again. Attaching working Xorg.0.log file
Comment 27 Kevin DeKorte 2006-07-17 10:53:24 EDT
Created attachment 132548 [details]
Log file for older driver on Aopen MiniPC that works correctly
Comment 28 Paul Dickson 2006-07-17 22:00:28 EDT
xorg-x11-drv-i810-1.6.0-11.20060713modeset.fc6:
This works for me without having to edit xorg.conf (although I did run
system-config-display while I had problem, but without positive results).

Both GDM and my session start with the correct native resolution for my
notebook's display (1280x800).

But System->Preferences->Screen Resolution no longer offers the 1024x768
resolution.  It does offer 800x600 though.  Is the lack of 1024x768 normal?  I'd
like to hookup a projector and press F8 while in 1024x768 (the native resolution
for the projector).  Most of the time, I don't have access to the projector, so
I can't play around with settings.  I like the 1024x768 setting with unused
sides of the screen being black to preset my system.
Comment 29 Bojan Smojver 2006-07-21 23:29:08 EDT
Exactly the same thing as comment #20 on Dell Inspiron 6400 with 1680x1050 LCD
panel. Blank screen with X running.

Driver shipped with FC6T1 (and the one from FC5 AIGLX repository) works fine
with 915resolution.
Comment 30 Tom London 2006-07-25 11:05:01 EDT
xorg-x11-drv-i810-1.6.0-12.20060717modeset.fc6 fails on my Thinkpad X41.

I get server crash with xorg.conf containing mode/sync lines.  Removing them
'cures' crash, but all I get is 'pan and scan' mode again.

Reverting to xorg-x11-drv-i810-1.6.0-5 restores 1280x1024 function again (after
uncommenting mode/sync lines in xorg.conf)
Comment 31 Tom London 2006-07-25 11:08:02 EDT
Content of gdm/:0.log for server crash:


X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.9-34.ELsmp i686 Red Hat, Inc.
Current Operating System: Linux localhost.localdomain 2.6.17-1.2445.fc6 #1 SMP
Mon Jul 24 22:43:31 EDT 2006 i686
Build Date: 24 July 2006
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Jul 25 07:19:12 2006
(==) Using config file: "/etc/X11/xorg.conf"
(WW) I810: No matching Device section for instance (BusID PCI:0:2:1) found
(EE) I810(0): Unable to read from SDVOCTRL_E Slave 112.
(EE) I810(0): Unable to read from SDVOCTRL_E Slave 114.
(EE) I810(0): DDC Analog 0, 00005010
(EE) I810(0): DDC LVDS 1, 00005018
Executing (ax == 0x5f01) BIOS call at i830_driver.c:617
Couldn't get established mode 5
Couldn't get established mode 12
(EE) I810(0): Modeline "1280x1024x75"x75.0  135.00  1280 1296 1440 1688  1024
1025 1028 1066 +hsync +vsync (80.0 kHz)
(EE) I810(0): Modeline "1280x1024x75"x75.0  135.00  1280 1296 1440 1688  1024
1025 1028 1066 +hsync +vsync (80.0 kHz)
(EE) I810(0): Modeline "1280x1024x60"x60.0  108.78  1280 1360 1496 1712  1024
1025 1028 1059 (63.5 kHz)

Fatal server error:
No modes found

Comment 32 Kevin DeKorte 2006-07-25 12:43:28 EDT
I agree the new driver does NOT fix the problem on my MiniPC as well. It has a
virtual size of 1280x1024 but an actual screen size of 800x600 so it goes into a
pan and scan mode. The driver should detect my screen size as 1280x1024 and use
that resolution. Reverting to the -4 version of the driver does not have this
problem.
Comment 33 Peter Robinson 2006-07-27 05:46:50 EDT
The 1.6.0-12.20060717modeset.fc6 version also makes no difference to the
previous modeset versions on my Dell D620 either.
Comment 34 Kevin DeKorte 2006-08-02 14:00:02 EDT
Are there any updates to this bug? This driver kinda sucks at the moment. Any
updates would be appreciated. Is there any information I can provide to help to
debug this issue.
Comment 35 Tom London 2006-08-03 10:00:07 EDT
Created attachment 133556 [details]
Xorg.0.log from 1.6.0-13 version of i810 driver
Comment 36 Tom London 2006-08-03 10:01:33 EDT
Created attachment 133557 [details]
Xorg.setup.log
Comment 37 Tom London 2006-08-03 10:12:18 EDT
Hmmm.... BZ dropped my comments for comment 35 and 36.

xorg-x11-drv-i810-1.6.0-13.20060717modeset.fc6 still fails badly on my Thinkpad
X41.  I had to revert to xorg-x11-drv-i810-1.6.0-5.

Above two attachments are Xorg.0.log and Xorg.setup.log.
Comment 38 Kevin DeKorte 2006-08-03 13:15:38 EDT
xorg-x11-drv-i810-1.6.0-13.20060717modeset.fc6 is still failing on my MiniPC...
Attaching Xorg.0.log
Comment 39 Kevin DeKorte 2006-08-03 13:16:49 EDT
Created attachment 133567 [details]
Xorg.0.log for failing 1.6-13 driver
Comment 40 Adam Jackson 2006-08-03 18:50:21 EDT
(In reply to comment #22)
> To be as clear as possible, here is the behavior I think is 'expected. (Please
> reset expectations if I have them wrong....):
> 
> 1. When there is no external monitor connected, or when the laptop display is
> 'selected', the display should be in max supported/configured resolution.  In my
> case (Thinkpad X41) this should be 1024x768, no?

I suppose.  How do you determine "selected" ?

> 2. When there is an external monitor connected and 'active', and when the laptop
> display is not 'active', the resolution should be in the max
> supported/configured resolution. I typically connect to 2 different LCD
> displays, one supports a max of 1280x1024, the other goes higher. Regardless, at
> least 1280x1024 should be selected.

Again, define "active".

> Also, once the pan and scan mode 'starts', I can't seem to get out of it except
> to System->Admin->Display and display a particular resolution (e.g., 1280x1024)
> that gets put in xorg.conf, and to restart Xorg.

System / Preferences / Screen Resolution should allow you to set to a smaller mode.
Comment 41 Adam Jackson 2006-08-03 18:55:17 EDT
(In reply to comment #24)
> driver: xorg-x11-drv-i810-1.6.0-11.20060713modeset.fc6
> 
> Hardware: Aopen MiniPC with built in i915 video card. External 19" display is a
> Hyundai L90D+, connection type DVI.
> 
> Previous driver detected 1280x1024 mode with no problem. The current driver does
> not. I will attach Xorg.0.log and xorg.conf to this bug

Just acquired this box, actually.  The bug is that the BIOS claims there's an
LFP connected, and so the driver attempts to clamp the mode pool to the size of
the LFP.  Except that there's no LFP on that box, so you lose.  You should be
able to work around it for the moment by saying:

Option "MonitorLayout" "DFP,NONE"

in the appropriate Device section of your xorg.conf, but I'll probably end up
blacklisting that hardware to ignore BIOS-reported LFP (fortunately the
subvendor/subdevice pair identifies it as an AOpen board).
Comment 42 Adam Jackson 2006-08-03 18:58:33 EDT
(In reply to comment #28)

> But System->Preferences->Screen Resolution no longer offers the 1024x768
> resolution.  It does offer 800x600 though.  Is the lack of 1024x768 normal?  I'd
> like to hookup a projector and press F8 while in 1024x768 (the native resolution
> for the projector).  Most of the time, I don't have access to the projector, so
> I can't play around with settings.  I like the 1024x768 setting with unused
> sides of the screen being black to preset my system.

What _should_ happen now is that if you start the Screen Resolution applet after
connecting the panel, the driver will re-probe all outputs, and the 10x7 mode
should magically appear in the list.
Comment 43 Adam Jackson 2006-08-03 19:07:09 EDT
(In reply to comment #35)
> Created an attachment (id=133556) [edit]
> Xorg.0.log from 1.6.0-6.modeset version of i810 driver

This concerns me:

(II) I810(0): Ranges: V min: 30  V max: 85 Hz, H min: 31  H max: 80 kHz,
PixClock max 140 MHz
...
(II) I810(0): Ignoring EDID Ranges. Using configured ranges.

That would seem to indicate that your config file still has sync ranges listed
for the monitor, which shouldn't be necessary.  There's definitely at least one
bug in the way the new code is handling sync ranges though; I'm building
xorg-x11-server-1.1.1-15 with a fix.

Also I realized that you're defining "LFP active" to mean something like "lid
open and enabled through BIOS hotkeys", which is sensible.  The hotkey thing
should be easy enough, the lid detection might be harder, I know how to get edge
triggers for it from ACPI but not status level yet.
Comment 44 Kevin DeKorte 2006-08-03 20:17:19 EDT
(In reply to comment #41)

> Option "MonitorLayout" "DFP,NONE"

Ok, I added this to my xorg.conf file and it is better... but not quite right..

The modes from xrandr are odd..

Using driver:
xorg-x11-drv-i810-1.6.0-13.20060717modeset.fc6


xrandr
 SZ:    Pixels          Physical       Refresh
*0   1280 x 1024   ( 373mm x 302mm )  *60  
 1   1024 x 768    ( 373mm x 302mm )   60  
 2    800 x 600    ( 373mm x 302mm )   60  
 3    640 x 480    ( 373mm x 302mm )   60  
 4   1280 x 960    ( 373mm x 302mm )   60  
 5   1152 x 864    ( 373mm x 302mm )   60  
 6   1280 x 720    ( 373mm x 302mm )   60  
 7   1280 x 800    ( 373mm x 302mm )   60  
 8   1280 x 768    ( 373mm x 302mm )   60  
 9   1440 x 900    ( 373mm x 302mm )   60  
 10  1600 x 1024   ( 373mm x 302mm )   60  
Current rotation - normal
Current reflection - none
Rotations possible - normal left inverted right 
Reflections possible - none


So the machine thinks my monitor is 1600x1024... vertical is right, but the
display has a virtual desktop that is too big (monitor is only 1280x1024) and so
the display "slides" left and right

I'll attach the log..
Comment 45 Kevin DeKorte 2006-08-03 20:19:45 EDT
Created attachment 133597 [details]
Results after putting Option "MonitorLayout"  "DFP,NONE" in xorg.conf

Results after putting Option "MonitorLayout"  "DFP,NONE" in xorg.conf for Aopen
MiniPC 915-B
Comment 46 Tom London 2006-08-03 21:48:09 EDT
(In reply to comment #43)

OK. I removed the mode lines from xorg.conf (sorry!) and restarted. The server
no longer crashes, but I'm back to pan and scan on top of 800x600.

I added Option "MonitorLayout" "DFP,NONE" to xorg.conf, and now get a usable system:

[tbl@localhost ~]$ xrandr
 SZ:    Pixels          Physical       Refresh
*0   1280 x 1024   ( 342mm x 272mm )  *75   60  
 1   1024 x 768    ( 342mm x 272mm )   75   70   60  
 2    800 x 600    ( 342mm x 272mm )   72   75   60   56  
 3    640 x 480    ( 342mm x 272mm )   73   75   60  
 4   1152 x 864    ( 342mm x 272mm )   75   60   70  
 5   1280 x 960    ( 342mm x 272mm )   60  
 6    832 x 624    ( 342mm x 272mm )   75  
 7   1280 x 720    ( 342mm x 272mm )   60   70   75  
 8   1280 x 800    ( 342mm x 272mm )   60   70   75  
 9   1280 x 768    ( 342mm x 272mm )   60   70   75  
 10  1400 x 1050   ( 342mm x 272mm )   60  
 11  1440 x 900    ( 342mm x 272mm )   60  
 12  1600 x 1024   ( 342mm x 272mm )   60  
 13   720 x 400    ( 342mm x 272mm )   70  
 14  1600 x 1050   ( 342mm x 272mm )   75  
Current rotation - normal
Current reflection - none
Rotations possible - normal left inverted right 
Reflections possible - none
[tbl@localhost ~]$ 

[Previously was only getting 1024x768@59, 800x600@59 and something like 812x622@59.]

I can now select 1280x1024, etc.

I attach Xorg.0.log below.
Comment 47 Tom London 2006-08-03 21:49:48 EDT
Created attachment 133605 [details]
Xorg.0.log from xorg-x11-drv-i810-1.6.0-13.20060717modeset.fc6
Comment 48 Adam Jackson 2006-08-04 01:08:29 EDT
(In reply to comment #44)
> So the machine thinks my monitor is 1600x1024... vertical is right, but the
> display has a virtual desktop that is too big (monitor is only 1280x1024) and so
> the display "slides" left and right

Gah.  The 1600x1024 mode raises its ugly head again.  I'll move that to the i128
driver where it belongs, thanks for the catch.
Comment 49 Adam Jackson 2006-08-04 01:26:54 EDT
(In reply to comment #46)
> I added Option "MonitorLayout" "DFP,NONE" to xorg.conf, and now get a usable
system:
> 
> [tbl@localhost ~]$ xrandr
>  SZ:    Pixels          Physical       Refresh
> *0   1280 x 1024   ( 342mm x 272mm )  *75   60  
>  1   1024 x 768    ( 342mm x 272mm )   75   70   60  
>  2    800 x 600    ( 342mm x 272mm )   72   75   60   56  
>  3    640 x 480    ( 342mm x 272mm )   73   75   60  
>  4   1152 x 864    ( 342mm x 272mm )   75   60   70  
>  5   1280 x 960    ( 342mm x 272mm )   60  
>  6    832 x 624    ( 342mm x 272mm )   75  
>  7   1280 x 720    ( 342mm x 272mm )   60   70   75  
>  8   1280 x 800    ( 342mm x 272mm )   60   70   75  
>  9   1280 x 768    ( 342mm x 272mm )   60   70   75  
>  10  1400 x 1050   ( 342mm x 272mm )   60  
>  11  1440 x 900    ( 342mm x 272mm )   60  
>  12  1600 x 1024   ( 342mm x 272mm )   60  
>  13   720 x 400    ( 342mm x 272mm )   70  
>  14  1600 x 1050   ( 342mm x 272mm )   75  
> Current rotation - normal
> Current reflection - none
> Rotations possible - normal left inverted right 
> Reflections possible - none
> [tbl@localhost ~]$ 

That looks a bit better, although the virtual sizing is still messed up, and
synthesizing a mode for 1600x1050 is clearly insane.

Can you attach the X log from without the MonitorLayout option, so I can see how
it's going wrong?
Comment 50 Kevin DeKorte 2006-08-04 08:57:47 EDT
I don't know if I should put this here, or open a new bug. But with the latest
driver the DPMS mode where the monitor goes into standby is now broken. It works
fine in 1.6.0-4, but no longer works in 1.6.0-13.20060717modeset. I tried it
with and without the MonitorLayout option and that does not seem to affect it.

xdpyinfo does show the DPMS extension as being loaded. And xset shows it as
being enabled. This problem showed up before in this driver and was fixed. Maybe
we have a regression in that code.
Comment 51 Tom London 2006-08-04 09:38:30 EDT
(In reply to comment #49)

Xorg.0.log attached below
Comment 52 Tom London 2006-08-04 09:40:26 EDT
Created attachment 133634 [details]
Xorg.0.log with no MonitorLayout option in xorg.conf
Comment 53 Adam Jackson 2006-08-04 10:46:59 EDT
(In reply to comment #50)
> I don't know if I should put this here, or open a new bug. But with the latest
> driver the DPMS mode where the monitor goes into standby is now broken. It works
> fine in 1.6.0-4, but no longer works in 1.6.0-13.20060717modeset. I tried it
> with and without the MonitorLayout option and that does not seem to affect it.

New bug, please.  It would be helpful if you could identify which revision
introduced the bug.
Comment 54 Paul Dickson 2006-08-05 14:15:04 EDT
Created attachment 133695 [details]
Xorg.0.log

xorg-x11-drv-i810-1.6.0-13.20060717modeset.fc6

randr:
 SZ:	Pixels		Physical       Refresh
*0   1280 x 800    ( 330mm x 211mm )  *64  
 1   1280 x 768    ( 330mm x 211mm )   60  
 2   1280 x 720    ( 330mm x 211mm )   60  
 3   1152 x 768    ( 330mm x 211mm )   60  
 4   1024 x 768    ( 330mm x 211mm )   60  
 5    832 x 624    ( 330mm x 211mm )   60  
 6    800 x 600    ( 330mm x 211mm )   60  
 7   1600 x 1024   ( 330mm x 211mm )   64  
Current rotation - normal
Current reflection - none
Rotations possible - normal left inverted right 
Reflections possible - none

GDM starts with 1600x1024 (I believe), but after I login, the screen switches
to 1280x800.

I have an "NEC AccuSync 50" attached to this laptop.  Both are displaying right
now.  

The Xorg.0.log has a mark added by me where I switched the screen resolution
from 1280x800 to 1024x768.  The xorg-x11 wants to display 1024x768 on the
notebook's LCD panel in stretch mode.  Can't xorg-x11 display 1024x768 normally
on the CRT and with black margins on the 1280x800 LCD panel?  Why can't I have
640x480 (with black margins) for modes like TV output (the notebook has a
SVideo output)?

BTW - If I press Fn-F8 (the CRT/LCD toggler), xorg-x11 either crashes (goes
back to GDM) or stops displaying.

Can this chipset be used for dual-heading (LCD and CRT separately)?
Comment 55 Paul Dickson 2006-08-05 19:03:47 EDT
On a fresh reboot, I'm no longer seeing the 1600x1024 entry.
Comment 56 Peter Robinson 2006-08-07 17:11:46 EDT
Created attachment 133760 [details]
i845 on Dell D620

Hmm, not sure why suddenly, but now the 1440x900 resolution has suddenly
started working (I was previously stuck at a streches 1024.768). I had left my
machine at work over the weekend and it had had some updates (Friday and Sat)
without logout as well as possible a change to xorg.conf (comment out the
following 2 lines).
#	HorizSync    31.5 - 100.0
#	VertRefresh  59.0 - 75.0

xorg-x11-server-Xorg-1.1.1-14.fc6
xorg-x11-drv-i810-1.6.0-4
915resolution-0.5.2-5.fc5.90.at

So its still without the modsetting driver but is at least running at the right
res now. I had installed the 915resolution and put the following line in my
rc.local but it hadn't really had much effect to date so I'm not sure what
'fixed' it.
/usr/sbin/915resolution 5c 1440 900 &

xorg.conf attached.... will also add xorg.0.log too
Comment 57 Peter Robinson 2006-08-07 17:25:56 EDT
Created attachment 133761 [details]
xorg log for i945 on Dell D620

attaching the log. Also note the comment 56 above is for a i945 (not i845 as
mentioned.
Comment 58 Paul F. Johnson 2006-08-09 04:36:42 EDT
Using a Toshiba Sat Pro (i845 chipset from memory).

When I fire up with xorg-x11-drv-i810-1.60-13.20060717modeset, X fails to start
and gives the following throwback

EE : I810 : detecting sil164
EE : Unable to read from DVOIC2_E Slave 112
EE : detecting ch7xxx
EE : Unable to read from DVOIC2_E Slave 236
EE : DDC Analogue, 00005010
EE : DDC LVDSE1, 00005018
EE : DDC DVO2, 00005012

Executing (ax == 0x5f01) BIOS CPU @ i830_drive.c: 617
Fatal server error
  No modes found on either pipe

Reverting back to 1.6.0-4 and X works again. 0-5 also works, all of the modeset
updates break X
Comment 59 Rene Rask 2006-08-09 06:49:30 EDT
Created attachment 133840 [details]
Xorg.0.log on an LG T1 Dual Express with org-x11-drv-i810-1.60-13.20060717modeset

The regular non-modesetting branch works fine with i915resolution.
i915resolution was disabled for this test.
I get what is a pretty cool almost organic decay of the screen when Xorg
starts. Just colors warping no real outlines or garbage on the display.
Comment 60 Kevin DeKorte 2006-08-09 11:26:51 EDT
Just some more info on this driver

With 1.6.0-4 I can use CTRL-ALT-F1 to switch to a text console
With 1.6.0-*modeset* I lose the text console (monitor gives me an invalid video
mode message on the screen), but I can get it back by enabling the kernel frame
buffer driver by adding vga=795 to the kernel line in grub. That setting is
1280x1024x32bit. I got the value from this page:
http://ruslug.rutgers.edu/~mcgrof/HOWTOS/framebuffer/framebuffer.php

Now I can switch to vt1 and fix things if X is broken. 
Comment 61 Yijun Yuan 2006-08-18 12:26:45 EDT
Created attachment 134456 [details]
xorg-x11-drv-i810-1.6.5-3.fc6 on Dell 640m/e1405

The "intel" driver still doesn't work for me, the screen turns grey when
startx.
The "i810" driver requires 915resolution to work, drm is ok.
Comment 62 Rene Rask 2006-09-15 16:36:05 EDT
What information can I provide that can help you make the modesetting driver
work? Is the Xorg.log all that you need?

I just tested version 1.6.5-5 of the intel driver from fc6 test3 on my fc5
install and it still doesn't work.

I don't know what you are looking for so it is hard to provide helpful details.

These are my lspci details:
00:02.0 VGA compatible controller: Intel Corporation Mobile Integrated Graphics
Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile Integrated Graphics
Controller (rev 03)

with the pci ids:
00:02.0 0300: 8086:27a2 (rev 03)
00:02.1 0380: 8086:27a6 (rev 03)
Comment 63 Christian Weiske 2006-10-25 17:50:59 EDT
I get the scrambled and flickering screen with the current modesetting branch 
of version 1.72 of the driver. My system is an Acer Travelmate 6003 with i855GM 
chip. Native display resolution is 1400x1050 which is actually detected - the 
flickering lines are actually display lines and not interlaced, and Xorg.0.log 
shows me that it detected the resolution. Attaching part of the log.

Btw, two constants are still not defined:
http://lists.freedesktop.org/archives/xorg/2006-October/018652.html
Comment 64 Christian Weiske 2006-10-25 17:52:52 EDT
Created attachment 139410 [details]
flickering xorg.log modelines
Comment 65 Daniel Pacheco 2006-11-07 21:00:23 EST
FC6 These instructions helped me to get 1440x900 video resolution in my Toshiba
Satellite laptop, everything looks great now:

http://forums.fedoraforum.org/showthread.php?t=133789

Fedora Core 6
Toshiba Satellite P105-S6024
Video card: Intel 945GM Express
Video drive: i810
Comment 66 Adam Jackson 2007-04-04 13:04:32 EDT
Wow, long time since this one was touched.  Anyone still having issues with this
driver should try again with 1.6.5-17 or newer, which includes a _very_ new
modesetting driver.
Comment 67 Tom London 2007-04-04 18:36:46 EDT
On my X60, I've been running with the driver set to i810 (not intel) for a long
while with no problems.  (Usually run the X60 in a dock connected to an LCD. 
Believe one LCD is quite old ....)

Setting the driver to "intel" has not worked for me.

Believe I have no mode setting lines in xorg.conf.

This the expected behavior?
Comment 69 Yijun Yuan 2007-04-05 09:16:01 EDT
(In reply to comment #66)
> Wow, long time since this one was touched.  Anyone still having issues with this
> driver should try again with 1.6.5-17 or newer, which includes a _very_ new
> modesetting driver.

"intel" driver works for me now.
Dell 640m/e1405, 945G, xorg-x11-drv-i810-1.6.5-17.fc7


[root@mstar ~]# lspci -v
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT
Express Memory Controller Hub (rev 03)
        Subsystem: Dell Unknown device 01d8
        Flags: bus master, fast devsel, latency 0
        Capabilities: [e0] Vendor Specific Information

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS/940GML
Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA])
        Subsystem: Dell Unknown device 01d8
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at eff00000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at eff8 [size=8]
        Memory at d0000000 (32-bit, prefetchable) [size=256M]
        Memory at efec0000 (32-bit, non-prefetchable) [size=256K]
        Capabilities: [90] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
        Capabilities: [d0] Power Management version 2

00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/940GML Express
Integrated Graphics Controller (rev 03)
        Subsystem: Dell Unknown device 01d8
        Flags: bus master, fast devsel, latency 0
        Memory at eff80000 (32-bit, non-prefetchable) [size=512K]
        Capabilities: [d0] Power Management version 2

Comment 70 Tom London 2007-04-05 12:25:05 EDT
Created attachment 151778 [details]
Xorg.0.log from 'intel' run

Updated to 1.6.5-17, and my Thinkpad X60 behaves differently than before.

With new driver, and xorg.conf set to i810, all works.

With new driver, and xorg.conf set to intel, both my LCD displays complain
about the frequency settings (OCD displays, eventually, displays sleep).

On my 'newer' display, using resolution of 1280x1024, it states that 'intel' is
using H-ref of 83kHz, V-ref of 78 Hz. 

Here is 'xrandr' running under i810:

[root@localhost ~]# xrandr
Screen 0: minimum 640 x 480, current 1280 x 1024, maximum 1680 x 1050
default connected 1280x1024+0+0 (normal left inverted right) 0mm x 0mm
   1680x1050	  56.0	
   1280x1024	  75.0* 
   1440x900	  60.0	
   1280x800	  75.0	
   1024x768	  75.0	
   800x600	  75.0	
   640x480	  75.0	
[root@localhost ~]# 

Below is my xorg.conf.	I just 'toggle' i810/intel:

# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen	    0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "ServerFlags"
	Option	    "AllowMouseOpenFail" "yes"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver	    "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	ModelName    "LCD Panel 1280x1024"
 ### Comment all HorizSync and VertSync values to use DDC:
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver	    "i810"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device	   "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth	 24
EndSection


Attaching Xorg.0.log from both 'intel' and 'i810' runs.
Comment 71 Tom London 2007-04-05 12:26:24 EDT
Created attachment 151779 [details]
Xorg.0.log from 'intel' run (previous was for i810, sorry)
Comment 72 Kevin DeKorte 2007-04-05 13:56:19 EDT
I have a similar problem. With the i810 driver everything works fine for the
most part. When I use the intel driver with everything else the same. My display
will randomly go dark and come back (almost like it is losing sync and getting
it back before the monitor can put up the error message). The display I am using
in a 1680x1050 LCD connected over DVI. The machine I have is a Aopen Mini PC
915-B. Also the frequency of going black increases the longer I use the machine.
I'm using a very minimal xorg.conf as generated by starting X. And adding the
one line about XAA bitmaps.

 more /etc/X11/xorg.conf
# Xorg configuration created by system-config-display

Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "i810"
        Option      "XAANoOffscreenPixmaps" "true"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

Comment 73 Rene Rask 2007-04-08 12:01:58 EDT
I've got a tablet pc which doesn't allow me to run at the native 1024x768
resolution. This is mostly a question about the modesetting selection routine.
As the list of modes below show, the 1024x600 mode is after the 1024x768 mode.
It seems the driver always selects that mode even though I explicitly configure
xorg.conf to only use 1024x768.
Is there a faulty logic in the selection routine which assumes that the higher
the mode number is the higher the resolution is. Or perhaps it only looks at the
horizontal resolution.
The default vga mode works for the text console, 800x600 works for X. 1024x600
works for X but is letterboxed (like 16:9 movies are on a 4:3 monitor). So the
display is running 1024x768 but X is only using 1024x600.
I've been testing this with the xorg server from the fedora development
repository and with the xorg from FC6.
Is there a way to force the driver to select one specific mode by id? Like mode
45 or 54.

855resolution version 0.4, by Alain Poirier
Chipset: Unknown (id=0x35758086)
VBIOS type: 3
VBIOS Version: 2756
Mode 30 : 640x480, 8 bits/pixel
Mode 31 : 640x400, 8 bits/pixel
Mode 32 : 800x600, 8 bits/pixel
Mode 34 : 1024x768, 8 bits/pixel
Mode 36 : 1024x600, 8 bits/pixel
Mode 38 : 1280x1024, 8 bits/pixel
Mode 3a : 1600x1200, 8 bits/pixel
Mode 3c : 1920x1440, 8 bits/pixel
Mode 40 : 640x480, 15 bits/pixel
Mode 41 : 640x480, 16 bits/pixel
Mode 42 : 800x600, 15 bits/pixel
Mode 43 : 800x600, 16 bits/pixel
Mode 44 : 1024x768, 15 bits/pixel
Mode 45 : 1024x768, 16 bits/pixel
Mode 46 : 1024x600, 15 bits/pixel
Mode 47 : 1024x600, 16 bits/pixel
Mode 48 : 1280x1024, 15 bits/pixel
Mode 49 : 1280x1024, 16 bits/pixel
Mode 4a : 1600x1200, 15 bits/pixel
Mode 4b : 1600x1200, 16 bits/pixel
Mode 4c : 1920x1440, 15 bits/pixel
Mode 4d : 1920x1440, 16 bits/pixel
Mode 50 : 640x480, 32 bits/pixel
Mode 52 : 800x600, 32 bits/pixel
Mode 54 : 1024x768, 32 bits/pixel
Mode 56 : 1024x600, 32 bits/pixel
Mode 58 : 1280x1024, 32 bits/pixel
Mode 5a : 1600x1200, 32 bits/pixel
Mode 5c : 1920x1440, 32 bits/pixel
Comment 74 Tom London 2007-04-11 15:35:31 EDT
I can get my Thinkpad X60 'working' using 'intel' instead of 'i810' by the
following:

It seems that with 'intel', the VertRefresh rate is getting set to 78 (instead
of 60 or 75).

Running 'randr --rate 60' seems to work: monitor is happy, etc.

Here is output from two runs of 'randr'.  The first, when the video was set at
78Hz (as reported by the little popup from my monitor), the second after running
'randr --rate 60'.

[tbl@localhost ~]$ xrandr
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 1280 x 1280
VGA connected 1280x1024+0+0 (normal left inverted right) 376mm x 301mm
   1280x1024      60.0 +   75.0*    59.9  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3  
   640x480        75.0     72.8     60.0  
   720x400        70.1  
LVDS connected 1024x768+0+0 (normal left inverted right) 246mm x 185mm
   1024x768       50.0*+   60.0     40.0  
   800x600        60.3  
   640x480        60.0     59.9  
TV disconnected (normal left inverted right)
[tbl@localhost ~]$ xrandr --rate 60
[tbl@localhost ~]$ xrandr
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 1280 x 1280
VGA connected 1280x1024+0+0 (normal left inverted right) 376mm x 301mm
   1280x1024      60.0*+   75.0     59.9  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3  
   640x480        75.0     72.8     60.0  
   720x400        70.1  
LVDS connected 1024x768+0+0 (normal left inverted right) 246mm x 185mm
   1024x768       50.0*+   60.0     40.0  
   800x600        60.3  
   640x480        60.0     59.9  
TV disconnected (normal left inverted right)
[tbl@localhost ~]$

I even tried putting 'VertRefresh  60,75' in xorg.conf to no avail.

Here are first few lines from 'lspci':
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT
Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS, 943/940GML
Express Integrated Graphics Controller (rev 03)

Comment 75 Tom London 2007-04-12 10:12:27 EDT
'xrandr --rate 60' makes 'intel' work on my older LCD as well.

'intel' appears to set refresh rate to 77.8Hz instead of 75 or 60.

[root@localhost ~]# xrandr
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 1280 x 1280
VGA connected 1280x1024+0+0 (normal left inverted right) 359mm x 287mm
   1280x1024      75.0     59.9* 
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        75.0     72.8     66.7     60.0  
LVDS connected (normal left inverted right)
   1024x768       50.0 +   60.0     40.0  
   800x600        60.3  
   640x480        60.0     59.9  
TV disconnected (normal left inverted right)
[root@localhost ~]# 

Some of the above 'rates' seem funny ...
Comment 76 Tom London 2007-04-12 10:52:42 EDT
Running with 'intel', and after 'xrandr --rate 60'.

Here is snippet of output from 'xrandr --verbose':

  1280x1024 (0x5f)  135.0MHz
        h: width  1280 start 1296 end 1440 total 1688 skew    0 clock   80.0KHz
        v: height 1024 start 1025 end 1028 total 1066           clock   75.0Hz
  1280x1024 (0x60)  109.0MHz
        h: width  1280 start 1368 end 1496 total 1712 skew    0 clock   63.7KHz
        v: height 1024 start 1027 end 1034 total 1063           clock   59.9Hz

The 'on screen display' of the monitor reports that the clock is actually
109.6MHz, H is 64.0kHz and V is 60.1Hz.

Is this just an apparent discrepency (109.0MHz vs. 109.6MHz, 63.7kHz vs. 64.0,
59.9Hz vs 60.1)?  Could this 'rounding/truncation' be driving 75Hz to 77.8Hz
(and 80KHz to 83KHz)?
Comment 77 Kevin DeKorte 2007-04-12 11:25:04 EDT
Running with the intel driver on FC6 xorg-x11-drv-i810-1.6.5-10.fc6

xrandr reports
 SZ:    Pixels          Physical       Refresh
*0   1680 x 1050   ( 454mm x 281mm )  *60  
 1   1280 x 1024   ( 454mm x 281mm )   75   60  
 2   1024 x 768    ( 454mm x 281mm )   75   70   60  
 3    800 x 600    ( 454mm x 281mm )   72   75   60   56  
 4    640 x 480    ( 454mm x 281mm )   73   75   60   67  
 5   1152 x 864    ( 454mm x 281mm )   75   60   70  
 6   1280 x 960    ( 454mm x 281mm )   60  
 7    832 x 624    ( 454mm x 281mm )   75  
 8   1280 x 720    ( 454mm x 281mm )   60   70   75  
 9   1280 x 800    ( 454mm x 281mm )   60   70   75  
 10  1280 x 768    ( 454mm x 281mm )   60   70   75  
 11  1400 x 1050   ( 454mm x 281mm )   60   70  
 12  1440 x 900    ( 454mm x 281mm )   60  
 13  1600 x 1024   ( 454mm x 281mm )   60  
 14   720 x 400    ( 454mm x 281mm )   70  
Current rotation - normal
Current reflection - none
Rotations possible - normal left inverted right 
Reflections possible - none

BUT only if I specify my MonitorLayout. If I don't specify my monitor layout the
 setup is totally wrong. The display I am using is a Gateway FPD2185W
(1680x1050) LCD connected over DVI. See Comment 45 above

Section "Device"
        Identifier  "Videocard0"
        Driver      "intel"
        Option      "XAANoOffscreenPixmaps" "true"
        Option      "MonitorLayout" "DFP"
EndSection

The machine I have is a Aopen MiniPC 915-B


00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML
Express Graphics Controller (rev 04) (prog-if 00 [VGA])
        Subsystem: AOPEN Inc. Unknown device 0589
        Flags: bus master, fast devsel, latency 0, IRQ 19
        Memory at d0180000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at da00 [size=8]
        Memory at c0000000 (32-bit, prefetchable) [size=256M]
        Memory at d0200000 (32-bit, non-prefetchable) [size=256K]
        Capabilities: <access denied>

00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express
Graphics Controller (rev 04)
        Subsystem: AOPEN Inc. Unknown device 0589
        Flags: bus master, fast devsel, latency 0
        Memory at d0100000 (32-bit, non-prefetchable) [size=512K]
        Capabilities: <access denied>
Comment 78 Bojan Smojver 2007-04-26 20:05:03 EDT
Modesetting driver works fine on Dell Inspiron 6400 with 1280x800 panel here, as
tested with Fedora 7 Test 4 Live CD (i386).
Comment 79 Bojan Smojver 2007-04-26 20:52:09 EDT
Ditto Dell Inspiron 6400 with 1680x1050 panel and F7T4 Live CD (i386).
Comment 80 Bojan Smojver 2007-04-26 21:07:01 EDT
With that higher res display (1680x1050), the display went crazy on my attempt
to reboot (with barely visible white rectangles sprinkled over the black
background). The box hung at that point. Had to press the button to turn it off.
Comment 81 Peter Robinson 2007-05-10 08:03:37 EDT
this works much better for me with my Dell D620 now using Fedora 7 Test 4. So
well in fact that after testing using the live CD I installed it.

I can get a fully working screen on both the internal 1440x900 wide screen and
the external screen. I can't seem to get it working properly across multiple
screens but then I'm not sure what the status of xinerma support is.

Basically the install (well yum upgrade) worked fine. Once running I then
removed the 915resolution command run from rc.local and removed the xorg.conf
file and regenerated it with the 'intel' driver and rebooted and it was all sweet!
Comment 82 MartinG 2007-05-10 16:54:41 EDT
I just tried the Fedora 7 test4 kde live cd, and have added some comments in 
bug #238171 (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=238171) 
regarding some strange behavior on Dell Latitude X1 (widescreen 1280x768 
internal display, intel 915GM/GMS/910GML) and an external monitor set to 
1280x1024, using the 'intel' driver in my xorg.conf. Clone sort of works, but 
spanning desktop results in X freezing white.

(sorry for not putting it here in the first place)

-MartinG

Comment 83 Peter Robinson 2007-05-11 07:08:21 EDT
I'm seeing exactly the same when trying to configure spanning. You configure
spanning and restart X and you just get all white, it seems I can't even go to a
terminal to reset it.

I have the following config:

Dell Latitude D620 Core Duo (not Core2) with a docking station with the
following screens:
- Laptop Panel (1440x900)
- HP LP1965 connected to dock analog (1280x1024)
- HP LP1965 connected to dock digital (1280x1024)

Ideally I'd like to have the 2 HP screens spanned when connected to the dock and
the 1440x900 when not. Not sure if there's enough support in the i945 to run all
3 at once. I suspect I can do this using xrandr commands manually when the
screen doesn't turn white when xinerama is configured.

So at the moment both HP screens are just mirrored when connected (laptop lid
shut) which also brings up another interesting issue. I suspect its more to do
with applications dealing with screens running at different resolutions but when
you maximise some apps they grow to 1440x900 rather than 1280x1024, firefox
seems OK but ForecastFox displays partway up the screen now. Evolution does some
interesting stuff and the mouse pointer disappears off the right of the screen.
Comment 84 Peter Robinson 2007-05-11 07:37:40 EDT
OK. The dual screen bit going white I think should be a different bug as its not
related to modesetting which (for me a least) seem to be much better.

A bit of reading through the X.org list and bugzilla revealed the following for
dual screen reveals the bugzilla entry which indicates that it is supported but
the config setup by the config gui tool does it wrong and it seems crashes the x
driver, so when I get a sec I'm going to try doing it manually (either with
xrandr or manual edit to the config file). There should probably be a bug done
for system-config-display (or whatever the package is to fix this).

https://bugs.freedesktop.org/show_bug.cgi?id=10706

Also saw some comments regarding my disparate display sizes with mice in this
thread http://lists.freedesktop.org/archives/xorg/2007-May/024351.html
Comment 85 Jesse Barnes 2008-01-10 16:35:51 EST
Current intel hardware is only able to drive to displays independently.  So if 
you have 3 connected (laptop LCD + two monitors) at least two will have to be 
clones.  It sounds like the actual modesetting is working ok here though, so 
maybe this bug should be closed out (that and there have been no adds for over 
6 months).
Comment 86 Peter Robinson 2008-01-11 04:54:23 EST
There was only ever a maximum of 2 running at any one time. When it was
connected to the docking station it was the 2 HP LCDs and the laptop lid was closed.
Comment 87 Bug Zapper 2008-05-13 22:11:45 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 88 Peter Robinson 2008-07-18 10:32:51 EDT
I think this can now be closed. with the 2.x series of drivers this has been
alot more stable. In Fedora 9 with a HP nx7400 1680x1050 LCD and a Dell 22inch
1680x1050 LCD attached this all just works. Got to love xrandr!
Comment 89 Adam Jackson 2008-08-11 12:38:49 EDT
Closing as per comment #88.

This bug is clearly tl;dr anyway.  If anyone is still having problems with intel output setup, please file new bugs so we can track them separately rather than dogpiling on this one.

Note You need to log in before you can comment on or make changes to this bug.