Bug 198069 - Invalid ethernet module option 'irq' in modprobe.conf
Invalid ethernet module option 'irq' in modprobe.conf
Status: CLOSED DUPLICATE of bug 198070
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-08 21:44 EDT by David A. Vavra
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-10 05:15:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David A. Vavra 2006-07-08 21:44:23 EDT
Description of problem:

For whatever reason, the network configuration had an added "options yyy 
irq=x" in modprobe.conf for both NICs in my system where x was some number and 
yyy was a NIC module. This option is apparently not accepted by the e100 nor 
natsemi modules. The result was no network connectivity and the interfaces 
could not be enabled.  

Removing the particular "options ..." lines from modprobe.conf fixed the 
problem. FWIW: I also disabled PnP support in the BIOS and disabled any BIOS 
assignment of IRQ values after I discovered the problem. 


Version-Release number of selected component (if applicable):

not sure. 'uname -r' yields 2.6.15-1.2054_FC5


How reproducible:

I only tried one install


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

  Relevant lines in modprobe.conf (IMHO):

alias eth0 natsemi
alias eth1 e100
alias eth2 e1000

options natsemi  irq=4 
options e100  irq=3
Comment 1 Harald Hoyer 2006-07-10 05:15:00 EDT

*** This bug has been marked as a duplicate of 198070 ***

Note You need to log in before you can comment on or make changes to this bug.