Bug 198079 - Graphviz broken: font error
Summary: Graphviz broken: font error
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: graphviz (Show other bugs)
(Show other bugs)
Version: 5
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jima
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-09 08:14 UTC by Marco
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: 2.8-4.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-15 18:08:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A sample DOT file to reproduce the problem (278 bytes, text/plain)
2006-07-09 08:14 UTC, Marco
no flags Details

Description Marco 2006-07-09 08:14:12 UTC
Description of problem:

I've installed RPM: graphviz-2.8-3.fc5.i386

It's seem graphviz isn't able to find fonts specified via "fontname" attribute.
E.g., if you specifiy in a DOT file:
  N1 [
     ...
     fontname="Helvetica",
     ...
  ]
You get the error:

  Error: Could not find/open font : Helvetica in
/usr/X11R6/lib/X11/fonts/TrueType:/usr/X11R6/lib/X11/fonts/truetype:/usr/X11R6/lib/X11/fonts/TTF:/usr/share/fonts/TrueType:/usr/share/fonts/truetype:/usr/openwin/lib/X11/fonts/TrueType:/usr/X11R6/lib/X11/fonts/Type1:/usr/common/share/fonts/ttf

Even setting env variables like DOTFONTPATH or GDFONTPATH or using other fonts
("Times Roman", "Courier", "Bitstream Vera", ...) the problem remains.

However, installing "official" RPM (i.e. RPM downloaded from graphviz site):
  graphviz.i386 0:2.8-1.fc5
  graphviz-cairo.i386 0:2.8-1.fc5
all works.

So I think graphviz FC5-Extras version has a problem
Another related problem is every time I "yum-update", yum says to me I should
update graphviz with the FC5-Extras version since it's version number is higher
(2.8-3) than the official one (2.8-1).

Version-Release number of selected component (if applicable):

2.8-3.fc5.i386

How reproducible:

You need the graphviz FC5-Extras RPM installed. Then you have to create a DOT
file like the one attached to this report. Finally, you execute the DOT command
to generate, for instance, a PNG image.

Steps to Reproduce:
1. Create a DOT file named "myfile.dot" and set the "fontname" node attribute to
"Helvetica" (alternatively, you can use attached file).
2. Execute this command: dot -Tpng myfile.dot >myfile.png
3. You can try to download the "official" (stable) RPM for comparing the behaviour
  
Actual results:

After executing the DOT command you get the following error:

  Error: Could not find/open font : Helvetica in
/usr/X11R6/lib/X11/fonts/TrueType:/usr/X11R6/lib/X11/fonts/truetype:/usr/X11R6/lib/X11/fonts/TTF:/usr/share/fonts/TrueType:/usr/share/fonts/truetype:/usr/openwin/lib/X11/fonts/TrueType:/usr/X11R6/lib/X11/fonts/Type1:/usr/common/share/fonts/ttf

The PNG image is generated, but with a different font (probably the default one).

Expected results:

No error reported by DOT command and all text in the generated image file with
the right font face.

Additional info:

Comment 1 Marco 2006-07-09 08:14:13 UTC
Created attachment 132122 [details]
A sample DOT file to reproduce the problem

Comment 2 Alex Lancaster 2006-09-15 17:52:03 UTC
Latest upgrade graphviz-2.8-4.fc5 (just appeared in repositories) appears to fix
this.  I can't duplicate this error with the new package.

Comment 3 Jima 2006-09-15 18:01:38 UTC
I admit, I'm going to be rather amused if I _accidentally_ fixed this bug.

Comment 4 Alex Lancaster 2006-09-15 18:04:39 UTC
(In reply to comment #3)
> I admit, I'm going to be rather amused if I _accidentally_ fixed this bug.

I suspect it was a side-effect (rather like the missing /usr/bin/lefty) of
fixing the package's broken spec file.

Try and reproduce it yourself, you shouldn't be able to...

Comment 5 Jima 2006-09-15 18:08:35 UTC
As I don't have any data to pump into graphviz (and wouldn't know it if the
results looked correct), I'll take your word for it.  You know the app better
than I.

Taking ownership of bug and closing it out.  Thanks again, Alex.

Comment 6 Alex Lancaster 2006-09-15 18:12:34 UTC
There is an attachment below that you simply save and pump into dot using the
command line mentioned in comment #0, but only if you're curious. ;)

(By the way, shouldn't we move Oliver to the Cc field, just in case, since the
package isn't officially orphaned?  I've seen other maintainers do that.)


Note You need to log in before you can comment on or make changes to this bug.