Bug 198084 - oowriter dies on loading a text file
oowriter dies on loading a text file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-09 07:19 EDT by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.3-7.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-18 04:25:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File which causes oowriter to die (5.58 KB, text/plain)
2006-07-09 07:19 EDT, Paul F. Johnson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 67186 None None None Never

  None (edit)
Description Paul F. Johnson 2006-07-09 07:19:14 EDT
Description of problem:
When I try to load the attached file, oowriter dies. I am loading it via
insert->file. The file loads fine into emacs and there doesn't seem to be
anything out of the ordinary in it.

Version-Release number of selected component (if applicable):
2.0.3-7.4

How reproducible:
Always

Steps to Reproduce:
1. insert->file
2. select the attached file
3.
  
Actual results:
oowriter dies with the following throwback

(I) x.org loaded video driver of...
(II) Loading /usr/lib64/xorg/modules/drivers/nv_drv.so
(III) Desktop is: GNOME
(IV) libgcj version is: libgcj-4.1.1-6-x86_64libgcj-4.1.1-6-i386
(V) kernel is: Linux 2.6.17-1.2339.fc6 #1 SMP Fri Jun 30 01:04:18 EDT 2006
x86_64 x86_64 x86_64
(VI) OpenOffice.org core rpm version is: openoffice.org-core-2.0.3-7.4-x86_64
(VII) accessibility is: false
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
0xb0148a97: /usr/lib64/openoffice.org2.0/program/libuno_sal.so.3 + 0x34a97
0xb01494fa: /usr/lib64/openoffice.org2.0/program/libuno_sal.so.3 + 0x354fa
0xad9359b0: /lib64/libc.so.6 + 0x2f9b0
0xadd74909: /usr/lib64/openoffice.org2.0/program/libvcl680lx.so + 0x123909
(Application::RemoveUserEvent(unsigned long) + 0x9)
0xab8aae97: /usr/lib64/openoffice.org2.0/program/libsw680lx.so + 0x982e97
(SwHTMLParser::~SwHTMLParser() + 0x357)
0xab8af16c: /usr/lib64/openoffice.org2.0/program/libsw680lx.so + 0x98716c
(HTMLReader::Read(SwDoc&, String const&, SwPaM&, String const&) + 0x13c)
0xab846676: /usr/lib64/openoffice.org2.0/program/libsw680lx.so + 0x91e676
(SwReader::Read(Reader const&) + 0x2e6)
0xabb89418: /usr/lib64/openoffice.org2.0/program/libsw680lx.so + 0xc61418
(SwView::InsertDoc(unsigned short, String const&, String const&, short) + 0x368)
0xabaf72ec: /usr/lib64/openoffice.org2.0/program/libsw680lx.so + 0xbcf2ec
(SwTextShell::Execute(SfxRequest&) + 0x31dc)
0xb2d209e7: /usr/lib64/openoffice.org2.0/program/libsfx680lx.so + 0x3459e7
(SfxDispatcher::Call_Impl(SfxShell&, SfxSlot const&, SfxRequest&, unsigned char)
+ 0x237)
0xb2d21111: /usr/lib64/openoffice.org2.0/program/libsfx680lx.so + 0x346111
(SfxDispatcher::PostMsgHandler(SfxRequest*) + 0x121)
0xb2d4ceaa: /usr/lib64/openoffice.org2.0/program/libsfx680lx.so + 0x371eaa
(SfxHintPoster::LinkStubDoEvent_Impl(void*, void*) + 0xa)
0xadf2e891: /usr/lib64/openoffice.org2.0/program/libvcl680lx.so + 0x2dd891
(ImplWindowFrameProc(void*, SalFrame*, unsigned short, void const*) + 0x701)
0xbca4fb36: /usr/lib64/openoffice.org2.0/program/libvclplug_gen680lx.so +
0x68b36 (SalDisplay::DispatchInternalEvent() + 0xb6)
0xbc57cf89: /usr/lib64/openoffice.org2.0/program/libvclplug_gtk680lx.so +
0x1ff89 (GtkXLib::userEventFn(void*) + 0xa9)
0xb75ff5c4: /lib64/libglib-2.0.so.0 + 0x2d5c4 (g_main_context_dispatch + 0x1b4)
0xb760240d: /lib64/libglib-2.0.so.0 + 0x3040d
0xb760293e: /lib64/libglib-2.0.so.0 + 0x3093e (g_main_context_iteration + 0x6e)
0xbc57d448: /usr/lib64/openoffice.org2.0/program/libvclplug_gtk680lx.so +
0x20448 (GtkXLib::Yield(unsigned char) + 0xb8)
0xadd75ff4: /usr/lib64/openoffice.org2.0/program/libvcl680lx.so + 0x124ff4
(Application::Yield() + 0x44)
0xadd76075: /usr/lib64/openoffice.org2.0/program/libvcl680lx.so + 0x125075
(Application::Execute() + 0x25)
0xaacf6f62: /usr/lib64/openoffice.org2.0/program/libsoffice.so + 0x30f62
(desktop::Desktop::Main() + 0x1492)
0xadd7b183: /usr/lib64/openoffice.org2.0/program/libvcl680lx.so + 0x12a183
(ImplSVMain() + 0xe3)
0xadd7b275: /usr/lib64/openoffice.org2.0/program/libvcl680lx.so + 0x12a275
(SVMain() + 0x25)
0xaacea56e: /usr/lib64/openoffice.org2.0/program/libsoffice.so + 0x2456e
(sal_main + 0x3e)
0xad9232b4: /lib64/libc.so.6 + 0x1d2b4 (__libc_start_main + 0xf4)
0x400619: /usr/lib64/openoffice.org2.0/program/swriter.bin + 0x619

Expected results:
The file should load

Additional info:
I can get other plain text files to load using the above method
Comment 1 Paul F. Johnson 2006-07-09 07:19:14 EDT
Created attachment 132126 [details]
File which causes oowriter to die
Comment 2 Caolan McNamara 2006-07-10 09:08:53 EDT
reproducable on x86_64
Comment 3 Caolan McNamara 2006-07-10 09:20:14 EDT
looks like an easy fix, I've attached the patch to
http://www.openoffice.org/issues/show_bug.cgi?id=67186.

Will be in next respin

Note You need to log in before you can comment on or make changes to this bug.