Bug 198094 - m in DejaVu squashed
m in DejaVu squashed
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: dejavu-fonts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nicolas Mailhot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-09 10:41 EDT by Jim Cornette
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-09 12:00:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Created a new profile, (104.41 KB, image/png)
2006-07-09 10:41 EDT, Jim Cornette
no flags Details
even worse renderiing (123.15 KB, image/png)
2006-07-09 10:45 EDT, Jim Cornette
no flags Details
reducing dp1 by 20 dpi (172.72 KB, image/png)
2006-07-09 19:54 EDT, Jim Cornette
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 7466 None None None Never

  None (edit)
Description Jim Cornette 2006-07-09 10:41:14 EDT
Description of problem:

When viewing the font within the gnome-terminal and various applications, the m
overlaps following characters. This overlapping make readability difficult when
viewing the fonts.

Version-Release number of selected component (if applicable):

dejavu-fonts-2.7.0-1.fc6
dejavu-fonts-experimental-2.7.0-1.fc6
dejavu-fonts-makedefault-2.7.0-1.fc6


How reproducible:


Steps to Reproduce:
1. Install fonts
2. Type characters starting with m in them
3. See next characters
  
Actual results:

Could not make out clearly what the character was supposed to be.

Expected results:

Sufficient spacing between characters to allow clarity.
Additional info:
Comment 1 Jim Cornette 2006-07-09 10:41:15 EDT
Created attachment 132131 [details]
Created a new profile,
Comment 2 Jim Cornette 2006-07-09 10:45:52 EDT
Created attachment 132132 [details]
even worse renderiing

Though I set my settings for the system to DejaVu, monospace was chosen and the
overlapping is even to a greater degree. This is what system settings looked
like with monospace and system settings set to DejaVu.
Comment 3 Nicolas Mailhot 2006-07-09 11:53:08 EDT
Thanks for the report.

The first shot looks like DejaVu Sans Mono - and I agree m looks sqhashed but
there's little you can do with m in monospace - it's the widest latin leter and
it has to fit in the same mono grid as other letters

Your second screenshot OTOH shows a serif font, so it's certainly not DejaVu
Sabs Mono so I believe this is NOTMYBUG

I'll open a bug in the dejavu bugzilla for the first screen, but as I wrote
given in monospace m must have the same width as other letters, and the width of
its lines can not shrink below 1 pixel, I don't really see what the designers can do
Comment 4 Nicolas Mailhot 2006-07-09 11:59:13 EDT
Perhaps you do not mean overlapping, but would like the font letter spacing wider?
Comment 5 Nicolas Mailhot 2006-07-09 12:00:24 EDT
Closing upstream, please follow the freedesktop bug now
https://bugs.freedesktop.org/show_bug.cgi?id=7466
Comment 6 Jim Cornette 2006-07-09 19:51:02 EDT
I'll follow the upstream bug. I did however find out that reducing the dpi from
its 94 dpi setting to a setting in the 70s looks a lot better and there is not
that same problem as noted above. I understand now what is meant by monospacing
anyway.

Attached below is for comparison.
Comment 7 Jim Cornette 2006-07-09 19:54:19 EDT
Created attachment 132153 [details]
reducing dp1 by 20 dpi

The spacing was set to 94 dpi originally. Reducing the dpi seems to make the
fonts more readable.

Note You need to log in before you can comment on or make changes to this bug.