Bug 198101 - X don't start with No modes found on either pipe
Summary: X don't start with No modes found on either pipe
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords:
: 198948 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-09 17:40 UTC by Patrice Dumas
Modified: 2012-12-16 06:48 UTC (History)
4 users (show)

Fixed In Version: 1.6.5-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-07 10:09:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg config file (3.95 KB, text/plain)
2006-07-09 17:42 UTC, Patrice Dumas
no flags Details

Description Patrice Dumas 2006-07-09 17:40:49 UTC
Description of problem:

X don't start with the i810 driver. The output is
(==) Log file: "/var/log/Xorg.1.log", Time: Sun Jul  9 19:37:13 2006
(==) Using config file: "/etc/X11/xorg.conf"

(EE) I810(0): DDC Analog 0, 00005010
(EE) I810(0): DDC DVO 1, 0000501C
Executing (ax == 0x5f01) BIOS call at i830_driver.c:617

Fatal server error:
No modes found on either pipe

X starts in vesa mode. I guess it stopped functionning with 
the latest yum update. There is only one xorg-x11-drv-i810 
in the downloadable packages. I thought that there were 2
versions. Does this mean that it hasn't changed? 

lspci relevant bits:
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated
Graphics Device (rev 02)
00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics
Device (rev 02)

Computer is a DELL Latitude D505.

Version-Release number of selected component (if applicable):


How reproducible:

always.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Patrice Dumas 2006-07-09 17:42:05 UTC
Created attachment 132139 [details]
xorg config file

Comment 2 Patrice Dumas 2006-07-09 19:48:14 UTC
I have just checked that it works fine with
xorg-x11-drv-i810-1.6.0-6

Comment 3 Steven Usdansky 2006-07-20 12:36:03 UTC
same problem on my Shuttle SB 52G; xorg-x11-drv-i810-1.6.0-1 works

output of lspci | grep Graphics:
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE
Chipset Integrated Graphics Device (rev 03)


Comment 4 Adam Jackson 2006-08-01 02:44:24 UTC
*** Bug 198948 has been marked as a duplicate of this bug. ***

Comment 5 Steven Usdansky 2006-08-09 12:32:48 UTC
output below was obtained using
  xorg-x11-drv-i810-1.6.0-14.20060808modeset.fc6.i386.rpm

(==) Log file: "/var/log/Xorg.0.log", Time: Wed Aug  9 07:28:00 2006
(==) Using config file: "/etc/X11/xorg.conf"

(EE) I810(0): detecting sil164
(EE) I810(0): Unable to read from DVOI2C_E Slave 112.
(EE) I810(0): detecting ch7xxx
(EE) I810(0): Unable to read from DVOI2C_E Slave 236.
(EE) I810(0): DDC Analog 0, 00005010
(EE) I810(0): DDC DVO 1, 0000501C
Executing (ax == 0x5f01) BIOS call at i830_driver.c:617

Fatal server error:
No modes found on either pipe

XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.


Comment 6 Pekka Savola 2006-08-16 08:34:43 UTC
FWIW, FC6 test 2 graphical installation on Thinkpad X30 doesn't work due to this:

00:02.0 VGA compatible controller: Intel Corporation 82830 CGC [Chipset Graphics
Controller]
00:02.1 Display controller: Intel Corporation 82830 CGC [...]



Comment 7 Patrice Dumas 2006-08-26 10:12:30 UTC
This is fixed for me with 
xorg-x11-drv-i810-1.6.5-4.fc6

I also remarked that it only happened when the mode set in 
xorg.conf was 1280x800, a mode that the driver don't like.
The mode used is now 1024x768 instead of X server not
starting. In the log there is:
(II) I810(0): Not using mode "1280x800" (no mode of this name)
(--) I810(0): Virtual size is 1024x768 (pitch 1024)
(**) I810(0):  Built-in mode "1024x768"
(**) I810(0):  Built-in mode "800x600"
(**) I810(0):  Built-in mode "640x480"


When specifying 1024x768 it worked fine even with interim
rawhide drivers.

Comment 8 Patrice Dumas 2007-04-07 10:09:36 UTC
Since I was the reporter, it works for me and there is no 
other feedback, I close.

Comment 9 Vinayak 2012-12-16 06:46:16 UTC
(In reply to comment #5)
> output below was obtained using
>   xorg-x11-drv-i810-1.6.0-14.20060808modeset.fc6.i386.rpm
> 
> (==) Log file: "/var/log/Xorg.0.log", Time: Wed Aug  9 07:28:00 2006
> (==) Using config file: "/etc/X11/xorg.conf"
> 
> (EE) I810(0): detecting sil164
> (EE) I810(0): Unable to read from DVOI2C_E Slave 112.
> (EE) I810(0): detecting ch7xxx
> (EE) I810(0): Unable to read from DVOI2C_E Slave 236.
> (EE) I810(0): DDC Analog 0, 00005010
> (EE) I810(0): DDC DVO 1, 0000501C
> Executing (ax == 0x5f01) BIOS call at i830_driver.c:617
> 
> Fatal server error:
> No modes found on either pipe
> 
> XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
>       after 0 requests (0 known processed) with 0 events remaining.




HEllo Steven..!

I too have same problem. If you tell me what the procedure you followed, I am new to linux... Kindly help me to resolve this issue

Comment 10 Vinayak 2012-12-16 06:48:11 UTC
output below was obtained using
  xorg-x11-drv-i810-1.6.0-14.20060808modeset.fc6.i386.rpm

(==) Log file: "/var/log/Xorg.0.log", Time: Wed Aug  9 07:28:00 2006
(==) Using config file: "/etc/X11/xorg.conf"

(EE) I810(0): detecting sil164
(EE) I810(0): Unable to read from DVOI2C_E Slave 112.
(EE) I810(0): detecting ch7xxx
(EE) I810(0): Unable to read from DVOI2C_E Slave 236.
(EE) I810(0): DDC Analog 0, 00005010
(EE) I810(0): DDC DVO 1, 0000501C
Executing (ax == 0x5f01) BIOS call at i830_driver.c:617

Fatal server error:
No modes found on either pipe

XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.


I have this issue, kindly help me to resolve, i am new to linux.
I am Using Redhat Linux 5


Note You need to log in before you can comment on or make changes to this bug.