Bug 198111 - directfb requires libsysfs.so.1 no longer in -development
directfb requires libsysfs.so.1 no longer in -development
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: directfb (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Vander Stichele
Fedora Extras Quality Assurance
:
: 198531 201666 203841 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-09 15:47 EDT by Matt Domsch
Modified: 2007-11-30 17:11 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-15 10:22:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
DirectFB-0.9.24-no-linux-compiler.h.patch (361 bytes, patch)
2006-07-12 00:55 EDT, Matt Domsch
no flags Details | Diff
Patch to compile 0.9.24 on current rawhide (925 bytes, patch)
2006-07-20 07:54 EDT, Mamoru TASAKA
no flags Details | Diff
compressed tarball containing a spec file + 3 patch files (2.91 KB, application/octet-stream)
2006-07-20 08:37 EDT, Joseph Sacco
no flags Details

  None (edit)
Description Matt Domsch 2006-07-09 15:47:09 EDT
Description of problem:
The directfb package in devel/ for what will be FC6 requires libsysfs.so.1,
however Core has upgraded to sysfsutils-2.0.0, and the appropriate BuildRequires
for directfb should be libsysfs-devel (with corresponding changes to any code if
necessary of course).

Installation of this package fails as it requires libsysfs.so.1 which is no
longer in the distribution.  Packages that require directfb thus also fail due
to this recursive dependency.

Version-Release number of selected component (if applicable):
directfb-0.9.24-5.fc5

How reproducible:
always

Steps to Reproduce:
1. yum --enablerepo=extras-development install directfb
  
Actual results:
fails to install due to missing libsysfs.so.1

Expected results:
installs
Comment 3 Hans de Goede 2006-07-10 00:39:44 EDT
Hmm, appearantly 0.9.25 breaks with x86_64, which is actually lucky though since
currently in the repo is 0.9.24 and directfb changes its soname each upstream
release!

So what needs to be done is co 0.9.24-5 and make that 0.9.25-6 with the BR fix
and build that one!
Comment 4 Matt Domsch 2006-07-12 00:55:07 EDT
Created attachment 132277 [details]
DirectFB-0.9.24-no-linux-compiler.h.patch

More is needed.
configure --enable-gettid=no
and a patch to not try including linux/compiler.h in one file (attached)

After doing this, I was able to successfully build the package on i386.
Comment 5 Hans de Goede 2006-07-14 10:48:26 EDT
Since as sorta usual when this happens the directfb owner himself is not
responding in a timely matter and since I've done a rogue takeover of it once
and he then all of a sudden resurface and wanted (and got) it back, maybe its
time to just kick directfb from the -devel branch. AFAIK even the directfb owner
himself has said as much as that he has sorta lost interest. With directfb
kicked, packages now using it can be easily rebuild to live without it, since
afaik there are no packages which cannot live without it,
Comment 6 Nicolas Mailhot 2006-07-15 09:16:13 EDT
mplayer from that-other-repo uses directfb
Comment 7 Hans de Goede 2006-07-15 09:18:36 EDT
(In reply to comment #6)
> mplayer from that-other-repo uses directfb

I know but it can be build without it just fine, actually uses directfb is a big
word, mplayer is compiled so that it can use directfb when the user instructs it
to use directfb, but by default it doesn't.

Comment 8 Nicolas Mailhot 2006-07-15 09:41:44 EDT
please someone mark bug #198531 as a dupe of this one
Comment 9 Hans de Goede 2006-07-15 10:13:00 EDT
*** Bug 198531 has been marked as a duplicate of this bug. ***
Comment 10 Mamoru TASAKA 2006-07-19 23:52:03 EDT
Maybe for x86_64, adding --enable-fbdev=no to configure option will be sufficient?
(this option suppresses building directfb-0.9.25/systems/libdirectfb_fbdev.so)

Note: directfb-0.9.25.1-2.fc6 also fails rebuilding on i386.
For this issue, 
perl -pi -e's,#include <linux/compiler.h>,,' \
        interfaces/IDirectFBVideoProvider/idirectfbvideoprovider_v4l.c
is needed.
Comment 11 Hans de Goede 2006-07-20 03:43:15 EDT
0.9.25 has a different soname, so building that while fixing the libsysfs
problem will only introduce new problems further down (up?) the dep chain. If
you want to help please focus on fixing / testing 0.9.24

Thanks,

Hans
Comment 12 Mamoru TASAKA 2006-07-20 07:54:45 EDT
Created attachment 132740 [details]
Patch to compile 0.9.24 on current rawhide

As for directfb-0.9.24-5.fc5, changing BR from sysfsutils-devel to
libsysfs-devel and applying the patch attached will be sufficient for
i386 ( I cannot try x86_64 or ppc ).

This patch is almost the same as Matt's patch.
Comment 13 Joseph Sacco 2006-07-20 08:37:03 EDT
Created attachment 132742 [details]
compressed tarball containing a spec file + 3 patch files

I patched version 0.9.24 to build and run on a 32-bit PPC under the current
rawhide environment. See attachment.

-Joseph
Comment 14 Ryan Skadberg 2006-08-16 20:42:00 EDT
Any chance of this getting fixed any time soon?  It's been almost a month now.
(26 days according to the broken dependencies report)
Comment 15 Hans de Goede 2006-08-17 02:57:53 EDT
(In reply to comment #14)
> Any chance of this getting fixed any time soon?  It's been almost a month now.
> (26 days according to the broken dependencies report)

Well the impact of this bug has been severely limited by a new version of
mplayer from that other repo which simply fixes this by no longer linking /
using directfb (as I suggested in commnet 7).

So AFAIK nothing is using directfb, so I think we should remove it altogether
from the repo. But thats up to Thomas.

Hello Thomas, ping?
Comment 16 Ryan Skadberg 2006-08-18 13:28:52 EDT
gstreamer-plugins-bad from freshrpms still needs it.
Comment 17 Kjartan Maraas 2006-08-31 07:37:08 EDT
*** Bug 203841 has been marked as a duplicate of this bug. ***
Comment 18 Kjartan Maraas 2006-08-31 07:41:27 EDT
*** Bug 201666 has been marked as a duplicate of this bug. ***
Comment 19 Bob Agel 2006-08-31 14:41:03 EDT
Still coming up as a daily exception on yum.  Is this a more complex issue or
perhaps just put off until 'final'?
Comment 20 Thomas Vander Stichele 2006-09-02 06:51:40 EDT
If poked at this over various weekends, and not having an x86_64 box I have
directfb-using cards in I can actually test anything with is not helping.

Hans is obviously bitter at me, and directfb has already given me a lot more
grief for maintaining it than it has given me any enjoyment at all, so if Hans
wants to turn his bitterness into positive energy he is more than welcome to
update directfb, break everyone's repository a few times, and get lots of crap
by taking over the package.

So unless someone objects I am going to put it up for adoption.
Comment 21 Hans de Goede 2006-09-02 07:05:10 EDT
(In reply to comment #20)
> Hans is obviously bitter at me, and directfb has already given me a lot more
> grief for maintaining it than it has given me any enjoyment at all, so if Hans
> wants to turn his bitterness into positive energy he is more than welcome to
> update directfb, break everyone's repository a few times, and get lots of crap
> by taking over the package.
> 

I'm not bitter with you at all, to quote myself from comment 5:
"Since as sorta usual when this happens the directfb owner himself is not
responding in a timely matter"

So I'm not bitter, but I'm worried about you not responding in a timely manner
the last time directfb broke and not responding in a timely manner this time
too. So I see a pattern here.

> So unless someone objects I am going to put it up for adoption.

Yes orphaning it is a good idea, then it will get removed from the repo for
FC-6, as I already suggested in comment 15, where I wrote: "So AFAIK nothing is
using directfb, so I think we should remove it altogether from the repo. But
thats up to Thomas."

Appologies if I sounded bitter somewhere and keep up the good work with your
other pakcages!
Comment 22 Bob Agel 2006-09-02 11:38:17 EDT
Hans mentions that 'nothing is using directfb' so I've removed it, but now
Firefox crashes on some pages, unfortunately without giving feedback in the
terminal.  Could this be connected, as Firefox has been completely stable prior
to removing directfb?  If so, any possible correction, as it can't be
reinstalled with the current sysfsutils problem.
Comment 23 Matthias Saou 2006-09-14 09:25:38 EDT
I'm about to push 0.9.25.1 for FC6, any objections? Only two trivial patches are
required to get it to build, one general (the linux include) and one for x86_64
(asm types).
Comment 24 Hans de Goede 2006-09-14 10:01:49 EDT
Matthias does that mean that you are taking over as maintainer? Have you
discussed this with Thomas? Firing of a one time build is not going to help
anyone in that case it would actually be better to let directfb get removed for FC6.
Comment 25 Matthias Saou 2006-09-14 10:35:55 EDT
Yup, spoke to Thomas quickly about it.
If no one wants to take over the package, I will... and I've got it ready for an
FC6 rebuild. So either it's a one time build just to help the next maintainer,
or it's taking care of the issue as the new maintainer.

Note You need to log in before you can comment on or make changes to this bug.