Bug 198117 - BIOS BUG MCFG for PCI
BIOS BUG MCFG for PCI
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-09 17:25 EDT by Leslie Satenstein
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-20 12:51:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Leslie Satenstein 2006-07-09 17:25:05 EDT
After installing 2.6.17-1.2145_FC5smp and also checking it out with 32 bit
non-smp and with 64 bit, I am getting the following:

ACPI: bus type pci registered
PCI: BIOS Bug: MCFG area is not E820-reserved
PCI: Not using MMCONFIG.
PCI: Using configuration type 1
Setting up standard PCI resources

First time ever for the MCFG message and the follow up about MMCONFIG.

Note: to eliminate the Mother board, 
I upgraded Intel bios, Mother board is a d945gnt with bios upgrade to May 2006.

From dmesg
ACPI: MCFG (v001 INTEL D945GNT 0x00000f5a MSFT 0x01000013) @ 0x3f6f6f10


Is it an informative message, an error message, or a bios problem.


Version-Release number of selected component (if applicable):
2.6.17-1.2145_FC5smp

How reproducible:
boot to fc5 non smp, fc5smp or fc5 64 bit.

Note. Message not present in preceding kernel version

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Konrad Rzeszutek 2006-07-20 12:51:58 EDT
The reason you see this message is b/c your machine implements MMCONFIG.
Unfortunatly, some Intel motherboards implemented this wrongly and Linux kernel
would crash. To boot up on those boards without crashing, the kernel checks to
see if the address specified in the ACPI MCFG area is also reserved in E820 area
(which btw, is not something the ACPI v3.0 and PCI Express spec mandates - it is
optional). This is short-term fix and once a better solution is found the
mainline kernel will have that (and FC will have it too)

So for right pls ignore it. It should eventually go away when main-line finds a
proper fix.

Note You need to log in before you can comment on or make changes to this bug.