Bug 198200 - should have <IfModule mod_mime.c> in /etc/httpd/conf.d/php.conf
Summary: should have <IfModule mod_mime.c> in /etc/httpd/conf.d/php.conf
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-10 13:48 UTC by Russell Coker
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-10 14:18:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix this bug (369 bytes, patch)
2006-07-10 13:48 UTC, Russell Coker
no flags Details | Diff

Description Russell Coker 2006-07-10 13:48:39 UTC
The attached patch makes the httpd work if the mod_mime.so is not loaded.

Comment 1 Russell Coker 2006-07-10 13:48:39 UTC
Created attachment 132174 [details]
patch to fix this bug

Comment 2 Joe Orton 2006-07-10 14:00:53 UTC
You should expect a configuration error if mod_mime is not loaded, since PHP
will not work otherwise.  This is desired behaviour.

Comment 3 Russell Coker 2006-07-10 14:10:21 UTC
Surely you should expect that if pre-requisite functionality is removed then 
PHP would simply be disabled.

How would you suggest handling the situation where you have multiple instances 
of Apache on one machine where one of them has PHP enabled and another 
doesn't?  Have separate conf.d directories for each instance?

I know that multiple instances of Apache is not supported (multiple copies of 
a daemon is too complex for most sys-admins to handle).  But it would be nice 
if it wasn't any more difficult than it has to be.

Comment 4 Joe Orton 2006-07-10 14:18:15 UTC
(In reply to comment #3)
> Surely you should expect that if pre-requisite functionality is removed then 
> PHP would simply be disabled.

No, silent failure is a bad thing.  If you want to complicate your configuration
with this kind of thing you can, but that doesn't mean it's necessary for the
default config.

> How would you suggest handling the situation where you have multiple instances 
> of Apache on one machine where one of them has PHP enabled and another 
> doesn't?  Have separate conf.d directories for each instance?

Yeah, or you could surround the php.conf with

<IfDefine DISABLE_PHP>

and run some httpd's with -DDISABLE_PHP on the command-line, for example.

Please take further discussion to fedora-list.



Note You need to log in before you can comment on or make changes to this bug.