Bug 198205 - Using selinux-policy requires m4, but m4 not in dependency list
Using selinux-policy requires m4, but m4 not in dependency list
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-10 10:14 EDT by Hans Ulrich Niedermann
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-10 10:22:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans Ulrich Niedermann 2006-07-10 10:14:27 EDT
Description of problem:

  "make -f /usr/share/selinux/devel/Makefile" requires m4, but the
selinux-policy package does not depend on m4.

  This forces all spec files which need to compile an SELinux policy module to
know that selinux-policy depends on m4 and add that dependency themselves.

Version-Release number of selected component (if applicable):

  selinux-policy-2.2.47-3.fc5

Expected behaviour:

  selinux-policy should depend on m4.
Comment 1 Daniel Walsh 2006-07-10 10:22:41 EDT
We have split out selinux-policy-devel in FC6/Rawhide package which has this
requirement.  I do not want to bring this requirement back into FC5 since it
might break other things.

Comment 2 Hans Ulrich Niedermann 2006-07-12 15:53:35 EDT
That makes sense in a way.

So I'm going to use the following in my SPEC file:

%if "%{fedora}" >= "6"
BuildRequires: selinux-policy-devel
%else
BuildRequires: selinux-policy, m4
%endif

Note You need to log in before you can comment on or make changes to this bug.