Bug 198265 - yum.log does not show package version when erasing
yum.log does not show package version when erasing
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 466827 483389 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-10 14:41 EDT by Steve Tyler
Modified: 2014-01-21 17:54 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 16:51:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Tyler 2006-07-10 14:41:52 EDT
Description of problem:
/var/log/yum.log does not show the package version when erasing,
while it does show the package version when installing or updating.

Version-Release number of selected component (if applicable):
yum-2.6.1-0.fc5

How reproducible:
always

Steps to Reproduce:
1. yum erase foo
2. tail /var/log/yum.log
3. The version of foo just erased is not in yum.log.
  
Actual results from /var/log/yum.log:
May 17 07:39:11 Erased: vnc-server
May 17 07:39:13 Erased: vnc

Expected results:
Package version should be shown as in:
May 19 14:40:33 Updated: ntp.i386 4.2.0.a.20050816-11.FC5
May 19 14:40:37 Installed: kmod-nvidia.i686 1.0.8756-3.2.6.16_1.2111_FC5
Comment 1 Jeremy Katz 2006-09-18 16:51:43 EDT
Unfortunately, there's no data passed back from rpm as to what the version of
the removed package was and thus there's not anything we can really do :(
Comment 2 Stuart R. Kirk 2008-10-14 01:08:06 EDT
*** Bug 466827 has been marked as a duplicate of this bug. ***
Comment 3 James Antill 2009-02-02 12:35:07 EST
*** Bug 483389 has been marked as a duplicate of this bug. ***
Comment 4 Steve Tyler 2013-08-04 17:07:37 EDT
This is fixed in F19.
Changing resolution to CURRENTRELEASE.

$ sudo grep Erased /var/log/yum.log | head -1
Jun 29 22:46:12 Erased: evolution-ews-3.8.3-1.fc19.x86_64
$ rpm -q yum rpm
yum-3.4.3-104.fc19.noarch
rpm-4.11.1-1.fc19.x86_64

Note You need to log in before you can comment on or make changes to this bug.