Bug 19828 - 2.2.17 fails to compile, even with kgcc
2.2.17 fails to compile, even with kgcc
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-25 15:14 EDT by Andreas-Johann Ulvestad
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-26 02:50:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas-Johann Ulvestad 2000-10-25 15:14:43 EDT
I'm trying to compile kernel 2.2.17 with kgcc (yes, I took a make mrproper
first). These are the errors:

floppy.c:603:60: warning: pasting would not give a valid preprocessing
token
floppy.c:712:34: warning: pasting would not give a valid preprocessing
token
floppy.c:718:72: warning: pasting would not give a valid preprocessing
token
floppy.c:719:48: warning: pasting would not give a valid preprocessing
token
cdrom.c:395:73: warning: pasting would not give a valid preprocessing token
cdrom.c:426:75: warning: pasting would not give a valid preprocessing token
cdrom.c:484:88: warning: pasting would not give a valid preprocessing token
/usr/src/linux-2.2.17/include/linux/sunrpc/debug.h:53:57: warning: nothing
can be pasted after this token
nfsproc.c:54:59: warning: pasting would not give a valid preprocessing
token
nfsproc.c:70:65: warning: pasting would not give a valid preprocessing
token
nfsproc.c:89:71: warning: pasting would not give a valid preprocessing
token
/tmp/ccrxTyb9.s:825: Warning: using `%edx' instead of `%dx' due to `l'
suffix
/tmp/ccrxTyb9.s:862: Warning: using `%edx' instead of `%dx' due to `l'
suffix
/tmp/ccrxTyb9.s:862: Warning: using `%edx' instead of `%dx' due to `l'
suffix
/tmp/ccrxTyb9.s:958: Warning: using `%ecx' instead of `%cx' due to `l'
suffix
{standard input}:1373: Warning: indirect lcall without `*'
{standard input}:1405: Warning: indirect lcall without `*'
{standard input}:1437: Warning: indirect lcall without `*'
make[2]: Entering directory `/usr/src/linux-2.2.17/arch/i386/lib'
cc -D__KERNEL__ -I/usr/src/linux-2.2.17/include -D__ASSEMBLY__ -D__SMP__
-traditional -c checksum.S -o checksum.o
checksum.S:231: badly punctuated parameter list in #define
checksum.S:237: badly punctuated parameter list in #define
make[2]: *** [checksum.o] Error 1
make[2]: Leaving directory `/usr/src/linux-2.2.17/arch/i386/lib'
make[1]: *** [first_rule] Error 2
make[1]: Leaving directory `/usr/src/linux-2.2.17/arch/i386/lib'
make: *** [_dir_arch/i386/lib] Error 2
Comment 1 Arjan van de Ven 2000-10-25 16:05:09 EDT
This _REALLY_ looks like you are NOT using kgcc. Did you do an "export CC=kgcc"
before
make bzImage ? (or edit the makefile to change CC (not hostcc))
Comment 2 Andreas-Johann Ulvestad 2000-10-25 16:50:04 EDT
Ooops.. I changed HOSTCC.... 
After changning from
CC     =$(CROSS_COMPILE)cc -D__KERNEL__ -I$(HPATH)
to
CC      =kgcc -D__KERNEL__ -I$(HPATH)
, it worked. Is this actually DOCUMENTED anywhere?
Comment 3 Andreas-Johann Ulvestad 2000-10-25 16:52:53 EDT
kgcc -D__KERNEL__ -I/usr/src/linux-2.2.17/include -Wall -Wstrict-prototypes -O2
-fomit-frame-pointer -fno-strict-aliasing -D__SMP__ -pipe -fno-strength-reduce
-m486 -malign-loops=2 -malign-jumps=2 -malign-functions=2 -DCPU=686 -DMODULE
-DMODVERSIONS -include /usr/src/linux-2.2.17/include/linux/modversions.h   -c -o
radio-miropcm20.o radio-miropcm20.c
In file included from radio-miropcm20.c:13:
../sound/lowlevel/miroaci.h:9: #error Compiling a driver that needs the
ACI-mixer but without ACI-mixer support
radio-miropcm20.c: In function `pcm20_mute':
radio-miropcm20.c:33: warning: implicit declaration of function `aci_write_cmd'
radio-miropcm20.c: In function `pcm20_setfreq':
radio-miropcm20.c:73: warning: implicit declaration of function
`aci_write_cmd_d'
radio-miropcm20.c: In function `pcm20_getsigstr':
radio-miropcm20.c:81: warning: implicit declaration of function
`aci_indexed_cmd'
{standard input}: Assembler messages:
{standard input}:9: Warning: Ignoring changed section attributes for .modinfo
make[2]: *** [radio-miropcm20.o] Error 1
make[2]: Leaving directory `/usr/src/linux-2.2.17/drivers/char'
make[1]: *** [_modsubdir_char] Error 2
make[1]: Leaving directory `/usr/src/linux-2.2.17/drivers'
make: *** [_mod_drivers] Error 2
Comment 4 Arjan van de Ven 2000-10-26 02:50:39 EDT
"../sound/lowlevel/miroaci.h:9: #error Compiling a driver that needs the
            ACI-mixer but without ACI-mixer support"
I think that says it all. You need to also enable the "ACI mixer" in the
sound/lowlevel section.
Comment 5 Alan Cox 2000-10-27 12:10:44 EDT
Its documented in the Readme. Documenting it better is on the list for the next
release and a valid
complaint.

Note You need to log in before you can comment on or make changes to this bug.