Bug 198308 - NULL pointer dereference on boot loading driver for USB DVB
NULL pointer dereference on boot loading driver for USB DVB
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-10 19:51 EDT by Simon Roberts
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-10 20:59:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
excerpt of /var/log/messages containing error (4.39 KB, text/plain)
2006-07-10 19:51 EDT, Simon Roberts
no flags Details
My modprobe.conf (942 bytes, text/plain)
2006-07-10 19:55 EDT, Simon Roberts
no flags Details
The entire /var/log/messages for the effected (previous message may be incomplete) (41.17 KB, text/plain)
2006-07-10 20:00 EDT, Simon Roberts
no flags Details
The entire /var/log/messages for the effected (previous message may be incomplete) (41.17 KB, text/plain)
2006-07-10 20:00 EDT, Simon Roberts
no flags Details

  None (edit)
Description Simon Roberts 2006-07-10 19:51:09 EDT
Description of problem:
NULL pointer dereference on boot loading driver for USB DVB.

Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2145_FC5 on "AMD Athlon(tm) 64 X2 Dual Core Processor 3800+"

How reproducible:
100%

Steps to Reproduce:
1. Boot machine with hardware installed
2.
3.
  
Actual results:
NULL pointer dereference as described in attachment messages.txt

Expected results:
Module should load and function correctly :)

Additional info:
The last time I tried this (kernel-2.6.17-1.2139_FC5) to module loaded, udev
created the devices, which sortof worked. It produced lots of "dvb-usb: bulk
message failed: -71 (5/0)" etc (ETIMEOUT and EPROTO IIRC) and stuttery output.
Device.
Hardware is http://www.fusionhdtv.co.kr/ENG/Products/DualDigital.aspx
Comment 1 Simon Roberts 2006-07-10 19:51:09 EDT
Created attachment 132208 [details]
excerpt of /var/log/messages containing error
Comment 2 Simon Roberts 2006-07-10 19:55:07 EDT
Created attachment 132209 [details]
My modprobe.conf
Comment 3 Simon Roberts 2006-07-10 20:00:37 EDT
Created attachment 132210 [details]
The entire /var/log/messages for the effected (previous message may be incomplete)
Comment 4 Simon Roberts 2006-07-10 20:00:48 EDT
Created attachment 132211 [details]
The entire /var/log/messages for the effected (previous message may be incomplete)
Comment 5 Pete Zaitcev 2006-07-10 20:15:55 EDT
Thanks a lot, complete logs are very important.

Since I don't have the hardware, I suppose I'll just use my thinking cap and
look at the code until I understand how that could happen...
Comment 6 Simon Roberts 2006-07-10 20:46:56 EDT
I note that the problem starts at:

Jul 10 20:21:17 mythtv kernel: cx2388x v4l2 driver version 0.0.6 loaded
Jul 10 20:21:17 mythtv kernel: cx88_blackbird: Unknown symbol cx88_user_ctrls
Jul 10 20:21:17 mythtv kernel: cx88_blackbird: Unknown symbol cx88_do_ioctl
Jul 10 20:21:17 mythtv kernel: cx88_blackbird: Unknown symbol cx8800_ctrl_query

Is this a v4l problem?  I'll remove the (*cough* atrpms *cough*) v4l modules and
retry.
Comment 7 Simon Roberts 2006-07-10 20:57:56 EDT
Ok
- uninstalled atrpms video4linux kernel modules
- removed lines from modprobe.conf that disable dvb_usb and dvb_usb_cxusb
- removed ivtv/lirc lines from modprobe.conf

Now I'm back to my old problem :) I'll close this issue, and file a new one for
that issue. Thanks!


Note You need to log in before you can comment on or make changes to this bug.