Bug 19832 - Post-Installation fails on an IBM Thinkpad 390, I cannot install 7.0 at all
Summary: Post-Installation fails on an IBM Thinkpad 390, I cannot install 7.0 at all
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-25 22:11 UTC by Uwe Beutin
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-30 21:29:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Uwe Beutin 2000-10-25 22:11:43 UTC
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1619, in
doInstall
    self.createCdrom()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1189, in
createCdrom
    os.symlink(device, self.instPath + "/dev/" + cdname)
OSError: [Errno 28] No space left on device

Local variables in innermost frame:
device: hdc
list: ['hdc']
self: <todo.ToDo instance at 82734e8>
cdname: cdrom
count: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I2
sS'tree'
p7
S'/mnt/source'
sS'device'
p8
S'hdc'
sS'progressWindow'
p9

<failed>

--------------
I have tried several methods for installing. It seems to tell me that there
is no space left on device /dev/hdc? I have manually partitioned my
/dev/hda because I need the IBM Hibernation Partition (0xA0) as a primary.
Might this be a problem? A "df" on tty2 shows plenty of room in all
physical partitions.

Comment 1 Michael Fulbright 2000-10-30 21:28:39 UTC
What partitions/mount points are you using (include the size of each)?

Comment 2 Michael Fulbright 2000-10-30 21:29:04 UTC
Most likely a dupe of bug 18403.

Comment 3 Uwe Beutin 2000-11-01 23:58:50 UTC
Resolved... Sorry to steal your time. The problem is that my / partition was big
enough alright but there weren't enough inodes available. Only after setting up
a different partition with a lot more space and then mke2fs'ing a new / myself
with a different blocksize/inode-per-blocks was I able to copy the /dev
directory in it's entirety.


Note You need to log in before you can comment on or make changes to this bug.