Bug 198327 - Screen corruption after running a Direct X application (games).
Screen corruption after running a Direct X application (games).
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-11 01:32 EDT by Gian Paolo Mureddu
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-18 05:19:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is how the screen looks like after running Diablo II with Wine 0.9.16 from Extras. (332.32 KB, image/png)
2006-07-11 01:32 EDT, Gian Paolo Mureddu
no flags Details

  None (edit)
Description Gian Paolo Mureddu 2006-07-11 01:32:32 EDT
Description of problem:
When exiting a Direct X application the screen will be corrupted and a
greenish-blueish tint is also present. This has been the case since version
0.9.15 supporting gnome-mount. Once the screen is grabled, the only way to clean
the desktop is to quit and restar the session, even other programs will have
issues, like xine or totem will keep the area where the window of the program
showed.

Version-Release number of selected component (if applicable):
wine-0.9.15 through 0.9.16

How reproducible:
Always

Steps to Reproduce:
1. Install some Direct X game or application.
2. Run said application.
3. Quit the program. A blueish-greenish tint will be left on the screen. 
  
Actual results:
See attached screenshots.


Expected results:
Previous versions of Wine did not have this problem.

Additional info:
Comment 1 Gian Paolo Mureddu 2006-07-11 01:32:32 EDT
Created attachment 132219 [details]
This is how the screen looks like after running Diablo II with Wine 0.9.16 from Extras.
Comment 2 Andreas Bierfert 2006-07-18 05:19:30 EDT
This actually is a Diablo 2 bug/feature you can also see on some Windows
Versions.  As to wine bugs: DirectX not working is something that happens at the
moment because wine developers are changing code ther a lot lately. So if you
have the time report these bugs at winehq.org as these are wine bugs and not
packaging bugs on fedora (at least most likely).
Comment 3 Gian Paolo Mureddu 2006-07-18 05:24:29 EDT
Indeed, as matter of fact other user reported this in the AppDB Entry for Diablo
2 and apparently Direct3D is broken for some "legacy" Direct3D < 7 applications
(which Diablo happens to be one of them) and apparently they've solved the issue
in CVS of 0.9.18, so I'd expect this to be resolved by 0.9.18, once more, thanks
for the heads up!

Note You need to log in before you can comment on or make changes to this bug.