Bug 198342 - No debuginfo available for cyrus-imapd
No debuginfo available for cyrus-imapd
Status: CLOSED DUPLICATE of bug 190802
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: cyrus-imapd (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-11 05:31 EDT by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-11 10:14:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2006-07-11 05:31:46 EDT
cyrus-imapd-2.2.12-3.RHEL4.1

RPM is a bit stupid and still parses that whether or not a comment:
# Disable -debuginfo package generation
#%define debug_package  %{nil}

Even when this is removed, only debug data for the Perl modules finds its way to
the -debuginfo package
Comment 1 Bastien Nocera 2006-07-11 05:35:11 EDT
That won't help either:
# Strip binaries
%{__strip} --strip-unneeded %{buildroot}%{_cyrexecdir}/* ||:
Comment 2 Bastien Nocera 2006-07-11 05:40:05 EDT
Removing those 2 lines will generate a ~9 megs -debuginfo instead of ~400k.

Peter will be rebuilding the packages in the buildsystem.
Comment 3 Bastien Nocera 2006-07-11 10:14:19 EDT
I knew this reminded me of something, it's a dupe of 190802

*** This bug has been marked as a duplicate of 190802 ***

Note You need to log in before you can comment on or make changes to this bug.