This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 198425 - [cal]C 'n' P operation crash evolution in DayView
[cal]C 'n' P operation crash evolution in DayView
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthew Barnes
: Desktop
Depends On:
Blocks: 208054
  Show dependency treegraph
 
Reported: 2006-07-11 07:07 EDT by A S Alam
Modified: 2013-07-02 20:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 12:44:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
backtrace after right-click on calendar (7.53 KB, text/plain)
2006-09-25 00:48 EDT, Lawrence Lim
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 350725 None None None Never

  None (edit)
Description A S Alam 2006-07-11 07:07:00 EDT
Description of problem:
when try to paste data from Clipboard to Calender's DayView, it is not working,
with Ctrl+V, it also not working

Version-Release number of selected component (if applicable):
evolution-2.7.3-9

How reproducible:
Everytime during paste in Dayview

Steps to Reproduce:
1.Open Evolution
2. goto Calender
3. try to paste data by Right Clicking or Ctrl+V
  
Actual results:
nothing pasted in text area

Expected results:
it should print normally

Additional info:
Comment 1 Mayank Jain 2006-08-03 07:31:31 EDT
ctrl + v does not works, but shift + inesert does works.
 evo version - Gnome evolution-2.8 2.7.90
Comment 2 Matthew Barnes 2006-08-08 23:25:32 EDT
Just to clarify, this behavior is observed while editing an appointment summary
directly in day view, but not in the "Appointment" dialog window.  Correct?

I am able to reproduce the problem in Evolution 2.7.91.  Has a bug report been
filed upstream?
Comment 3 A S Alam 2006-08-09 08:47:48 EDT
Yes "Appointment" dialog window working fine, but problem only with day view
(direct)

No, not yet filed in Upstream
Comment 4 A S Alam 2006-08-10 08:32:51 EDT
Filed to upstream, please check
http://bugzilla.gnome.org/show_bug.cgi?id=350725
Comment 6 A S Alam 2006-08-30 02:59:07 EDT
with evolution-2.7.92-6.fc6 Version:
if you copy (by Right Click) 1 entry to another entry it is ok (RIght Click/Ctrl+V)
Comment 7 Mayank Jain 2006-09-02 08:57:44 EDT
(In reply to comment #6)
> with evolution-2.7.92-6.fc6 Version:
> if you copy (by Right Click) 1 entry to another entry it is ok (RIght
Click/Ctrl+V)

So it means its working fine or not?

Comment 8 Leon Ho 2006-09-06 00:08:47 EDT
Based on comment #5, this is important for all desktop users.
Comment 9 Mayank Jain 2006-09-14 06:27:49 EDT
Few findings

- The paste operation via right click, IMHO was designed to copy & paste full
appointments than text in those events.

- Right click > paste OR paste from ctrl+v does not crashes evo

Aman, can you please confirm the crash issue?

Thanks,
Mayank
Comment 10 A S Alam 2006-09-15 07:27:44 EDT
yes, that is checked with latest build and finding with you.

regards
Comment 11 Lawrence Lim 2006-09-25 00:48:52 EDT
Created attachment 137030 [details]
backtrace after right-click on calendar
Comment 12 Nicole Dai 2006-10-16 04:08:26 EDT
Retest copy and paste appointment in DayView of Canlendars, details are as below:
RHEL5-Client-20061012.9
evolution-2.8.0-8.el5

Test step:
1. Launch Calendars via Application-Office-Calendar or press Ctrl+3 in Evolution.
2. Highlight an appointment in DayView, press Ctrl+C (if there is not any
appointment pls new one)
3. Press Ctrl+V.
4. Right-click an appointment, select Copy.
5. Right-click a blank time entry, select Paste.

Test result:
3. It does not work via Ctrl+C and Ctrl+V.
5. Copy/Paste provided by floating window does work well except a strange problem:
If the length of Summary and Description are more than 2 Chinese words,(English
is no problem)right-click | Copy and Paste does not work. 
Summary  Description  Result
工作      工作         Work well
工作间    工作间       does not work
工作      工作间       work well
工作间    工作         work well


Comment 13 Matthew Barnes 2007-01-02 12:44:33 EST
Closing as UPSTREAM since this has already been forwarded upstream.  I will
continue to track the problem there.  Please refer to [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=350725

Note You need to log in before you can comment on or make changes to this bug.