Bug 19849 - upgrading from 6.2 to 7.0 form a machine with RAID5 md
upgrading from 6.2 to 7.0 form a machine with RAID5 md
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 21908 23015 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-26 06:20 EDT by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-04 10:50:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-26 06:20:24 EDT
I have two machines, A and B. They both have the same motherboard  and 
RAID5 MDs (The system partition is also on one of the MDs). The only
difference is that machine A uses 3 18GB Fujitsu SCSI Ultra160 disks for
the RAID 5 MD and machine B uses 6 18GB IBM SCSI-LVD disks. The upgrading
of machine A from RH 6.2 to 7.0 is OK. But when I upgrade machine B from RH
6.2 to 7.0, I got the following error message:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 336, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 678, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 428, in
nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 466, in
setScreen
    new_screen = screen.getScreen ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/examine_gui.py", line
30, in getScreen
    self.parts = self.todo.upgradeFindRoot ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 841, in
upgradeFindRoot
    mdList = raid.startAllRaid(drives)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/raid.py", line 61, in
startAllRaid
    for (mdDevice, deviceList) in scanForRaid(driveList):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/raid.py", line 25, in
scanForRaid
    (major, minor, raidSet, level, nrDisks, totalDisks, mdMinor) = \
  File "/usr/lib/anaconda/isys.py", line 37, in raidsb
    rc = _isys.getraidsb(fd)
ValueError: bad md magic on device

Local variables in innermost frame:
mdDevice: sdg5
fd: 18

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2000-10-30 16:39:08 EST
How were the RAID partitions created?

Could you include the partition table for each drive (use the 'fdisk -l
/dev/<device>')?

Also please include the /etc/fstab file.
Comment 2 Need Real Name 2000-11-03 07:37:40 EST
The RAID partitions were created by Druid->Make Raid Device button during RH6.2
installation and I then manully added the spare disk (/dev/sdg) to the
/etc/raidtab after successfully installed RH6.2.

The partition tables are (output from fdisk -lu)

Disk /dev/sda: 255 heads, 63 sectors, 2231 cylinders
Units = sectors of 1 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/sda1   *        63     48194     24066   83  Linux
/dev/sda2         48195    289169    120487+  82  Linux swap
/dev/sda3        289170  35841014  17775922+   5  Extended
/dev/sda5        289233    706859    208813+  fd  Linux raid autodetect
/dev/sda6        706923   1526174    409626   fd  Linux raid autodetect
/dev/sda7       1526238   1927799    200781   fd  Linux raid autodetect
/dev/sda8       1927863   2329424    200781   fd  Linux raid autodetect
/dev/sda9       2329488  35664299  16667406   fd  Linux raid autodetect
/dev/sda10     35664363  35841014     88326   83  Linux

Disk /dev/sdb: 255 heads, 63 sectors, 2231 cylinders
Units = sectors of 1 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/sdb1   *        63     48194     24066   83  Linux
/dev/sdb2         48195    289169    120487+  82  Linux swap
/dev/sdb3        289170  35841014  17775922+   5  Extended
/dev/sdb5        289233    706859    208813+  fd  Linux raid autodetect
/dev/sdb6        706923   1526174    409626   fd  Linux raid autodetect
/dev/sdb7       1526238   1927799    200781   fd  Linux raid autodetect
/dev/sdb8       1927863   2329424    200781   fd  Linux raid autodetect
/dev/sdb9       2329488  35664299  16667406   fd  Linux raid autodetect
/dev/sdb10     35664363  35841014     88326   83  Linux

Disk /dev/sdc: 255 heads, 63 sectors, 2231 cylinders
Units = sectors of 1 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/sdc1   *        63     48194     24066   83  Linux
/dev/sdc2         48195    289169    120487+  82  Linux swap
/dev/sdc3        289170  35841014  17775922+   5  Extended
/dev/sdc5        289233    706859    208813+  fd  Linux raid autodetect
/dev/sdc6        706923   1526174    409626   fd  Linux raid autodetect
/dev/sdc7       1526238   1927799    200781   fd  Linux raid autodetect
/dev/sdc8       1927863   2329424    200781   fd  Linux raid autodetect
/dev/sdc9       2329488  35664299  16667406   fd  Linux raid autodetect
/dev/sdc10     35664363  35841014     88326   83  Linux

Disk /dev/sdd: 255 heads, 63 sectors, 2231 cylinders
Units = sectors of 1 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/sdd1   *        63     48194     24066   83  Linux
/dev/sdd2         48195    289169    120487+  82  Linux swap
/dev/sdd3        289170  35841014  17775922+   5  Extended
/dev/sdd5        289233    706859    208813+  fd  Linux raid autodetect
/dev/sdd6        706923   1526174    409626   fd  Linux raid autodetect
/dev/sdd7       1526238  1927799    200781   fd  Linux raid autodetect
/dev/sdd8       1927863   2329424    200781   fd  Linux raid autodetect
/dev/sdd9       2329488  35664299  16667406   fd  Linux raid autodetect
/dev/sdd10     35664363  35841014     88326   83  Linux

Disk /dev/sde: 255 heads, 63 sectors, 2231 cylinders
Units = sectors of 1 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/sde1   *        63     48194     24066   83  Linux
/dev/sde2         48195    289169    120487+  82  Linux swap
/dev/sde3        289170  35841014  17775922+   5  Extended
/dev/sde5        289233    706859    208813+  fd  Linux raid autodetect
/dev/sde6        706923   1526174    409626   fd  Linux raid autodetect
/dev/sde7       1526238   1927799    200781   fd  Linux raid autodetect
/dev/sde8       1927863   2329424    200781   fd  Linux raid autodetect
/dev/sde9       2329488  35664299  16667406   fd  Linux raid autodetect
/dev/sde10     35664363  35841014     88326   83  Linux

Disk /dev/sdf: 255 heads, 63 sectors, 2231 cylinders
Units = sectors of 1 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/sdf1   *        63     48194     24066   83  Linux
/dev/sdf2         48195    289169    120487+  82  Linux swap
/dev/sdf3        289170  35841014  17775922+   5  Extended
/dev/sdf5        289233    706859    208813+  fd  Linux raid autodetect
/dev/sdf6        706923   1526174    409626   fd  Linux raid autodetect
/dev/sdf7       1526238   1927799    200781   fd  Linux raid autodetect
/dev/sdf8       1927863   2329424    200781   fd  Linux raid autodetect
/dev/sdf9       2329488  35664299  16667406   fd  Linux raid autodetect
/dev/sdf10     35664363  35841014     88326   83  Linux

Disk /dev/sdg: 255 heads, 63 sectors, 2221 cylinders
Units = sectors of 1 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/sdg1   *        63     48194     24066   83  Linux
/dev/sdg2         48195    289169    120487+  82  Linux swap
/dev/sdg3        289170  35680364  17695597+   5  Extended
/dev/sdg5        289233    706859    208813+  fd  Linux raid autodetect
/dev/sdg6        706923   1526174    409626   fd  Linux raid autodetect
/dev/sdg7       1526238   1927799    200781   fd  Linux raid autodetect
/dev/sdg8       1927863   2329424    200781   fd  Linux raid autodetect
/dev/sdg9       2329488  35664299  16667406   fd  Linux raid autodetect
/dev/sdg10     35664363  35680364      8001   83  Linux

The /etc/raidtab is :
raiddev             /dev/md0
raid-level                  5
nr-raid-disks               6
chunk-size                  64k
persistent-superblock       1
nr-spare-disks      1
    device          /dev/sda5
    raid-disk     0
    device          /dev/sdb5
    raid-disk     1
    device          /dev/sdc5
    raid-disk     2
    device          /dev/sdd5
    raid-disk     3
    device          /dev/sde5
    raid-disk     4
    device          /dev/sdf5
    raid-disk   5
    device          /dev/sdg5
    spare-disk    0
raiddev             /dev/md1
raid-level                  5
nr-raid-disks               6
chunk-size                  64k
persistent-superblock       1
nr-spare-disks      1
    device          /dev/sda6
    raid-disk     0
    device          /dev/sdb6
    raid-disk     1
    device          /dev/sdc6
    raid-disk     2
    device          /dev/sdd6
    raid-disk     3
    device          /dev/sde6
    raid-disk     4
    device          /dev/sdf6
    raid-disk     5
    device          /dev/sdg6
    spare-disk     0
raiddev             /dev/md2
raid-level                  5
nr-raid-disks               6
chunk-size                  64k
persistent-superblock       1
nr-spare-disks      1
    device          /dev/sda7
    raid-disk     0
    device          /dev/sdb7
    raid-disk     1
    device          /dev/sdc7
    raid-disk     2
    device          /dev/sdd7
    raid-disk     3
    device          /dev/sde7
    raid-disk     4
    device          /dev/sdf7
    raid-disk     5
    device          /dev/sdg7
    spare-disk     0
raiddev             /dev/md3
raid-level                  5
nr-raid-disks               6
chunk-size                  64k
persistent-superblock       1
nr-spare-disks      1
    device          /dev/sda8
    raid-disk     0
    device          /dev/sdb8
    raid-disk     1
    device          /dev/sdc8
    raid-disk     2
    device          /dev/sde8
    raid-disk     3
    device          /dev/sdf8
    raid-disk     4
    device          /dev/sdd8
    raid-disk     5
    device          /dev/sdg8
    spare-disk     0
raiddev             /dev/md4
raid-level                  5
nr-raid-disks               6
chunk-size                  64k
persistent-superblock       1
nr-spare-disks      1
    device          /dev/sda9
    raid-disk     0
    device          /dev/sdb9
    raid-disk     1
    device          /dev/sdc9
    raid-disk     2
    device          /dev/sdd9
    raid-disk     3
    device          /dev/sde9
    raid-disk     4
    device          /dev/sdf9
    raid-disk     5
    device          /dev/sdg9
    raid-disk     0


The /etc/fstab is:
/dev/md0                /                       ext2    defaults        1 1
/dev/sda1               /boot                   ext2    defaults        1 2
/dev/md4        /data   ext2     exec,dev,nosuid,rw,usrquota,grpquota 1 2
/dev/md3                /knox                   ext2    defaults        1 2
/dev/md1                /usr                    ext2    defaults        1 2
/dev/md2                /var                    ext2    defaults        1 2
/dev/fd0                /mnt/floppy             auto    noauto,owner    0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/pts                devpts  gid=5,mode=620  0 0
/dev/sda2               swap                    swap    defaults        0 0
/dev/sdb2   swap                    swap    defaults        0 0
/dev/sdc2               swap                    swap    defaults        0 0
/dev/sdd2               swap                    swap    defaults        0 0
/dev/sde2               swap                    swap    defaults        0 0
/dev/sdf2               swap                    swap    defaults        0 0
/dev/sdg2               swap                    swap    defaults        0 0

Furthermore, the /home is not mounted locally. It is mounted by NIS and autofs.
I am wondering whether that causes trouble.

Regards
Comment 3 Michael Fulbright 2000-11-15 11:31:08 EST
Was /home mounted locally when you installed the current version of Linux which
is on your machine?

I think that having /home remotely mounted is probably a problem.
Comment 4 Michael Fulbright 2001-01-19 16:27:48 EST
*** Bug 21908 has been marked as a duplicate of this bug. ***
Comment 5 Michael Fulbright 2001-01-26 13:07:36 EST
*** Bug 23015 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.