Bug 198534 - /etc/sysconfig/snmpd file not read at snmpd startup
/etc/sysconfig/snmpd file not read at snmpd startup
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-snmp (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-11 13:19 EDT by John DeFranco
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-29 16:45:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John DeFranco 2006-07-11 13:19:05 EDT
Description of problem:
According to the net-snmp docs I've seen I should be able to set OPTIONS
for snmpd in the file /etc/sysconfig/snmpd. This does not work however as
the /etc/rc.d/init.d/snmpd file does not use the /etc/sysconfig/snmpd file 
and the OPTIONS parameters are hardcoded anyway. There should be some way
for a user to specify OPTION changes without having to edit the 
/etc/rc.d/init.d/snmpd file, which could be lost if the net-snmp rpm 
is updated.

Version-Release number of selected component (if applicable):
net-snmp-5.1.2-11

How reproducible:

Look at the file.
# source function library
. /etc/init.d/functions

OPTIONS="-Lsd -Lf /dev/null -p /var/run/snmpd -a"
RETVAL=0
prog="snmpd"

OPTIONS are hardcoded and no mention of using the /etc/sysconfig/snmpd file.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Radek Vokal 2006-07-12 08:18:15 EDT
well, users are basically forced to use /etc/snmp/snmpd.conf file for all
configuration. But I see this is really missing there for runtime options but
I'd prefer moving it to the same directory as snmpd.conf is - eg.
/etc/snmp/snmpd.options file like for snmptrapd. 
Comment 2 RHEL Product and Program Management 2006-08-18 11:12:21 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 David Lawrence 2006-08-29 16:30:13 EDT
Sounds like more discussion is needed to determine where the final options
should live. Then we can work towards finding a good test case for fix
verification. QE_ACK-
Comment 4 RHEL Product and Program Management 2006-08-29 16:45:12 EDT
Quality Engineering Management has reviewed and declined this request.  You may
appeal this decision by reopening this request. 
Comment 5 Peter Bieringer 2007-05-09 07:25:42 EDT
Note that at since net-snmp-5.1.2-11.EL4.10 (RHEL4 U5) support of
/etc/sysconfig/snmpd.options was added:

if [ -e /etc/sysconfig/snmpd.options ]; then
  . /etc/sysconfig/snmpd.options
else
  OPTIONS="-Lsd -Lf /dev/null -p /var/run/snmpd.pid -a"
fi


But I do not understand, why the naming schema was broken, I would expect
/etc/sysconfig/snmpd instead of /etc/sysconfig/snmpd.options - has this a deeper
reason or should a new bug be opened regarding this naming issue?

Related changelog entry in spec file:
- fixed snmpd init script, the path for config file is
/etc/sysconfig/snmpd.options (#199450)

BTW: #199450 is not accessable at least by me :-(

Bug status should be changed now.

Note You need to log in before you can comment on or make changes to this bug.