Bug 198550 - PS2 keyboard and mouse work in BIOS, but not recognized in OS
PS2 keyboard and mouse work in BIOS, but not recognized in OS
Status: CLOSED DUPLICATE of bug 198549
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-11 15:20 EDT by James Laska
Modified: 2013-09-02 02:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-11 15:21:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (23.71 KB, text/plain)
2006-07-11 15:20 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2006-07-11 15:20:57 EDT
# RPM kernel-2.6.17-1.2364.fc6
# SYSTEM Dell Precision 380

The mouse and keyboard work in the BIOS and grub ... but are not recognized by
the OS.  I can plug in a USB keyboard and that works.  The same behavior is
observed regardless of whether connected to a KVM or directly to keyboard+mouse.

The only input devices that show up in sysfs are:

# cat /sys/class/input/input*/name
PC Speaker

Compared to my laptop running the same kernel:

$ cat /sys/class/input/input*/name
AT Translated Set 2 keyboard
Logitech Logitech USB Keyboard
Logitech Logitech USB Keyboard
SynPS/2 Synaptics TouchPad
PC Speaker
TPPS/2 IBM TrackPoint
Logitech USB-PS/2 Mouse M-BA47

Please advise if there are any additional details I can grab to assist with
debugging.  I have attached dmesg on the failing system.
Comment 1 James Laska 2006-07-11 15:20:57 EDT
Created attachment 132264 [details]
dmesg
Comment 2 James Laska 2006-07-11 15:21:46 EDT
Sorry for noise ... having bugzilla issues at the moment ... duping to bug
198549    

*** This bug has been marked as a duplicate of 198549 ***
Comment 3 James Laska 2006-07-11 15:24:48 EDT

*** This bug has been marked as a duplicate of 198549 ***
Comment 4 James Laska 2006-07-11 15:34:40 EDT

*** This bug has been marked as a duplicate of 198549 ***

Note You need to log in before you can comment on or make changes to this bug.