Bug 198574 - firefox unaligned access messages
firefox unaligned access messages
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: firefox (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
massRequestForReproduction
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-11 20:42 EDT by Bryan Stillwell
Modified: 2010-01-25 16:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-25 16:24:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Stillwell 2006-07-11 20:42:47 EDT
Description of problem:
When choosing to configure connection settings in firefox, multiple unaligned
access messages are written to the console.

Version-Release number of selected component (if applicable):
firefox-1.5.0.3-2

How reproducible:100%


Steps to Reproduce:
1. Run firefox
2. Click on Edit
3. Choose Preferences
4. In the General tab, click on the 'Connection Settings' button
5. Notice the unaligned access messages
  
Actual results:
firefox-bin(31460): unaligned access to 0x60000ffffed44acf, ip=0x2000000008b0e9f0
firefox-bin(31460): unaligned access to 0x60000ffffed44acf, ip=0x20000000010f4651
firefox-bin(31460): unaligned access to 0x60000ffffed44acf, ip=0x20000000010f4840
firefox-bin(31460): unaligned access to 0x60000ffffed44acf, ip=0x2000000008af9600
firefox-bin(31460): unaligned access to 0x60000ffffed44acf, ip=0x2000000005776ce1



Expected results:
no output

Additional info:
Moving around in the preferences menus produces more messages in different areas.
Comment 1 Bryan Stillwell 2006-07-11 20:44:36 EDT
This was in rhel5a1.  I had to choose rhel4 because rhel5 wasn't an option.
Comment 2 Matěj Cepl 2008-02-08 15:42:48 EST
Since this bugzilla report was filed, we have seriously upgraded Gecko-related
packages, which may have resolved this issue. Users who have experienced this
problem are encouraged to upgrade their system to the latest version of their
distribution available.

Please, confirm to us that this bug is reproducible on the latest upgrade of the
supported distribution (that's RHEL, or Fedora 7, 8, and Rawhide).

Setting the bug to NEEDINFO. If I won't get confirmation of reproducability in
30 days, the bug will be closed as INSUFFICIENT_DATA.

[This is mass-changing of bugs which seem to be too old and irrelevant anymore;
we are sorry, if this bug should not be incldued.]
Comment 3 Bryan Stillwell 2008-02-08 17:29:31 EST
Still exists in rhel5.1/ia64
Comment 4 Bryan Stillwell 2008-02-08 17:40:15 EST
Changing status back to ASSIGNED
Comment 5 Yolkfull Chow 2008-07-01 05:19:42 EDT
This problem also happen on firefox-3.0.1 over ia64 though I haven't been enable
to catch the exact steps.
Comment 6 Chuck Morrison 2008-09-16 17:22:03 EDT
Trying this on a rhel5.2 dom0(Firefox-3.0-b5/ia64), I don't see the messages that this bz was filed about. However, I get these messages over and over and over (in dmesg) :

Allowing physinfo call with newer ABI version
Allowing physinfo call with newer ABI version
Allowing physinfo call with newer ABI version
Allowing physinfo call with newer ABI version
Allowing physinfo call with newer ABI version
Allowing physinfo call with newer ABI version
Allowing physinfo call with newer ABI version
Allowing physinfo call with newer ABI version
Allowing physinfo call with newer ABI version
Allowing physinfo call with newer ABI version
Allowing physinfo call with newer ABI version
Allowing physinfo call with newer ABI version
Allowing physinfo call with newer ABI version
Allowing physinfo call with newer ABI version

I don't see this issue when trying it on rhel5.2 (Firefox-3.0-b5/ia64) in a PV domU.
Comment 7 Rick Hester 2010-01-25 16:24:58 EST
closing due to age

Note You need to log in before you can comment on or make changes to this bug.