Bug 198580 - kernel hang "Starting udev:_" on Athlon SiS 730
kernel hang "Starting udev:_" on Athlon SiS 730
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-11 21:38 EDT by John Reiser
Modified: 2015-01-04 17:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-16 09:22:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
git names the first bad commit (985 bytes, text/plain)
2006-07-13 12:48 EDT, John Reiser
no flags Details
.git/BISECT_LOG (2.30 KB, text/plain)
2006-07-13 12:50 EDT, John Reiser
no flags Details
lspci output (5.31 KB, text/plain)
2006-07-13 12:51 EDT, John Reiser
no flags Details

  None (edit)
Description John Reiser 2006-07-11 21:38:42 EDT
Description of problem:
The kernel hangs with a hard freeze during init on a clone box with Athlon plain
CPU and Silicon Integrated Systems [SiS] 730 chipset.  The VGA console shows
"Starting udev:_" where the '_' indicates that the cursor has stopped blinking.
 Serial console shows no Oops.  There is no response to any keyboard entries,
including <ctrl><alt><del>, <alt><sysrq>T, etc., even when appending "debug" or
"debug=7" to boot command line.  The same symptom appears when appending
"single" option on the boot command line.

On the surface this seems to be a replay of:
bug #179601  which was caused by a bad kernel patch.

Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2364

How reproducible:
always

Steps to Reproduce:
1. boot
2.
3.
  
Actual results:
Hang "Starting udev:_"; no response after three minutes.

Expected results:
Normal boot.

Additional info:
Last kernel known to work is 2.6.16-1.2289 ("2.6.17-rc6-bit7" ?)

I tried to perform git bisect.  "git clone git://...", "git bisect start", "git
bisect bad 2.6.18" all worked.  But "git bisect good 2.6.17" says "fatal: Need a
single revision" which stumps me.  Suggestions?
Comment 1 John Reiser 2006-07-13 12:48:15 EDT
Created attachment 132385 [details]
git names the first bad commit
Comment 2 John Reiser 2006-07-13 12:50:15 EDT
Created attachment 132386 [details]
.git/BISECT_LOG

Log of runs of git bisect.
Comment 3 John Reiser 2006-07-13 12:51:09 EDT
Created attachment 132387 [details]
lspci output

lcpsi; lspci -n; lspci -v
Comment 4 John Reiser 2006-07-13 12:58:10 EDT
At the last 4 ir 5 stages of "git bisect", the blink rate of the cursor on the
VGA console was erratic during "Starting udev: _".  From about 2 Hz it would
slow to 1 Hz (or less) for 5 or 6 seconds, then resume at 2 Hz.  Of course, the
bad bisects would slow to 0 Hz (no blinking; freeze).
Comment 5 Dave Jones 2006-07-15 23:23:21 EDT
if this still isn't fixed, could you bring it up on linux-kernel ?

Thanks.
Comment 6 John Reiser 2006-07-16 09:22:58 EDT
The problem has disappered from kernel-2.6.17-1.2396.fc6 (and also 2405; 2401
not checked.)

Note You need to log in before you can comment on or make changes to this bug.