Bug 198592 - ThinkPad T42 won't suspend, complaining of unstopped tasks
Summary: ThinkPad T42 won't suspend, complaining of unstopped tasks
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
Whiteboard: MassClosed
Depends On:
TreeView+ depends on / blocked
Reported: 2006-07-12 06:47 UTC by Myk Melez
Modified: 2008-01-20 04:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-20 04:37:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

Description Myk Melez 2006-07-12 06:47:24 UTC
Ever since June 28, shortly after I updated some software on my laptop, I've
often been unable to suspend it.  /var/log/messages sometimes reports that one
task failed to stop:

Jul 10 10:21:45 myk kernel:  stopping tasks failed (1 tasks remaining)
Jul 10 10:21:45 myk kernel: Restarting tasks...<6> Strange, hald-addon-stor not

But often it reports that 11 failed (it seems to be the same 11 every time):

Jul 11 12:47:44 myk kernel: Restarting tasks...<6> Strange, khubd not stopped
Jul 11 12:47:44 myk kernel:  Strange, kseriod not stopped
Jul 11 12:47:44 myk kernel:  Strange, pdflush not stopped
Jul 11 12:47:44 myk kernel:  Strange, pdflush not stopped
Jul 11 12:47:44 myk kernel:  Strange, kswapd0 not stopped
Jul 11 12:47:44 myk kernel:  Strange, pccardd not stopped
Jul 11 12:47:44 myk NetworkManager: <information>       Waking up from sleep.
Jul 11 12:47:44 myk NetworkManager: <information>       Deactivating device eth0.
Jul 11 12:47:44 myk kernel:  Strange, pccardd not stopped
Jul 11 12:47:44 myk kernel:  Strange, kjournald not stopped
Jul 11 12:47:44 myk kernel:  Strange, kjournald not stopped
Jul 11 12:47:44 myk kernel:  Strange, hald-addon-stor not stopped
Jul 11 12:47:44 myk kernel:  Strange, kauditd not stopped

Here are the packages I installed shortly before experiencing this problem for
the first time (a snippet from rpm -qa --last):

meld-1.1.4-2.fc5                              Wed 28 Jun 2006 11:13:14 AM PDT
gnome-python2-gconf-2.12.4-1                  Wed 28 Jun 2006 11:13:12 AM PDT
python-devel-2.4.3-8.FC5                      Mon 26 Jun 2006 03:40:45 PM PDT
shared-mime-info-0.17-1.fc5.2                 Mon 26 Jun 2006 03:40:35 PM PDT
NetworkManager-gnome-0.6.3-1.fc5              Mon 26 Jun 2006 03:40:31 PM PDT
tetex-3.0-20.FC5                              Mon 26 Jun 2006 03:40:25 PM PDT
ruby-devel-1.8.4-6.fc5                        Mon 26 Jun 2006 03:40:15 PM PDT
cscope-15.5-13.7                              Mon 26 Jun 2006 03:40:13 PM PDT
system-config-lvm-1.0.18-1.2.FC5              Mon 26 Jun 2006 03:40:12 PM PDT
mkbootdisk-1.5.2-7                            Mon 26 Jun 2006 03:40:10 PM PDT
ruby-ri-1.8.4-6.fc5                           Mon 26 Jun 2006 03:40:08 PM PDT
NetworkManager-glib-0.6.3-1.fc5               Mon 26 Jun 2006 03:40:00 PM PDT
autofs-4.1.4-29                               Mon 26 Jun 2006 03:39:59 PM PDT
smartmontools-5.36-fc5.1                      Mon 26 Jun 2006 03:39:57 PM PDT
frysk-              Mon 26 Jun 2006 03:39:55 PM PDT
nss-devel-3.11.1-1.fc5                        Mon 26 Jun 2006 03:39:51 PM PDT
gdm-2.14.9-1                                  Mon 26 Jun 2006 03:39:34 PM PDT
nss-3.11.1-1.fc5                              Mon 26 Jun 2006 03:39:29 PM PDT
openmotif-2.3.0-                       Mon 26 Jun 2006 03:39:27 PM PDT
ruby-rdoc-1.8.4-6.fc5                         Mon 26 Jun 2006 03:38:26 PM PDT
ruby-irb-1.8.4-6.fc5                          Mon 26 Jun 2006 03:38:25 PM PDT
tetex-fonts-3.0-20.FC5                        Mon 26 Jun 2006 03:37:41 PM PDT
libvte-java-0.12.0-0.FC5                      Mon 26 Jun 2006 03:37:20 PM PDT
libglade-java-2.12.4-0.FC5                    Mon 26 Jun 2006 03:37:18 PM PDT
libgnome-java-2.12.3-0.FC5                    Mon 26 Jun 2006 03:37:16 PM PDT
ruby-1.8.4-6.fc5                              Mon 26 Jun 2006 03:37:15 PM PDT
ruby-libs-1.8.4-6.fc5                         Mon 26 Jun 2006 03:37:11 PM PDT
NetworkManager-0.6.3-1.fc5                    Mon 26 Jun 2006 03:37:05 PM PDT
python-2.4.3-8.FC5                            Mon 26 Jun 2006 03:36:55 PM PDT
libgtk-java-2.8.5-0.FC5                       Mon 26 Jun 2006 03:36:39 PM PDT
cairo-java-1.0.4-0.FC5                        Mon 26 Jun 2006 03:36:35 PM PDT
glib-java-0.2.5-0.FC5                         Mon 26 Jun 2006 03:36:32 PM PDT

I think I also installed kernel 2.6.17-1.2139_FC5 shortly before the problem
cropped up, although I've since uninstalled it, so I don't have a record of its
install date.  I'm currently running 2.6.17-1.2145_FC5.  Before the problems
started, I was running 2.6.16-1.2133_FC5.

Once, when hald-addon-stor was the only task that wouldn't stop, I tried to kill
it manually, first nicely and then aggressively (kill -9), but it turned out to
be in the "uninterruptable sleep" state, owned by the init process, according to
ps, and thus unstoppable.

I've also tried letting nonsleeping dogs lie for a day or so, but once it stops
being able to suspend, it never regains that ability until I reboot.  It usually
takes a couple days to get into the state, although I've seen it happen within a

I note bug 197404, bug 197675, and bug 197944 (all dupes?), but they're all
FC6/devel, while my issue is on FC5.  But perhaps it's the same problem, and it
just manifests differently on FC5.

Comment 1 Dave Jones 2006-10-16 17:41:37 UTC
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.

Comment 2 Jon Stanley 2008-01-20 04:37:53 UTC
(this is a mass-close to kernel bugs in NEEDINFO state)

As indicated previously there has been no update on the progress of this bug
therefore I am closing it as INSUFFICIENT_DATA. Please re-open if the issue
still occurs for you and I will try to assist in its resolution. Thank you for
taking the time to report the initial bug.

If you believe that this bug was closed in error, please feel free to reopen
this bug.

Note You need to log in before you can comment on or make changes to this bug.