Bug 198653 - xf86writeConfigFile always writes Files and Module sections
xf86writeConfigFile always writes Files and Module sections
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-12 11:12 EDT by Chris Lumens
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-21 16:49:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to not write out empty sections (821 bytes, patch)
2006-07-12 11:12 EDT, Chris Lumens
no flags Details | Diff

  None (edit)
Description Chris Lumens 2006-07-12 11:12:04 EDT
The Files and Module sections are always written out, even if they are empty,
because the printers in xc/programs/Xserver/hw/xfree86/parser/write.c do not
have guards to check for NULL.  Other sections in the config file writer have
these guards.  Attached is a simple, but untested, patch against the gitweb sources.
Comment 1 Chris Lumens 2006-07-12 11:12:04 EDT
Created attachment 132311 [details]
patch to not write out empty sections
Comment 2 Mike A. Harris 2006-07-21 16:49:26 EDT
Patch added to: xorg-x11-server-1.1.1-7

Note You need to log in before you can comment on or make changes to this bug.