This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 198662 - After latest updating coreutils has lost ACL support completely
After latest updating coreutils has lost ACL support completely
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-12 12:31 EDT by Dmitry Butskoy
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.97-1.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-20 07:29:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dmitry Butskoy 2006-07-12 12:31:50 EDT
Description of problem:
The current FC5's coreutils-5.96-1.2 package (latest update) has no ACL support
at all.


Version-Release number of selected component (if applicable):
5.96-1.2

How reproducible:
>foo
setfacl -m u:daemon:r-x foo

ls foo
 -- shows "rwxr-xr-x" instead of "rwxr-xr-x+"
ldd /bin/ls
 -- no libacl in dependencies

cp -p foo bar
getfacl bar
 -- new file has no acl


Additional info:
Perhaps it is because the configure script did not find acl libs, as there is no
libacl-devel as BR ...
Comment 1 Tim Waugh 2006-07-13 06:56:20 EDT
Thanks for the report.  coreutils-5.97-1.1 is now in the works for an FC5 update
to fix this.
Comment 2 Dmitry Butskoy 2006-07-17 08:04:11 EDT
coreutils-5.97-1.1 from updates/testing/5 is OK
Comment 3 Dmitry Butskoy 2006-07-20 07:29:00 EDT
Fixed in coreutils-5.97-1.1, now in updates/5 .

Note You need to log in before you can comment on or make changes to this bug.