Bug 198692 - Odd handling of debuginfo download URL
Odd handling of debuginfo download URL
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-12 16:33 EDT by Orion Poplawski
Modified: 2014-01-21 17:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 17:49:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2006-07-12 16:33:42 EDT
Description of problem:

I mirror the fedora repository locally, but not the debuginfo packages.  So, I
have repos configured like:

[updates-testing]
name=Fedora Core $releasever - $basearch - Updates Testing
failovermethod=priority
baseurl=file:///data/sw1/fedora/core/updates/testing/$releasever/$basearch/
enabled=1

[updates-testing-debuginfo]
name=Fedora Core $releasever - $basearch - Updates Testing - Debug
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/$releasever/$basearch/debug/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora

No, with util-linux-debuginfo-2.13-0.20.1 installed, and -0.20.4 available from
updates-testing-debuginfo, I run into the following problem:

[root@hammer ~]# yum --enablerepo updates-testing-debuginfo update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
core                                                                 [1/7]
livna                                                                [2/7]
updates-testing-debuginfo                                            [3/7]
updates                                                              [4/7]
CoRA                                                                 [5/7]
updates-testing                                                      [6/7]
extras                                                               [7/7]
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package createrepo.noarch 0:0.4.4-0.1 set to be updated
---> Package util-linux.x86_64 0:2.13-0.20.4 set to be updated
---> Package hal.x86_64 0:0.5.7-3.fc5.3 set to be updated
---> Package tcsh.x86_64 0:6.14-6.fc5.2 set to be updated
---> Package quota.x86_64 1:3.13-1.2.2 set to be updated
---> Package xorg-x11-drv-nv.x86_64 0:1.2.0-1.fc5 set to be updated
---> Package nscd.x86_64 0:2.4-9 set to be updated
---> Downloading header for util-linux-debuginfo to pack into transaction set.
file:///data/sw1/fedora/core/updates/testing/5/x86_64/debug/util-linux-debuginfo-2.13-0.20.4.x86_64.rpm:
[Errno 5] OSError: [Errno 2] No such file or directory:
'/data/sw1/fedora/core/updates/testing/5/x86_64/debug/util-linux-debuginfo-2.13-0.20.4.x86_64.rpm'
Trying other mirror.
Error: failure: debug/util-linux-debuginfo-2.13-0.20.4.x86_64.rpm from
updates-testing: [Errno 256] No more mirrors to try.

Why is it trying to use the url from [updates-testing] instead of
[updates-testing-debuginfo] ?

Version-Release number of selected component (if applicable):
yum-2.6.1-0.fc5
Comment 1 Jeremy Katz 2006-07-18 16:28:00 EDT
Can you look in the repodata/primary.xml.gz of your local copy and see if it
contains util-linux-debuginfo? 
Comment 2 Orion Poplawski 2006-07-27 13:04:22 EDT
I'm afraid we may have lost this config.  But this is what I had most recently.

updates
updates-debuginfo
  <name>util-linux-debuginfo</name>
  <location href="util-linux-debuginfo-2.13-0.20.1.x86_64.rpm"/>
      <rpm:entry name="util-linux-debuginfo" flags="EQ" epoch="0" ver="2.13"
rel="0.20.1"/>
updates-testing
updates-testing-debuginfo
  <name>util-linux-debuginfo</name>
  <location href="util-linux-debuginfo-2.13-0.20.4.x86_64.rpm"/>
      <rpm:entry name="util-linux-debuginfo" flags="EQ" epoch="0" ver="2.13"
rel="0.20.4"/>
Comment 3 Jeremy Katz 2006-07-27 17:49:45 EDT
This was almost certainly caused by the fact that the debug/ repodata was
chunked in with the main updates/ metadata.  Luke fixed that up in the past day
or three

Note You need to log in before you can comment on or make changes to this bug.