Bug 198696 - joe uses spaces instead of tabs in makefiles
joe uses spaces instead of tabs in makefiles
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: joe (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-12 17:21 EDT by Jeff MacDonald
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-20 04:21:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff MacDonald 2006-07-12 17:21:45 EDT
Description of problem:

joe, by default, does not use tabs in Makefiles.

Version-Release number of selected component (if applicable):
joe-3.3-2

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:

joe uses spaces instead of tabs in makefiles

Expected results:

makefiles *require* tabs for indentation.


Additional info:

add "--spaces" to "*akefiles" rule in /etc/joe/joerc
Comment 1 Jeff MacDonald 2006-07-12 17:23:59 EDT
might also need/want to add "-indentc 9" to the *akefile rule as well
Comment 2 Marcela Mašláňová 2006-07-19 10:06:23 EDT
I tested the same version joe without and with parameter, but I see tabs in both
cases.
Comment 3 Jeff MacDonald 2006-07-19 11:12:55 EDT
this issue is only relevant if spaces are being used for indenting. I can't see
any harm in adding a couple of directives to the default joerc, since makefiles
will *always* require tabs for indenting.

Comment 4 Marcela Mašláňová 2006-07-20 04:21:39 EDT
I don't think spaces instead tabs are good idea. These options are unusal so I
can't include them in standart package.

Note You need to log in before you can comment on or make changes to this bug.