Bug 198720 - yum configuration for core-debuginfo repository seems to be incorrect.
Summary: yum configuration for core-debuginfo repository seems to be incorrect.
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-13 04:14 UTC by Tim Mayberry
Modified: 2013-01-10 01:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-19 23:54:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Mayberry 2006-07-13 04:14:26 UTC
Description of problem:

I installed FC6test1 recently and noticing a bug I enabled the core-debuginfo
repository and tried to install a debuginfo package and got this error:

# yum install glibc-debuginfo
Setting up Install Process
Setting up repositories
Error: Cannot find a valid baseurl for repo: core-debuginfo

I changed the configuration to from this:

[core-debuginfo]
name=Fedora Core $releasever - $basearch - Debug
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/$releasever/$basearch/debug/
mirrorlist=http://fedora.redhat.com/Download/mirrors/fedora-core-debug-$releasever
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
file:///etc/pki/rpm-gpg/RPM-GPG-KEY

to this:

[core-debuginfo]
name=Fedora Core $releasever - $basearch - Debug
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/$releasever/$basearch/debug/
mirrorlist=http://fedora.redhat.com/Download/mirrors/fedora-core-rawhide-debug
enabled=1
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
file:///etc/pki/rpm-gpg/RPM-GPG-KEY

to get a debuginfo package from the core repository installed.

Note that I also had to disable the gpgcheck because it reported the packages as
being unsigned:
 
Package glibc-debuginfo-2.4.90-13.i686.rpm is not signed

Version-Release number of selected component (if applicable):

fedora-release-5.90-3

Comment 1 Jesse Keating 2006-07-19 23:54:56 UTC
the Core debug should point to the relase version.  The Core repos shouldn't be
enbaled, the development repos should, which point to rawhide-debug.


Note You need to log in before you can comment on or make changes to this bug.