Bug 198751 - 2.4.21-20.EL proc/net/dev reports empty lines with net-snmp
2.4.21-20.EL proc/net/dev reports empty lines with net-snmp
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-13 05:30 EDT by Jose Plans
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-18 18:41:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jose Plans 2006-07-13 05:30:07 EDT
Description of problem:

Using net-snmp, a customer noticed that sometimes /proc/net/dev reports an empty
line. the reports show :

     snmpd[26834]: /proc/net/dev data format error, line ==|0| 

Reading in the code of net-snmp, this part of the code just reads /proc/net/dev,
and if an empty line is found then pass to the next line. Is this a known race
condition ?

This is using 2.4.21-20.

Version-Release number of selected component (if applicable):

net-snmp-5.0.9-2.30E.19
kernel-2.4.21-20.EL.i686

How reproducible:
Not always.

Steps to Reproduce:
1. Set monitoring with net-snmp
2. See the error lines appearing.
  
Actual results:

We see net-snmp reporting empty lines.

snmpd[26834]: /proc/net/dev data format error, line ==|0|


Expected results:

No empty lines.

Additional info:

This seems not to be harmful since the net-snmp project decided to workaround
the issue with a test on empty lines within the code.

-- agent/mibgroup/mibII/interfaces.c --
        if (!*ifstart || ((stats = strrchr(ifstart, ':')) == NULL)) {
            snmp_log(LOG_ERR,
                     "/proc/net/dev data format error, line ==|%s|", line);
            continue;
        }
-- agent/mibgroup/mibII/interfaces.c --
Comment 1 Ernie Petrides 2006-07-17 18:42:15 EDT
RHEL3 is now closed.
Comment 4 RHEL Product and Program Management 2006-12-18 18:41:53 EST
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.