Bug 198895 - RX2600 display problems with Radeon card (itanium)
Summary: RX2600 display problems with Radeon card (itanium)
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11   
(Show other bugs)
Version: 4.0
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Dave Airlie
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords: OtherQA
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-14 14:11 UTC by Bastien Nocera
Modified: 2009-06-19 08:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 00:46:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (45.06 KB, text/plain)
2006-07-14 14:11 UTC, Bastien Nocera
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0657 normal SHIPPED_LIVE xorg-x11 bug fix and enhancement update 2008-07-23 15:28:26 UTC

Description Bastien Nocera 2006-07-14 14:11:22 UTC
xorg 6.8.2-1.EL.13.33

On the RX2600 (an ia64 machine), after the initial installation, all the uses of
X show garbled display.

The problem looks similar to bug 182471, but only testing with the certified
machine would allow to verify that it's the same issue.

Xorg recognises the card as a "RV100 QY/Radeon 7000/VE".
The same card running in an x86 machine doesn't show any display problems.

X log attached.

80:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon
7000/VE]
80:00.0 Class 0300: 1002:5159

Comment 1 Bastien Nocera 2006-07-14 14:11:23 UTC
Created attachment 132440 [details]
Xorg.0.log

Comment 2 Bastien Nocera 2006-07-14 14:13:02 UTC
I forgot to mention that adding the "Option XaaNoOffscreenPixmaps" line in the
xorg.conf corrected the problem.

Comment 5 Søren Sandmann Pedersen 2007-01-11 23:52:51 UTC
Is it possible for someone to test whether the packages in 

   /mnt/redhat/brewroot/packages/xorg-x11/6.8.2/1.EL.13.41

fix this problem?

Thanks

Comment 6 Søren Sandmann Pedersen 2007-01-22 17:52:21 UTC
Any update?

Comment 7 Søren Sandmann Pedersen 2007-01-29 23:06:37 UTC
XAANoOffscreenPixmaps is turned on for __ia64__ in 

xorg-x11-6.8.2-1.EL.13.44



Comment 8 Bastien Nocera 2007-01-30 09:34:47 UTC
The original reported says:
"No, the newer xorg-x11 packages built (on an RHEL4u4 everything-install) do not
help."

Comment 10 Søren Sandmann Pedersen 2007-01-30 18:40:05 UTC
Note that the package doesn't change anything in the xorg.conf file. It simply
changes the default setting of the XAANoOffScreenPixmaps from FALSE to TRUE on
IA64 internally in the X server.


Comment 12 Søren Sandmann Pedersen 2007-01-30 21:49:45 UTC
Yes, the change should be in 13.44.

Can you ask them to explicitly put

   Option "XaaNoOffscreenPixmaps" "yes"

in the "Device" section of xorg.conf and see if that helps?


Comment 13 Søren Sandmann Pedersen 2007-01-30 22:36:03 UTC
Nevermind that. The patch I applied was wrong. I'll fix this in 13.46. Sorry
about that.

Comment 14 Søren Sandmann Pedersen 2007-01-30 22:45:06 UTC
13.46 is being built now.

Comment 16 Søren Sandmann Pedersen 2007-01-31 22:28:59 UTC
I was defeated by the Xorg config API. Not only should 13.48 fix it, it will
also print useful information about it in the log file. So if 13.48 doesn't
work, please also attach the generated log file (but I really think it should
work this time). 


Comment 23 Adam Jackson 2007-04-11 19:59:26 UTC
Moving to 4.6.

"ugliness is seen" isn't really descriptive enough to know what the problem is.
 Getting a hardware setup where we can reproduce this somewhere near me would be
helpful, but at a minimum we need to know what the failure mode actually is.

Comment 27 Suzanne Yeghiayan 2007-09-17 20:10:13 UTC
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.

Comment 28 RHEL Product and Program Management 2007-11-29 04:25:21 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 29 Dave Airlie 2008-04-03 00:46:18 UTC
upstream closed the request, don't bother unless they raise it again.

Comment 30 Chris Ward 2008-07-29 07:26:44 UTC
Partners, I would like to thank you all for your participation in assuring the
quality of this RHEL 4.7 Update Release. My hat's off to you all. Thanks.


Note You need to log in before you can comment on or make changes to this bug.