Bug 198940 - dovecot - incosistencies in a spec file
dovecot - incosistencies in a spec file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dovecot (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Petr Rockai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-14 16:23 EDT by Michal Jaegermann
Modified: 2014-01-21 17:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-10 14:08:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-07-14 16:23:08 EDT
Description of problem:

In dovecot.spec %files section says:

%config(noreplace) %{ssldir}/dovecot-openssl.cnf

But earlier in a spec file we have

mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/pki/dovecot/
install -p -m644 $RPM_BUILD_DIR/dovecot-%{upstream}/doc/dovecot-openssl.cnf
$RPM_BUILD_ROOT/%{_sysconfdir}/pki/dovecot/dovecot-openssl.cnf

and later

SSLDIR=%{ssldir} OPENSSLCONFIG=%{_sysconfdir}/pki/dovecot/dovecot-openssl.cnf \
	%{docdir}-%{version}/examples/mkcert.sh &> /dev/null

By a lucky accident all that happens to end up in the same location
as earlier there is

%define ssldir /etc/pki/%{name}

and %{_sysconfdir} currently evals to /etc; but if one will change
that %define above then dovecot-openssl.cnf from %files cannot be found.
%{ssldir} should be used throughout.

Also in %files section lines

%{_libdir}/%{name}/imap/*
%{_libdir}/%{name}/lda/*

generate only a bunch of "warning: File listed twice" because
next there is

%{_libdir}/%{name}/*

which covers all of that and more.  In any case instead of the
last line there really should be

%{_libdir}/%{name}

Otherwise we have "is not owned by any package" if we will try
to check what package owns that directory and removing 'dovecot'
package will result in leftovers.

Version-Release number of selected component (if applicable):
dovecot-1.0-0.beta8.2.1

Note You need to log in before you can comment on or make changes to this bug.