Bug 198941 - Multiple response (DUP!) to ICMP ping requests
Multiple response (DUP!) to ICMP ping requests
Status: CLOSED DUPLICATE of bug 198939
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-14 16:24 EDT by Tulio Llosa
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-17 18:51:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tulio Llosa 2006-07-14 16:24:07 EDT
Description of problem: 

We have several servers configured with two network channel bonding devices 
(bond0 and bond1) running RHEL 3 with active-backup or 1 mode:

/etc/modules.conf
#################
alias bond0 bonding
alias bond1 bonding
options bond0 miimon=100 mode=1
options bond1 -o bonding1 miimon=100 mode=1


Ethernet devices
################
more /etc/sysconfig/network-scripts/ifcfg-bond1
DEVICE=bond1
IPADDR=xx.xx.xx.xx
NETMASK=255.255.255.128
ONBOOT=yes
BOOTPROTO=none
USERCTL=no

more /etc/sysconfig/network-scripts/ifcfg-eth3
DEVICE=eth3
ONBOOT=yes
USERCTL=no
BOOTPROTO=none
MASTER=bond1
SLAVE=yes
PEERDNS=no
TYPE=Ethernet

more /etc/sysconfig/network-scripts/ifcfg-eth5
DEVICE=eth5
ONBOOT=yes
USERCTL=no
BOOTPROTO=none
MASTER=bond1
SLAVE=yes
PEERDNS=no
TYPE=Ethernet


Ifconfig shows:
##############
bond1     Link encap:Ethernet  HWaddr 00:00:00:00:00:00
          inet addr:xx.xx.xx.xx  Bcast:xx.xx.xx.127  Mask:255.255.255.128
          UP BROADCAST RUNNING MASTER MULTICAST  MTU:1500  Metric:1
          RX packets:3451982 errors:0 dropped:0 overruns:0 frame:0
          TX packets:33936 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:280649389 (267.6 Mb)  TX bytes:7757119 (7.3 Mb)


eth3      Link encap:Ethernet  HWaddr 00:00:00:00:00:00
          inet addr:xx.xx.xx.xx   Bcast:xx.xx.xx.127  Mask:255.255.255.128
          UP BROADCAST RUNNING SLAVE MULTICAST  MTU:1500  Metric:1
          RX packets:1738963 errors:0 dropped:0 overruns:0 frame:0
          TX packets:33936 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:152894258 (145.8 Mb)  TX bytes:7757119 (7.3 Mb)
          Base address:0xcc80 Memory:df5c0000-df5e0000


eth5      Link encap:Ethernet  HWaddr 00:00:00:00:00:00
          inet addr:xx.xx.xx.xx   Bcast:xx.xx.xx.127  Mask:255.255.255.128
          UP BROADCAST RUNNING NOARP SLAVE MULTICAST  MTU:1500  Metric:1
          RX packets:1713033 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:127756393 (121.8 Mb)  TX bytes:0 (0.0 b)
          Base address:0xbc80 Memory:df3c0000-df3e0000



When we ping the hosts sporadically we get duplicate packets in response to 
ICMP ping requests.

64 bytes from xx.xx.xx.xx: icmp_seq=0 ttl=63 time=0.683 ms (DUP!)

According to the ping manpage, this is something which should not 
happen: "Duplicate packets
should never occur, and seem to be caused by inappropriate link-level 
retransmissions.  


Version-Release number of selected component (if applicable):

2.4.21-27.ELsmp #1 SMP Wed Dec 1 21:59:02 EST 2004 i686 i686 i386 GNU/Linux

How reproducible: 

It occurs sporadically.


Steps to Reproduce:
1.ping 163.192.2.71
PING xx.xx.xx.xx (xx.xx.xx.xx) 56(84) bytes of data.

2.
3.
  
Actual results:
64 bytes from xx.xx.xx.xx: icmp_seq=0 ttl=63 time=0.683 ms (DUP!)


Expected results:

64 bytes from xx.xx.xx.xx: icmp_seq=0 ttl=63 time=0.670 ms

Additional info:
Comment 1 Tulio Llosa 2006-07-14 16:29:34 EDT
For some reason it created two bugs that are the same 198939 and 198941.  You 
can remove this one 198941.
Comment 2 Ernie Petrides 2006-07-17 18:51:23 EDT
This is an unintentional duplicate bug entry.

*** This bug has been marked as a duplicate of 198939 ***

Note You need to log in before you can comment on or make changes to this bug.