Bug 198976 - Selinux and squid problem
Selinux and squid problem
Status: CLOSED DUPLICATE of bug 198554
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-15 04:25 EDT by Daniel Rowe
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-17 15:49:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Rowe 2006-07-15 04:25:05 EDT
Description of problem:

With the latest updates (July 15 2006) Squid fails with this in dmesg:

audit(1152888712.465:4): avc:  denied  { name_bind } for  pid=2581 comm="squid"
src=3130 scontext=system_u:system_r:squid_t:s0
tcontext=system_u:object_r:http_cache_port_t:s0 tclass=udp_socket
audit(1152888715.757:5): avc:  denied  { name_bind } for  pid=2588 comm="squid"
src=3130 scontext=system_u:system_r:squid_t:s0
tcontext=system_u:object_r:http_cache_port_t:s0 tclass=udp_socket
audit(1152888719.029:6): avc:  denied  { name_bind } for  pid=2594 comm="squid"
src=3130 scontext=system_u:system_r:squid_t:s0
tcontext=system_u:object_r:http_cache_port_t:s0 tclass=udp_socket
audit(1152888722.301:7): avc:  denied  { name_bind } for  pid=2601 comm="squid"
src=3130 scontext=system_u:system_r:squid_t:s0
tcontext=system_u:object_r:http_cache_port_t:s0 tclass=udp_socket
audit(1152888725.573:8): avc:  denied  { name_bind } for  pid=2608 comm="squid"
src=3130 scontext=system_u:system_r:squid_t:s0
tcontext=system_u:object_r:http_cache_port_t:s0 tclass=udp_socket

Version-Release number of selected component (if applicable):

Fedord Core 5 AMD64 

squid-2.5.STABLE14-2.FC5
libselinux-python-1.30.3-4.fc5
libselinux-1.30.3-4.fc5
libselinux-devel-1.30.3-4.fc5
selinux-policy-2.2.47-3.fc5
selinux-policy-targeted-2.2.47-3.fc5
libselinux-1.30.3-4.fc5

How reproducible:

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Sitsofe Wheeler 2006-07-15 12:54:12 EDT
This looks like a dup of bug #198554
Comment 2 Martin Stransky 2006-07-17 15:49:13 EDT
Yes, it looks like bug #198554 and the message is the same...

*** This bug has been marked as a duplicate of 198554 ***

Note You need to log in before you can comment on or make changes to this bug.