Bug 198982 - aiglx+composite is enabled by default, but does not work with GForce 7600 GS
aiglx+composite is enabled by default, but does not work with GForce 7600 GS
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-15 05:48 EDT by Nicolas Mailhot
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-18 04:53:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
normal system xorg conf (3.00 KB, text/plain)
2006-07-24 10:26 EDT, Nicolas Mailhot
no flags Details
xorg log when bluescreening winth composing on in metacity (54.61 KB, text/plain)
2006-07-24 10:27 EDT, Nicolas Mailhot
no flags Details

  None (edit)
Description Nicolas Mailhot 2006-07-15 05:48:39 EDT
Description of problem:

On an x86_64 ck804 system, with a 7600 GS, nv driver in exa mode xorg
blue-screens by default in rawhide

disabling composite in xorg.conf recovers the display but kills metacity

trying to disable aiglx in serverlayout is an instant-reboot one xorg is launched

what poor nv users like me are supposed to do in the brave new aiglx world ?
Comment 1 Nicolas Mailhot 2006-07-15 08:23:35 EDT
Ok, more analysis: like a lot of people I had tried aiglx in the past before
deciding it was not for me. So I hade the use-composing entry in my metacity
settings

It was inactive for months

Then composing is forced on by default. And even after setting the composing
extension to off, metacity still tries it and crashes if it's not active.

Metacity should fallback transparently to non-composing on an xserver with
composing disabled intead of leaving the user with no window manager
Comment 2 Nicolas Mailhot 2006-07-16 13:33:59 EDT
Moving the metacity part to bug #199055 to keep only the aiglx+compose part
Comment 3 Mike A. Harris 2006-07-24 08:49:01 EDT
log+config please...
Comment 4 Mike A. Harris 2006-07-24 08:50:10 EDT
Also, are you using the 32bit OS, or 64bit x86_64 OS?
Comment 5 Nicolas Mailhot 2006-07-24 09:14:29 EDT
x86_64
Comment 6 Nicolas Mailhot 2006-07-24 10:25:16 EDT
More investigation shows the problem only occurs when the gconf key for
composing is on in metacity (apps/metacity/general/composing_manager):
- with normal xorg.conf -> blue screen in user session
- with normal xorg.conf + AIGLX off -> blue screen in user session, reboot in
gdm after trying to switch to-and-from console a few times
- with normal xorg.conf + composing off -> no blue screen, metacity dies in the
user session with:

$ metacity
Window manager warning: Log level 16: Disabling compositor since the server is
missing at least one of the COMPOSITE, DAMAGE, FIXES or TEST extensions
Erreur de segmentation
Comment 7 Nicolas Mailhot 2006-07-24 10:26:52 EDT
Created attachment 132916 [details]
normal system xorg conf
Comment 8 Nicolas Mailhot 2006-07-24 10:27:35 EDT
Created attachment 132917 [details]
xorg log when bluescreening winth composing on in metacity
Comment 9 Nicolas Mailhot 2006-07-24 10:28:51 EDT
AIGLX off is just putting Option "AIGLX" "Off" in ServerLayout

I don't have the logs for the reboot case
Comment 10 Ray Strode [halfline] 2006-07-25 16:32:09 EDT
We're going to disable the metacity compositor for FC6, but the same thing might
happen with compiz.

Have you tried compiz? Do you know if the same thing does happen?
Comment 11 Nicolas Mailhot 2006-07-25 16:42:26 EDT
Need to wait next week-end before I try something as invasive as changing the
WM, sorry
Comment 12 Joachim Frieben 2006-08-10 05:56:56 EDT
The "metacity" compositor "gconf" key never got enabled unless the user decided
deliberately to do so!
Comment 13 Adam Jackson 2006-10-03 11:14:59 EDT
Reporter, I see at least two bugs in this report:

- Disabling AIGLX in config file makes machine reboot when X starts
- Compositor (compiz now) fails aggressively on nv hardware

Are you still seeing either one of these failures?

Note You need to log in before you can comment on or make changes to this bug.