Bug 198983 - creative vibra 128 doesn`t work with linux FC5
creative vibra 128 doesn`t work with linux FC5
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: alsa-utils (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-15 06:39 EDT by andro
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-03 10:07:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
scsound.log (4.67 KB, text/plain)
2006-07-15 06:39 EDT, andro
no flags Details

  None (edit)
Description andro 2006-07-15 06:39:11 EDT
Description of problem:my creative vibra 128 sound card and it is PCI it doesn`t
work i use fc5 the syetem detect it as (Ensoniq 5880 Audio pci snd-ens1371) and
when i hit the play there is no sound i am new in linux byt when i open the
scsound.log i think there is a problem but i cant fix it . can any one hlp plz
the sound card is model is ( CT 4810 ) 
 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 andro 2006-07-15 06:39:12 EDT
Created attachment 132480 [details]
scsound.log
Comment 2 andro 2006-07-15 18:50:54 EDT
(In reply to comment #0)
> Description of problem:my creative vibra 128 sound card and it is PCI it doesn`t
> work i use fc5 the syetem detect it as (Ensoniq 5880 Audio pci snd-ens1371) and  
> when i hit the play there is no sound i am new in linux byt when i open the
> scsound.log i think there is a problem but i cant fix it . can any one hlp plz
> the sound card is model is ( CT 4810 ) i am using AMD athlon processor i have
a friend use intel processor and use the same sound card but it work good at his
pc with FC5 so is the problem in my system
>  
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
>   
> Actual results:
> 
> 
> Expected results:
> 
> 
> Additional info:

(In reply to comment #0)
> Description of problem:my creative vibra 128 sound card and it is PCI it doesn`t
> work i use fc5 the syetem detect it as (Ensoniq 5880 Audio pci snd-ens1371) and
> when i hit the play there is no sound i am new in linux when i open the
> scsound.log i think there is a problem but i cant fix it . can any one hlp plz
> the sound card is model is ( CT 4810 ) i am using AMD athlon processor i have
a friend use intel processor and use the same sound card but it work good at his
pc with FC5 so is the problem in my system 
>  
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
>   
> Actual results:
> 
> 
> Expected results:
> 
> 
> Additional info:

Comment 3 Martin Stransky 2006-07-24 08:30:14 EDT
Please check turn acpi off by adding acpi=off to the kernel command line in
grub.conf (it's a common problem so you can search in some forums)

Or you can check the latest ALSA drivers, how-to is here:
http://people.redhat.com/stransky/alsa/
Comment 4 andro 2006-07-24 08:38:07 EDT
i aslo found that there is no /dev/dsp and how can i trun acpi off
Comment 5 andro 2006-07-25 03:17:26 EDT
(In reply to comment #4)
> i aslo found that there is no /dev/dsp and how can i trun acpi off i do
something  it make the sound work 

at the /boot/config2.17.xxxx_FC5 file i edit the following
Sound
#
CONFIG_SOUND=y>>>>>it was m
# 

#
# Advanced Linux Sound Architecture
#
CONFIG_SND=y>>>>>>>>>it was m
CONFIG_SND_TIMER=y>>>>>>was m
CONFIG_SND_PCM=y>>> was m
CONFIG_SND_HWDEP=y>>>>>was m 
CONFIG_SND_RAWMIDI=y>>>>was m
CONFIG_SND_SEQUENCER=y>>>>>>was m
CONFIG_SND_SEQ_DUMMY=y>>>>>was m
CONFIG_SND_OSSEMUL=y
CONFIG_SND_MIXER_OSS=y>>>>>was m
CONFIG_SND_PCM_OSS=y>>>>>was m
CONFIG_SND_PCM_OSS_PLUGINS=y
CONFIG_SND_SEQUENCER_OSS=y
CONFIG_SND_RTCTIMER=y>>>>>>>was m
CONFIG_SND_SEQ_RTCTIMER_DEFAULT=y
CONFIG_SND_DYNAMIC_MINORS=y
# CONFIG_SND_SUPPORT_OLD_API is not set
CONFIG_SND_VERBOSE_PROCFS=y
# CONFIG_SND_VERBOSE_PRINTK is not set
# CONFIG_SND_DEBUG is not set


CONFIG_SND_ENS1371=y>>>>was m aslo


after that i reboot then it works fine excpt the the machine become very slow so
itry to return it back to its orignal state(the file i mean) and i no sound
again i try to redite it agian to make the sound work but it doesn`t work ever i
try many times to make the file  like the 1st time but noway there is no sound 
from the i think i have the right module and right driver but there is something
wrong in the system setting can anybody help plz what shall i fix in the system
Comment 6 Martin Stransky 2006-07-25 05:02:56 EDT
Don't you see in this file "# Automatically generated make config: don't edit"??
There isn'y any problem.

Just append "acpi=off" to this line in /boot/grub/grub.conf:

kernel /boot/vmlinuz-xxxx_FC5 ro root=LABEL=/ rhgb quiet

(and install kernel again if you break your /boot/config2.17.xxxx_FC5)
Comment 7 andro 2006-07-25 05:28:05 EDT
(In reply to comment #6)
> Don't you see in this file "# Automatically generated make config: don't 
edit"??
> There isn'y any problem.
> Just append "acpi=off" to this line in /boot/grub/grub.conf:
> kernel /boot/vmlinuz-xxxx_FC5 ro root=LABEL=/ rhgb quiet
> (and install kernel again if you break your /boot/config2.17.xxxx_FC5)

if i have the a copy of the orginal file shall i replace it or should i 
reinstalle the kernel
Comment 8 Martin Stransky 2006-07-25 05:30:49 EDT
restore it from backup is ok...
Comment 9 Martin Stransky 2006-08-04 16:33:15 EDT
any news here?
Comment 10 andro 2006-08-04 16:45:24 EDT
i restore the orignal copy but the sound still the same no sound . i still 
don`t have /dev/dsp and the pcm device is not work just the sound card detected
but i think there is sound thing worng in my config cuz when i edite the kernel 
file it works
Comment 11 Martin Stransky 2006-08-08 02:31:13 EDT
Please reinstall your box ond/or kernel and check the latest drivers (1.0.12r2)
from my page:
http://people.redhat.com/stransky/alsa/
Comment 12 andro 2006-09-11 06:47:41 EDT
ok sir i am back i have read tha ALSA support page and  i did the steps from 1
to 6 and reboot and it didn`t work i download alsa lib and alsa utils but the
command does not compelet and it show some errors i can`t solve this error some
i stoped
Comment 13 andro 2006-09-11 06:50:04 EDT
imean compileing command of alsa lib and alsa utils does not work and show some
errors
Comment 14 andro 2006-09-11 07:28:42 EDT
[root@localhost Desktop]# rpmbuild --rebuild alsa-utils-1.0.12-2.src.rpm
Installing alsa-utils-1.0.12-2.src.rpm
warning: user komat does not exist - using root
warning: group komat does not exist - using root
warning: user komat does not exist - using root
warning: group komat does not exist - using root
warning: user komat does not exist - using root
warning: group komat does not exist - using root
warning: user komat does not exist - using root
warning: group komat does not exist - using root
warning: user komat does not exist - using root
warning: group komat does not exist - using root
warning: user komat does not exist - using root
warning: group komat does not exist - using root
error: Failed build dependencies:
        alsa-lib-devel >= 1.0.12 is needed by alsa-utils-1.0.12-2.i386
        ncurses-devel is needed by alsa-utils-1.0.12-2.i386
        gettext-devel is needed by alsa-utils-1.0.12-2.i386
Comment 15 andro 2006-09-11 11:56:32 EDT
[root@localhost alsa-driver-1.0.12]# make install
rm -f /lib/modules/2.4.20/misc/snd*.*o /lib/modules/2.4.20/misc/persist.o
/lib/modules/2.4.20/misc/isapnp.o
make[1]: Entering directory `/home/ANDRO/Desktop/alsa-driver-1.0.12/acore'
mkdir -p /lib/modules/2.4.20/misc
cp snd-hwdep.o snd-page-alloc.o snd-pcm.o snd-rawmidi.o snd-timer.o snd.o
/lib/modules/2.4.20/misc
cp: cannot stat `snd-hwdep.o': No such file or directory
cp: cannot stat `snd-page-alloc.o': No such file or directory
cp: cannot stat `snd-pcm.o': No such file or directory
cp: cannot stat `snd-rawmidi.o': No such file or directory
cp: cannot stat `snd-timer.o': No such file or directory
cp: cannot stat `snd.o': No such file or directory
make[1]: *** [_modinst__] Error 1
make[1]: Leaving directory `/home/ANDRO/Desktop/alsa-driver-1.0.12/acore'
make: *** [install-modules] Error 1
Comment 16 andro 2006-09-13 07:12:39 EDT
[root@localhost ANDRO]# cd /home/ANDRO/Desktop/alsa-driver-1.0.11
[root@localhost alsa-driver-1.0.11]# ./configure
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for ranlib... ranlib
checking for a BSD-compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking whether time.h and sys/time.h may both be included... yes
checking whether gcc needs -traditional... no
checking for current directory... /home/ANDRO/Desktop/alsa-driver-1.0.11
checking cross compile...
checking for directory with kernel source... /lib/modules/2.6.17-1.2174_FC5/sour ce
checking for directory with kernel build... /lib/modules/2.6.17-1.2174_FC5/build
checking for kernel linux/version.h... no
The file /lib/modules/2.6.17-1.2174_FC5/source/include/linux/version.h does not
exist.
Please install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /lib/modules/2.6.17-1.2174_FC5/source).
Comment 17 Axel H. Ahlberg 2006-09-24 21:02:52 EDT
(In reply to comment #11)
> Please reinstall your box ond/or kernel and check the latest drivers (1.0.12r2)
> from my page:
> http://people.redhat.com/stransky/alsa/

I have roughly the same problem with my SB32 soundcard and tried what was
suggested, i.e. to install the latest drivers, and I get the exact same problem
shown in andro's log output.  Despite the fact that I installed the developer
version of FC5, I get that same message about the missing version.h header file.

I just went thru the update to vmlinuz-2.6.17-1.2187_FC5 from 2054 and the
problem remains, no sound and attempting to run configure to install the latest
alsa-utils gets the same log output as andro.

If there are any tests or changes you would like me to try don't hesitate to
ask.  I am an experienced software engineer but new to the Linux world.
Comment 18 andro 2006-09-26 11:23:23 EDT
i try to compile the kernel 2.6.18 after download but it give me the following
errors i go and install qt-devel and qt toolkit still have the error
   [ANDRO@localhost linux-2.6.18]$ make mrproper
  CLEAN   scripts/basic
  CLEAN   scripts/kconfig
  CLEAN   include/config
[ANDRO@localhost linux-2.6.18]$ make xconfig
  HOSTCC  scripts/basic/fixdep
  HOSTCC  scripts/basic/docproc
  CHECK   qt
*
* Unable to find the QT installation. Please make sure that
* the QT development package is correctly installed and
* either install pkg-config or set the QTDIR environment
* variable to the correct location.
*
make[1]: *** [scripts/kconfig/.tmp_qtcheck] Error 1
make: *** [xconfig] Error 2
[ANDRO@localhost linux-2.6.18]$ make menuconfig
  HOSTCC  scripts/kconfig/conf.o
  HOSTCC  scripts/kconfig/kxgettext.o
  HOSTCC  scripts/kconfig/mconf.o
  SHIPPED scripts/kconfig/zconf.tab.c
  SHIPPED scripts/kconfig/lex.zconf.c
  SHIPPED scripts/kconfig/zconf.hash.c
  HOSTCC  scripts/kconfig/zconf.tab.o
  HOSTLD  scripts/kconfig/mconf
  HOSTCC  scripts/kconfig/lxdialog/checklist.o
In file included from scripts/kconfig/lxdialog/checklist.c:24:
scripts/kconfig/lxdialog/dialog.h:31:20: error: curses.h: No such file or direct ory
In file included from scripts/kconfig/lxdialog/checklist.c:24:
scripts/kconfig/lxdialog/dialog.h:128: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘
__attribute__’ before ‘use_colors’
scripts/kconfig/lxdialog/dialog.h:129: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘
__attribute__’ before ‘use_shadow’
scripts/kconfig/lxdialog/dialog.h:131: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘
__attribute__’ before ‘attributes’
scripts/kconfig/lxdialog/dialog.h:143: error: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/dialog.h:146: error: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/dialog.h:147: error: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/dialog.h:148: error: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/dialog.h:149: error: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/dialog.h:151: error: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/checklist.c:31: error: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/checklist.c:59: error: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/checklist.c:95: error: expected ‘)’ before ‘*’ token
scripts/kconfig/lxdialog/checklist.c: In function ‘dialog_checklist’:
scripts/kconfig/lxdialog/checklist.c:117: error: ‘WINDOW’ undeclared (first use
in this function)
scripts/kconfig/lxdialog/checklist.c:117: error: (Each undeclared identifier is
reported only once
scripts/kconfig/lxdialog/checklist.c:117: error: for each function it appears in .)
scripts/kconfig/lxdialog/checklist.c:117: error: ‘dialog’ undeclared (first use
in this function)
scripts/kconfig/lxdialog/checklist.c:117: error: ‘list’ undeclared (first use in
 this function)
scripts/kconfig/lxdialog/checklist.c:117: warning: left-hand operand of comma ex
pression has no effect
scripts/kconfig/lxdialog/checklist.c:117: warning: statement with no effect
scripts/kconfig/lxdialog/checklist.c:121: warning: implicit declaration of funct
ion ‘endwin’
scripts/kconfig/lxdialog/checklist.c:122: warning: implicit declaration of funct
ion ‘fprintf’
scripts/kconfig/lxdialog/checklist.c:122: warning: incompatible implicit declara
tion of built-in function ‘fprintf’
scripts/kconfig/lxdialog/checklist.c:122: error: ‘stderr’ undeclared (first use
in this function)
scripts/kconfig/lxdialog/checklist.c:140: error: ‘COLS’ undeclared (first use in
 this function)
scripts/kconfig/lxdialog/checklist.c:141: error: ‘LINES’ undeclared (first use i
n this function)
scripts/kconfig/lxdialog/checklist.c:143: warning: implicit declaration of funct
ion ‘draw_shadow’
scripts/kconfig/lxdialog/checklist.c:143: error: ‘stdscr’ undeclared (first use
in this function)
scripts/kconfig/lxdialog/checklist.c:145: warning: implicit declaration of funct
ion ‘newwin’
scripts/kconfig/lxdialog/checklist.c:146: warning: implicit declaration of funct
ion ‘keypad’
scripts/kconfig/lxdialog/checklist.c:146: error: ‘TRUE’ undeclared (first use in
 this function)
scripts/kconfig/lxdialog/checklist.c:148: warning: implicit declaration of funct
ion ‘draw_box’
scripts/kconfig/lxdialog/checklist.c:148: error: ‘attributes’ undeclared (first
use in this function)
scripts/kconfig/lxdialog/checklist.c:149: warning: implicit declaration of funct
ion ‘wattrset’
scripts/kconfig/lxdialog/checklist.c:150: warning: implicit declaration of funct
ion ‘mvwaddch’
scripts/kconfig/lxdialog/checklist.c:152: warning: implicit declaration of funct
ion ‘waddch’
scripts/kconfig/lxdialog/checklist.c:156: warning: implicit declaration of funct
ion ‘print_title’
scripts/kconfig/lxdialog/checklist.c:159: warning: implicit declaration of funct
ion ‘print_autowrap’
scripts/kconfig/lxdialog/checklist.c:166: warning: implicit declaration of funct
ion ‘subwin’
scripts/kconfig/lxdialog/checklist.c:191: warning: implicit declaration of funct
ion ‘print_item’
scripts/kconfig/lxdialog/checklist.c:197: warning: implicit declaration of funct
ion ‘print_arrows’
scripts/kconfig/lxdialog/checklist.c:200: warning: implicit declaration of funct
ion ‘print_buttons’
scripts/kconfig/lxdialog/checklist.c:202: warning: implicit declaration of funct
ion ‘wnoutrefresh’
scripts/kconfig/lxdialog/checklist.c:204: warning: implicit declaration of funct
ion ‘doupdate’
scripts/kconfig/lxdialog/checklist.c:207: warning: implicit declaration of funct
ion ‘wgetch’
scripts/kconfig/lxdialog/checklist.c:214: error: ‘KEY_UP’ undeclared (first use
in this function)
scripts/kconfig/lxdialog/checklist.c:214: error: ‘KEY_DOWN’ undeclared (first us
e in this function)
scripts/kconfig/lxdialog/checklist.c:224: error: ‘FALSE’ undeclared (first use i
n this function)
scripts/kconfig/lxdialog/checklist.c:225: warning: implicit declaration of funct
ion ‘scrollok’
scripts/kconfig/lxdialog/checklist.c:226: warning: implicit declaration of funct
ion ‘wscrl’
scripts/kconfig/lxdialog/checklist.c:235: warning: implicit declaration of funct
ion ‘wrefresh’
scripts/kconfig/lxdialog/checklist.c:285: warning: incompatible implicit declara
tion of built-in function ‘fprintf’
scripts/kconfig/lxdialog/checklist.c:286: warning: implicit declaration of funct
ion ‘delwin’
scripts/kconfig/lxdialog/checklist.c:290: error: ‘KEY_LEFT’ undeclared (first us
e in this function)
scripts/kconfig/lxdialog/checklist.c:291: error: ‘KEY_RIGHT’ undeclared (first u
se in this function)
make[2]: *** [scripts/kconfig/lxdialog/checklist.o] Error 1
make[1]: *** [menuconfig] Error 2
make: *** [menuconfig] Error 2

can u plz help fix this error to build the kernel
Comment 19 andro 2006-09-29 14:12:29 EDT
i had recompile the kernel but still have the same problem 

ALSA lib confmisc.c:672:(snd_func_card_driver) cannot find card '0'
ALSA lib conf.c:3492:(_snd_config_evaluate) function snd_func_card_driver return
ed error: No such device
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3492:(_snd_config_evaluate) function snd_func_concat returned er
ror: No such device
ALSA lib confmisc.c:1072:(snd_func_refer) error evaluating name
ALSA lib conf.c:3492:(_snd_config_evaluate) function snd_func_refer returned err
or: No such device
ALSA lib conf.c:3961:(snd_config_expand) Evaluate error: No such device
ALSA lib pcm.c:2099:(snd_pcm_open_noupdate) Unknown PCM default
aplay: main:547: audio open error: No such device
[ANDRO@localhost ~]$ modprobe
bash: modprobe: command not found
[ANDRO@localhost ~]$ modprope
bash: modprope: command not found
[ANDRO@localhost ~]$ mod --help
bash: mod: command not found
[ANDRO@localhost ~]$ alsa
bash: alsa: command not found
Comment 20 Martin Stransky 2006-10-03 10:07:12 EDT
Please, you don't need to compile kernel. Just install it from fedora updates as
a binary package.

Please report your problem to ALSA project (www.alsa-project.org) and attach
scsound.log there. They're authors of your driver so they may help you...

Note You need to log in before you can comment on or make changes to this bug.