Bug 199001 - Workaround for libmbfl not needed with php-5.1.4
Workaround for libmbfl not needed with php-5.1.4
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: php-pecl-mailparse (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-15 11:26 EDT by Remi Collet
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-13 07:53:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Remi Collet 2006-07-15 11:26:45 EDT
Description of problem:
Not a bugg, just an information.

Version-Release number of selected component (if applicable):
php-pecl-mailparse-2.1.1
php-5.1.4

Working on the mailparse (i've missed your work), i've encountered the same
problem with the libmbfl.

Rather than using a workaround, i make a patch for PHP. This patch have been
included upstream (in php-5.1.3). So you can remove the workaround on FC5 and devel.

More information : http://bugs.php.net/bug.php?id=37103

Cordialy.
Comment 1 Matthias Saou 2006-07-24 11:37:00 EDT
Sorry, but you might want to file a bug against the php package first, since the
workaround is still required in the FC devel php-5.1.4-1 package :

[...]
/usr/src/rpm/BUILD/mailparse-2.1.1/php_mailparse.h:86:49: error: ext/mbstring/li
bmbfl/mbfl/mbfilter.h: No such file or directory
[...]

$ rpm -ql php-devel-5.1.4-1 | grep "ext/mbstring"
/usr/include/php/ext/mbstring
/usr/include/php/ext/mbstring/libmbfl
/usr/include/php/ext/mbstring/libmbfl/config.h

Thanks for the tip, tough, and please do let me know when the issue is really
fixed so that I can drop the workaround.
Comment 2 Remi Collet 2006-07-25 12:14:07 EDT
Ok, i must apologize.

My patch is only gone "partialy" in CVS, so php-5.1.4 still buggy (quite
frustrating).

I've check, php-5.2.0-dev is OK.

Do you think it's worth to file a "Fedora" bug for php to have my little patch
applied ?
Comment 3 Matthias Saou 2006-08-22 08:46:33 EDT
I doubt having the missing part of your patch in the Fedora PHP package would be
really useful. Let's just wait for the next release to be included. Do you mind
if I close this bug for now? You can simply re-open it once your fix gets its
way into the Fedora PHP package ;-)
Comment 4 Remi Collet 2006-08-22 11:25:47 EDT
Ok for me.  You can close it.

Note You need to log in before you can comment on or make changes to this bug.