Bug 199018 - kdump triggered kernel doesn't fully boot into system
kdump triggered kernel doesn't fully boot into system
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2006-07-15 14:02 EDT by Need Real Name
Modified: 2009-09-08 23:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 12:07:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-07-15 14:02:19 EDT
Description of problem:
kdump kernel never fully boots

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Installed kernel-kdump
2. /sbin/chkconfig kdump on
3. made appropriate changes to /boot/grub/grub.conf:
kernel /vmlinuz-2.6.17-1.2145_FC5smp ro root=/dev/md1 rhgb quiet crashkernel=64M@16M
(Note that I tried this with the single CPU version of the kernel too)

4. made, I think, appropriate changes to /etc/sysconfig/kdump:
KDUMP_COMMANDLINE="root=/dev/md1 init 1 irqpoll maxcpus=1"

5. rebooted.
6. echo c > /proc/sysrq-trigger

new kernel started, runs through detecting hardware, the raid partition,
mentions some ext3 fixes and then kernel panics after exec of init( ) fails.

Actual results:
No fstab.sys, mounting internal defaults
WARNING: Can't access
Exec of Init( ) failed!!!
No such file or directory
kernel panic

Expected results:
boot into kdump kernel works.

Additional info:
I've tried this with the single processor version of kernel thinking that SMP
was somehow the cause.
I've also rebuilt the mkinitrd, without success.
Comment 1 Need Real Name 2006-07-19 00:57:43 EDT
Latest kernel has this fixed:
Comment 2 Red Hat Bugzilla 2007-05-03 00:51:48 EDT
User vgoyal@redhat.com's account has been closed
Comment 3 Bug Zapper 2008-04-03 23:18:29 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 4 Bug Zapper 2008-05-06 12:07:20 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.