Bug 199031 - bugzilla logon page slow and unnecessarily delayed
bugzilla logon page slow and unnecessarily delayed
Status: CLOSED DUPLICATE of bug 214842
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
https://bugzilla.redhat.com/bugzilla/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-15 22:55 EDT by David Timms
Modified: 2013-06-23 23:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 11:57:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
2nd packet capture for retreiving the login page ethereal libpcap format (17.01 KB, application/octet-stream)
2006-07-15 22:55 EDT, David Timms
no flags Details

  None (edit)
Description David Timms 2006-07-15 22:55:44 EDT
Description of problem:
Bringing up the bugzilla logon page may occur within 2-3 seconds, but I can't
begin to login until a further ~10 seconds have passed.

Version-Release number of selected component (if applicable):

2.18 (Bugzilla Version 2.18-rh)

How reproducible: Everytime.

Steps to Reproduce:
1. go to a bug while not logged in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=198867
2. stop other network processes and start ethereal capture all
3. click Log In in the top right corner.
  
Actual results:
Log in page is retrieved and drawn immediately within 2-3 seconds, with the
mouse cursor still spinning. ~10 seconds later, the cursor changes to standard
mouse pointer as the page completes and web browser inserts it's password
auto-completion.

Expected results:
Log in page is retrieved and drawn immediately. The mouse cursor then
immediately changes to show page complete and page is ready for user entry (or
auto as the case may be). 

Additional info:
firefox-1.5.0.4-1.2.fc5 on fc5+updates {2006-07-15}
From Australia, round trip delay seems to be 0.3 seconds.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=198867

Then click Log in
ethereal trace shows: {35 packets}
first run     | repeat gw/dns need re-request|doing 
00.00 -> 00.00| 00.00 -> 00.27|dns/gw lookup   
00.00 -> 00.27| 00.54 -> 00.55|tcp syn
00.56 -> 00.57| 00.83 -> 01.45|encrypted handshake {second run 4 round trips}
00.95 -> 01.95| 01.86 -> 02.53|app data > page appears to be fully drawn - but
mouse icon still spinning
  !! no traffic for 9.37| 10.32  seconds !!
11.27 -> 11.28| 12.85 -> 12.86|application data
11.28 -> 11.29| 12.86 -> 13.14|tcp reset. mouse cursor stops spinning and
firefox password fill puts my username/password into the boxes.

The last packet before the ten second delay is from me to bugzilla (https ACK).
The next message is from bugzilla to me (with application data, but very small
packets that seem to be finalizing the connection).
Comment 1 David Timms 2006-07-15 22:55:47 EDT
Created attachment 132519 [details]
2nd packet capture for retreiving the login page ethereal libpcap format
Comment 2 David Lawrence 2008-01-22 11:57:36 EST

*** This bug has been marked as a duplicate of 214842 ***

Note You need to log in before you can comment on or make changes to this bug.